Panoramica sull'aggiornamento

Attenzione: Pagina in costruzione


Iniziare a godersi le fantastiche funzionalità dell'ultima versione di Moodle in quattro semplici passaggi.

Passo 1: Assicurarsi che il server possa eseguire Moodle 3.5

Nota: Occorre eseguire l'aggiornamento a Moodle 3.0 o versioni successive prima di eseguire l'aggiornamento a 3.5.

Andare su Amministrazione del sito > Server > Ambiente

Lo Stato è OK per tutto? Fantastico! Andare al passo 2...

Qualche problema? Probabilmente occorre aggiornare il software del server (come PHP) a una versione più recente.

Passo 2: Prepararsi

Come con qualsiasi aggiornamento di grandi dimensioni, occorre sempre essere pronti a effettuare un 'rollback' se c'è un problema con i dati o qualche codice personalizzato aggiunto.

Creare un'installazione di prova
Consigliamo vivamente di creare una copia del sito di produzione per esercitarsi prima sull'aggiornamento. In questo modo, se ci si imbatte in problemi che devono essere risolti, non si intaccherà il sito principale.
Effettuare sempre i backup
Quando si aggiorna l'istanza di produzione, assicurarsi di avere copie di tutto, per ogni evenienza. Le istruzioni complete sono disponibili su Backup del sito

Passo 3: Sostituire il codice Moodle

A questo punto è possibile sostituire il codice Moodle sul server con la versione scaricata.

Controllare i plugin
Tutti i plugin installati saranno sostituiti con una versione appropriata alla nuova versione di Moodle. Se non è ancora disponibile una versione aggiornata del plugin, sarà necessario disinstallarla prima di aggiornare il sito.

Passo 4: Eseguire l'aggiornamento

Attivare l'aggiornamento consultando la pagina di amministrazione.

Se il sito è di grandi dimensioni, l'aggiornamento potrebbe richiedere ore, consigliamo quindi l'aggiornamento via riga di comando.

Com'è andata?

Sì - ha funzionato!
Fantastico! Ripetere il processo per Moodle 3.5, e per favore scrivere un post nel forum (EN) Installing and upgrading help per condividere il successo con la Community di Moodle.
No - c'è stato un errore..
Nessun problema, l'aiuto è a portata di mano. Scrivere un post nel forum (EN) Installing and upgrading help dove i nostri esperti sono in attesa di spiegare eventuali errori ottenuti.

Per saperne di più