FAQ Aggiornamento

Attenzione: Pagina in costruzione


Come aggiorno da 1.9.x a 3.5?

1.x > 1.9.19+ > 2.2.11 > 2.7.20 > 3.0.10 > 3.5

È meglio aggiornare all'ultima versione stabile prima di passare al ramo successivo, lo stesso vale per i plugin. L'aggiornamento dai primi rami stabili di solito funziona ma non c'è alcuna garanzia.

Nella pagina dei (EN) download sono disponibili le versioni legacy - non più supportate.

Come posso aggiornare Moodle? Sovrascrivo solo i file?

NON sovrascrivere i file, poiché potrebbero causare strani errori. Leggere la documentazione sull'aggiornamento prima di procedere.

Ottengo il messaggio "Upgrade already running in this session, please wait!"

Molto probabilmente la pagina è stata aggiornata prima del messaggio di completamento. Se si è assolutamente certi che non ci siano processi di aggiornamento attivi (php e/o mysql), cliccare su "!!!" e riavviare l'aggiornamento.

Nota: : Se si clicca su "!!!" o si prova a riavviare l'aggiornamento da un altro browser, esiste la possibilità che i dati nel database possano essere danneggiati. In tal caso, sarà necessario ripristinare il database da dump sql, quindi riavviare l'aggiornamento e attendere: il processo può richiedere diverse ore sui siti di grandi dimensioni.

Posso aggiornare più di una versione alla volta?

È possibile eseguire l'aggiornamento:

  • a Moodle 3.5 da Moodle 3.0 o versioni successive.
  • a Moodle 2.7 da Moodle 2.2 o versioni successive.
  • a Moodle 2.2 da Moodle 1.9 o versioni successive.

Ho un codice personalizzato nel mio sito. Come posso aggiornarlo?

Si prega di consultare il post (EN) How to Upgrade version 2.3.1 to 2.7 del forum per alcuni suggerimenti.

Vedere anche