Notes de mise à jour de Moodle 3.10.9

De MoodleDocs

Cette version de Moodle n'est plus entièrement supportée. Généralement, seuls les correctifs de sécurité, de confidentialité des données et de pertes de données ont été intégrés dans les dernières versions de cette branche. Vous êtes encouragé à mettre à jour vers une version entièrement supportée de Moodle.

Remarque : la traduction de cette page n'est pas terminée. N'hésitez pas à traduire tout ou partie de cette page ou à la compléter. Vous pouvez aussi utiliser la page de discussion pour vos recommandations et suggestions d'améliorations.

Date de sortie : 17 janvier 2022

Vous pouvez consulter la liste des détails sur les évolutions et corrections de bogues de cette version 3.10.9 (en anglais).

Corrections et améliorations

  • MDL-69061 - Lack of files reported during upgrade to 3.9 when $CFG->admin differs from 'admin'
  • MDL-73195 - mod_url: Error makes course/view.php unreachable if an invalid URL is saved
  • MDL-72701 - Expand unit test coverage defaults
  • MDL-72785 - Impossible de supprimer une catégorie de cours

Améliorations d'accessibilité

  • MDL-70274 - The WCAG (cynthia.exe) validator links in the footer is no longer available

Pour les développeurs

  • MDL-73175 - Add behat generators for glossary entries and categories
  • MDL-73202 - Add behat generators for forum discussions and posts
  • MDL-72846 - Create default block generator for testing
  • MDL-73269 - Ajout des versions PHP et des extensions requises/optionnelles à composer.json

Amélioration de sécurité

  • MDL-72096 - New helper function for cleaning SQL ORDER BY clauses

Correction de sécurité

  • MSA-22-0002 calendar:manageentries capability allows CRUD access to all calendar events
  • MSA-22-0003 Capability gradereport/user:view not always respected when navigating to a user's course grade report
  • MSA-22-0004 CSRF risk in badge alignment deletion

Voir aussi