Notes de mise à jour de Moodle 2.7

Attention : vous consultez actuellement la documentation dédiée aux versions 2.x de Moodle. La documentation pour les versions 3.x de Moodle est consultable ici : Notes de mise à jour de Moodle 2.7.

Cette version de Moodle n'est plus supportée ! Vous devriez mettre à jour vers une version supportée de Moodle.

Remarque : cette page est la traduction d'une page de la documentation Développeur, considérée comme particulièrement importante. Elle est mise à jour fréquemment. Nous vous recommandons de consulter régulièrement son original en anglais : Moodle 2.7 release notes.

Version 2.7

Sortie : 12 mai 2014

Vous pouvez consulter les Nouvelles fonctionnalités pour un survol avec des copies d'écran.

Vous pouvez consulter la liste des détails sur les évolutions et corrections de bogues de cette version 2.7 (en anglais).

Merci beaucoup à tous les développeurs qui ont travaillé sur les correctifs et les nouvelles fonctionnalités de cette version.

Prérequis serveur

Ces versions sont les versions minimales pour assurer un fonctionnement correct ; nous vous recommandons d'utiliser des versions récentes et à jour.

  • Versions PHP : 5.4.4 minimum (utilisez toujours la dernière version 5.4.x ou 5.5.x sous Windows - http://windows.php.net/download/). PHP 7 n'est pas supporté !
  • Extensions PHP recommandées : GD (pour la conversion des images), zlib, OPcache
  • Ghostscript doit être installé pour l'annotation des fichiers PDF rendus dans les devoirs

Prérequis de base de données

Moodle supporte les bases de données suivantes. Les versions minimales sont bien les minimales supportées, il est recommandé d'utiliser les dernières versions stables de chaque logiciel !

Base de données Version minimale Version recommandée
PostgreSQL 9.1 Dernière
MySQL 5.5.31 Dernière
MariaDB 5.5.31 Dernière
Microsoft SQL Server 2008 Dernière
Oracle 10.2 Dernière

Pour Oracle 10.2, oci_native_moodle_package.sql doit être lancé avant de mettre à jour sur les serveurs Oracle.

Prérequis client

Navigateurs internet supportés

Navigateur Internet Version minimale Version recommandée Notes
Google Chrome 30.0 Dernière
Mozilla Firefox 25.0 Dernière
Apple Safari 6 Dernière
Microsoft Internet Explorer 9 Dernière IE 10 requis pour le glisser-déposer de contenu de l'extérieur du navigateur vers Moodle

Lecteurs d'écran

Nous supportons maintenant et testons deux configurations de lecteur d'écran (MDL-44002).

Navigateur Lecteur d'écran Version minimale Version recommandée
Microsoft Internet Explorer Jaws 15 Dernière
Mozilla Firefox NVDA 2014.1 Dernière

Avant de mettre à jour

Pour pouvoir mettre à jour vers Moodle 2.7, Moodle 2.2 minimum est nécessaire (si vous avez une version plus ancienne, passez d'abord à Moodle 2.2.11).

Si vous n'installez pas une version neuve de Moodle 2.7, mais réalisez une mise à jour depuis une version existante, consultez impérativement les informations de Mise à jour à Moodle 2.7 !

Nouvelles fonctionnalités majeures

Interface

  • MDL-42964 - Thèmes (nettoyage) - Moodle se focalise sur Bootstrap et un affichage adaptatif amélioré. Clean est maintenant le thème par défaut et la plupart des anciens thèmes ne sont plus en standard (mais disponibles depuis la base de données des Plugins). Plusieurs petites améliorations ont été apportées à de multiples emplacements de l'interface Moodle.
  • MDL-43786 - Nouveau thème "More" - Permet une configuration simple via l'interface utilisateur tout en profitant de l'efficacité de LESS et de l'adaptation de Bootstrap.
  • MDL-43841 - Nouvel éditeur de texte Atto - Profondément intégré dans Moodle et focalisé sur l'usage et l'accessibilité (TinyMCE toujours disponible en option)
  • MDL-44070 - Amélioration des Activités conditionnelles - Les combinaisons booléennes complexes sont maintenant supportées pour contrôler quand les ressources et activités sont disponibles aux étudiants, ainsi que des plugins de conditions et une interface améliorée. Le tout en étant plus rapide !
  • MDL-43855 - Nouvel éditeur d'équation mathématique pour Atto, produisant du TeX via une interface graphique sans nécessiter Java. Fonctionne partout, même sur tablettes et téléphones.
  • MDL-43856 - Nouveau filtre MathJax pour afficher des équations mathématiques sans nécessiter de programme supplémentaire sur le serveur.
  • MDL-44637 - Nouveaux rapports listant tous les événements possibles sur le site.

Plateforme

  • MDL-37658 - Historiques - un nouveau système d'historiques (log) avec des plugins permettant aux historiques Moodle d'être très détaillés et externalisés. Les rapports d'historique ont également été mis à jour. Beaucoup de nouveaux événements ont été ajoutés, dont les développeurs peuvent profiter. Ces améliorations permettront de meilleures analyses et l'emploi d'outils tels que TinCan.
  • MDL-25499 - Tâches planifiées - un système de programmation amélioré (comme les cron Unix) qui permet une programmation précise des tâches même sur des serveurs complexes en cluster.
  • Performance - avec des améliorations concernant les log et les tâches planifiées, ainsi que plusieurs autres améliorations, la performance globale est améliorée, notamment pour les sites importants.

Support à long terme (LTS) jusqu'à mai 2017

La plupart de nos versions bénéficient de corrections de bogues pendant un an et de corrections de sécurité et pertes de données pendant un an et demi par Moodle HQ.

Suite à une demande populaire, Moodle 2.7 aura un support de corrections de sécurité et de perte de données étendu à 3 ans (un an et demi de support supplémentaire, mais toujours un an de corrections de bogues généraux).

Si vous êtes resté bloqué sur une ancienne version comme Moodle 1.9, c'est sans doute le bon moment pour mettre à jour !

Autres nouveautés et améliorations

Administration

Activité Test et banque de questions

  • MDL-41727 - Amélioration des rapports de test.
    • Responses from all tries are available for analysis when using or "Adaptive", "Interactive with multiple tries" or similar behaviours.
    • Break-down by question variant, for question types like Calculated, STACK and Variable-numeric, which one question can have different random variants.
    • Progress bar during long calculations to prevent time-outs.
    • Low-level calculation code moved into the question component, where it could potentially be reused by other activities.
    • Much more automated testing of this complex area of code.
  • Some minor improvements to the usability of the question bank - Some of MDL-40987
    • MDL-33653 - To duplicate a question, you now start by clicking the x2 icon, like for activities.
    • MDL-33839 - The various different ways to move questions in the question bank have been rationalised.
    • MDL-33653 - There is now a 'Save changes and continue editing' button when editing questions. Useful when you are working on a complex question with the preview open in another window.
    • MDL-32729 - The interface of the question type selector has been updated
  • MDL-40313 & MDL-40457 - New plugin point, so that plugins can add columns to the question bank, or new search conditions.
  • MDL-39756 - Essay questions can now require an attachment, with the text optional, rather than the other way around.
  • MDL-27414 - Random short-answer matching question type brought back from the dead. (This was in stable branches, but worth mentioning again.)
  • MDL-43478 - Option to show all tries in responses report.

Activité Devoir

  • MDL-33952 - L'ancienne activité Devoir (2.2) a été supprimée. It has been replaced by a stub to support transparently remapping urls and restoring course backups from the old module to the new one. If you are still using the old assignment module - all instances of the old assignment module will be hidden after upgrading to Moodle 2.7. Once the upgrade tool is run on those assignments they will become visible again. It is recommended to upgrade, and then convert any remaining assignments because logic has been added to the assignment upgrade code for Moodle 2.7 to transparently map urls from the old assignment module to the new one. If you really, really need to keep using the old module, you should update the code to Moodle 2.7, and then replace the "mod/assignment" folder with the one from https://github.com/moodlehq/moodle-mod_assignment/releases before completing the upgrade.
  • MDL-28448 - Une nouvelle capacité mod/assign:editothersubmission peut être autorisée aux enseignants pour leur permettre de modifier ou supprimer les remises des élèves.
  • MDL-33600 - Une case à cocher 'Notifier les étudiants' est disponible pour contrôler quand envoyer un feedback durant le processus de notation.
  • MDL-34432 - Les enseignants peuvent maintenant commenter directement les remises d'étudiants sous forme de texte en ligne
  • MDL-42585 - Nouvelle capacité mod/assign:viewgrades permettant de voir les notes, sans forcément pouvoir les modifier
  • MDL-44268 - Assignment grading table filters
  • MDL-35373 - Word limit feature added to online assignments.
  • MDL-44629 - Assignment plugins can display an introduction.

Base de données

Forum

  • MDL-44505 - Subject line of forum notifications can now be configured through language string customisation

SCORM

  • MDL-43011 - les nouvelles fenêtres SCORM s'ouvrent maintenant sans entête et pied de page, comme attendu.

Cron

  • MDL-25499 - Cron a reçu une grosse amélioration et supporte maintenant les tâches programmées et ad-hoc.

Les bénéfices de ces changements sont :

  • La programmation de chaque tâche peut être configurée par l'administrateur
  • Les tâches peuvent fonctionner en parallèle
  • Les processus Cron utilisent un système de verrouillage pour empêcher la même tâche de fonctionner plusieurs fois en même temps par différents processus

Un résultat de ceci est que cron peut être lancé bien plus souvent, ce qui signifie (par exemple) que les messages de forums peuvent être expédiés plus tôt. Il est donc recommandé que les administrateurs augmentent la fréquence de lancement du cron chaque minute. Il est possible de garder l'ancienne fréquence, si vous ne souhaitez pas bénéficier de ces changements.

Badges

Authentification

Carnet de notes

Cours et pages

  • MDL-38923 - Les blocs peuvent être placés dans le dock en utilisant le thème Clean.
  • MDL-44269 - La barre de navigation est déplacée sous l'image du logo avec le thème Clean.

Mobile

  • MDL-44342 - Airnotifier allows notifications to be sent to MoodleMobile app.
  • MDL-30085, MDL-30106 Web services added for grades and forums.

Sécurité

  • MSA-14-0014 Injection de requêtes illégitimes par rebond dans les devoirs
  • MSA-14-0015 Problème d'expiration du jeton dans les services web pour Moodle Mobile
  • MSA-14-0016 Identité d'étudiant anonyme révélée dans les devoirs
  • MSA-14-0017 Problème d'accès aux fichiers dans les blocs HTML
  • MSA-14-0018 Fuite d'information dans les cours
  • MSA-14-0019 Injection de code indirecte dans le dépôt téléchargement d'URL

Pour les développeurs

  • Logging and events: All plugins should convert their logging and triggering of events to the new API. See dev:Migrating logging calls in plugins.
  • Rapports : les rapports utilisant la table de log devraient être mis à jour pour utiliser le nouvel environnement de log. Les anciens rapports continueront de fonctionner comme avant tant que l'ancien mode de log est activé sur le site. Voyez comment migrer l'accès aux log dans les rapports pour plus de détails.
  • Les développeurs peuvent maintenant utiliser l'API de verrouillage pour verrouiller des tâches critiques (même sur plusieurs nœuds d'un cluster).
  • Les plugins peuvent maintenant utiliser l'API des tâches pour programmer les tâches de fond et les développeurs sont encouragés à convertir à cette API leurs anciennes tâches cron.
  • Nouveau type de plugin pour les activités conditionnelles. Voir les conditions de disponibilité.
  • Nouveau type de plugin pour l'éditeur Atto. Voir le développement d'Atto
  • Nouveau type de plugin pour Logging store.

Développeurs : changements dans les API

  • MDL-39952 - Core events: All core events have been converted to the new Events API. The list of all events is available for admin in report "Events list". Writing observers to the new events is easier but old-style observers will continue to work. Moodle plans to add missing validation to core events before release of 2.7.1 (it will not affect plugins unless they directly trigger core events).
  • MDL-43040 - Les modules d'activité devraient maintenant utiliser $plugin au lieu de $module dans mod/*/version.php.
  • MDL-45250 - add_to_log() est déprécié et génère maintenant un avertissement de débogage
  • MDL-44510 - PHPUnit 4.x est maintenant supporté.
  • Nouvelle API pour augmenter la limite de temps de PHP core_php_time_limit::raise()
  • MDL-39337 - Nouvelle API html_writer::image()

Notes de mise à jour pour les développeurs

Authentication plugins 
http://git.moodle.org/gw?p=moodle.git;a=blob;f=auth/upgrade.txt;hb=master
Badges
http://git.moodle.org/gw?p=moodle.git;a=blob;f=badges/upgrade.txt;hb=master
Blog
http://git.moodle.org/gw?p=moodle.git;a=blob;f=blog/upgrade.txt;hb=master
Cache
http://git.moodle.org/gw?p=moodle.git;a=blob;f=cache/upgrade.txt;hb=master
Core
http://git.moodle.org/gw?p=moodle.git;a=blob;f=lib/upgrade.txt;hb=master
Filters
http://git.moodle.org/gw?p=moodle.git;a=blob;f=filter/upgrade.txt;hb=master
Modules
http://git.moodle.org/gw?p=moodle.git;a=blob;f=mod/upgrade.txt;hb=master
Question system
http://git.moodle.org/gw?p=moodle.git;a=blob;f=question/upgrade.txt;hb=master
Reports
http://git.moodle.org/gw?p=moodle.git;a=blob;f=report/upgrade.txt;hb=master
Tags
http://git.moodle.org/gw?p=moodle.git;a=blob;f=tag/upgrade.txt;hb=master
Themes
http://git.moodle.org/gw?p=moodle.git;a=blob;f=theme/upgrade.txt;hb=master
Webservices
http://git.moodle.org/gw?p=moodle.git;a=blob;f=webservice/upgrade.txt;hb=master

Voir aussi