Mise à jour à Moodle 2.8

Attention : vous consultez actuellement la documentation dédiée aux versions 2.x de Moodle. La documentation pour les versions 3.x de Moodle est consultable ici : Mise à jour à Moodle 2.8.

Nouveauté
Moodle
2.8
Cette page liste des informations spécifiques à la mise à jour vers Moodle 2.8. Elle doivent être utilisées en conjonction avec les informations générales de mise à jour de Moodle.

Pour passer à Moodle 2.8, vous devez impérativement avoir Moodle 2.2 ou plus récent installé ! Si vous utilisez une version plus ancienne (comme 1.9.x, 2.0.x ou 2.1.x), vous devez d'abord passer à Moodle 2.2.10 !

Attention : Nous vous recommandons très fortement de tester la mise à jour sur une COPIE de votre site de production, afin de tester que tout fonctionne comme prévu.

Attention : Cette page n'est pas entièrement mise à jour, pensez donc à revenir la consulter ultérieurement ! En attendant, nous vous conseillons la lecture de la version anglaise.

Prérequis système

Plugins et thèmes additionnels

Les différents plugins et thèmes que vous aviez installés sur votre site devront être remplacés par une version compatible avec Moodle 2.8 avant de faire la mise à jour.

  • Vérifiez dans la Base de données des plugins Moodle si une version Moodle 2.8 de vos plugins est disponible et copiez les sources dans l'arborescence de votre code Moodle.
  • La mise à jour des plugins s'effectuera en même temps que celle de Moodle.
  • S'il n'y a pas de version Moodle 2.8 de vos plugins disponibles, vous devrez désinstaller les plugins avant de mettre à jour, sinon la mise à jour risque d'échouer.

Avant de procéder à la mise à jour

ATTENTION : Le processus de mise à jour va modifier de manière irréversible le contenu de votre base de données et de votre dossier moodledata de stockage de fichiers. Si quelque chose se passe mal, vous ne pourrez pas revenir en arrière ! Il est vital que vous fassiez de bonnes sauvegardes des dossiers moodledata et de la base de données au cas où vous auriez des problèmes avec la mise à jour. Si vous n'êtes pas sûr de savoir comment faire, lisez Sauvegarde de site ou demandez dans les forums moodle.org (en expliquant quel est votre système d'exploitation).

  • Lisez les Notes de mise à jour de Moodle 2.8
  • Vérifiez que votre serveur respecte tous les prérequis nécessaires pour installer cette version de Moodle, via Administration > Serveur > Environnement.
  • Faites une sauvegarde complète de la base de données !
  • Faites une sauvegarde complète de votre dossier moodledata !
  • Sauvegardez également votre dossier moodle
  • Vérifiez vos sauvegardes soigneusement !
  • Si vous utilisez un accélérateur PHP, videz son cache (Voir la documentation de l'accélérateur PHP que vous utilisez).

Questions

Ce problème ne vous affectera probablement pas.

Vous pouvez facilement vérifier si vous devez vous inquiéter par rapport à cela en allant en bas de la page de vérification de l'environnement de votre site (à partir de Moodle 2.4.9, 2.5.5 ou 2.6.2). Si aucune ligne ne signale les questions, vous n'avez pas de problème. Si vous avez à cet endroit un message à propos des questions, vous devrez agir !

Pour donner l'historique : dans Moodle 2.1 il y a eu une mise à jour majeure des questions. Comme expliqué dans la documentation de mise à jour vers cette version, il était possible d'attendre pour mettre à jour certaines parties de la base de données. Mais avant de passer à Moodle 2.7 ou 2.8, cette mise à jour doit être effectuée !

Problèmes qui pourraient vous affecter

Si vous mettez à jour depuis Moodle 2.2, vous devriez lire les problèmes qui pourraient vous affecter dans les informations de mise à jour vers Moodle 2.3.

Consultez les détails de cette rubrique sur la version anglaise de cette page.

Suppression de DragMath

DragMath n'est plus distribué avec Moodle. Il reste disponible comme plugin tiers que l'administrateur peut installer s'il le souhaite.

Erreur MySQL dmlwriteexceptionerror exception affichée lors d'une restauration de cours

Certains utilisateurs ont l'erreur MySQL suivante qui s'affiche lors d'une restauration de cours :

 Row size too large (>8126). Changing some columns to TEXT or BLOB or using ROW_FORMAT=DYNAMIC or ROW_FORMAT=COMPRESSED may help.

Cela affecte toutes les versions de Moodle et est lié au format de fichier InnoDB par défaut (Antilope) de MySQL, qui ne peut pas gérer plus de 10 colonnes de texte. Nous vous recommandons fortement de changer le format de fichier InnoDB pour Barracuda.

Depuis Moodle 2.6, nous avons un outil pour aider les utilisateurs à effectuer cette conversion. Vous pouvez donc utiliser la commande suivante pour faire le changement :

 php admin/cli/mysql_compressed_rows.php

Vous trouverez plus d'information à propos des formats de fichiers InnoDB ici :

 http://dev.mysql.com/doc/innodb/1.1/en/glossary.html#glos_antelope
 http://dev.mysql.com/doc/innodb/1.1/en/glossary.html#glos_barracuda

Vérifier le schéma de la base de données

Si votre site Moodle a été mis à jour depuis de nombreuses versions antérieures (surtout avant 2.0), il risque d'y avoir quelques problèmes avec le schéma de la base de données (par rapport à une nouvelle installation 2.8). Cela peut entraîner l'échec de la mise à jour. Si votre site a commencé avant Moodle 2.0, vous devriez vérifier et corriger le schéma de base de données avant la mise à jour.

Vous devriez également :

Mettre à jour

Maintenant que vous avez satisfait les exigences de Moodle 2.8 suivez les instructions sur la page mise à jour de Moodle.

Sur les serveurs Linux, Moodle 2.8 prend en charge l'exécution de la mise à jour en ligne de commande, plutôt que via un navigateur Web. Ceci est susceptible d'être plus fiable, en particulier pour les grands sites.

Après la mise à jour

Le fichier config.php de votre installation 2.2, 2.3, 2.4, 2.5, 2.6 ou 2.7 devrait fonctionner correctement, mais si vous regardez le fichier config-dist.php fourni avec Moodle 2.8, vous verrez qu'il y a plus d'options (ou des options différentes) disponibles (par exemple les pilotes de base de données et paramètres). C'est une bonne idée d'adapter votre ancien fichier config.php en vous basant sur le fichier config-dist.php fourni avec Moodle 2.8.

Voir aussi