Mise à jour à Moodle 2.3

Attention : vous consultez actuellement la documentation dédiée aux versions 2.x de Moodle. La documentation pour les versions 3.x de Moodle est consultable ici : Mise à jour à Moodle 2.3.

Nouveauté
Moodle
2.3
Cette page liste des informations spécifiques à la mise à jour vers Moodle 2.3. Elle doivent être utilisées en conjonction avec les informations générales de mise à jour de Moodle.

Pour passer à Moodle 2.3, vous devez impérativement avoir Moodle 2.2 installé ! Si vous utilisez une version plus ancienne (comme 1.9.x, 2.0.x ou 2.1.x), vous devez d'abord passer à Moodle 2.2 !

Attention : Nous vous recommandons très fortement de tester la mise à jour sur une COPIE de votre site de production, afin de tester que tout fonctionne comme prévu.

Attention : Cette page sera complétée lorsque Moodle 2.3 sera sorti (ou juste un peu avant/après), pensez donc à revenir la consulter ultérieurement !

Prérequis système

  • Moodle 2.2 minimum est requis
  • PHP 5.3.2 minimum est requis (comme Moodle 2.2).
    • Extensions PHP requises : iconv, curl, ctype, zip, simplexml, spl, pcre, dom, xml, json
    • La variable PHP memory_limit doit être d'au moins 40 Mo (64 Mo ou plus recommandé si vous le pouvez)
  • Les bases de données supportées sont les suivantes :
  • Un navigateur internet récent respectant les standards de ces dernières années, par exemple :
    • Firefox 4 ou version ultérieure
    • Safari 5 ou version ultérieure
    • Google Chrome 11 ou version ultérieure
    • Opera 9 ou version ultérieure
    • MS Internet Explorer 8 ou version ultérieure

Avant de procéder à la mise à jour

ATTENTION : Le processus de mise à jour va modifier de manière irréversible le contenu de votre base de données et de votre dossier moodledata de stockage de fichiers. Si quelque chose se passe mal, vous ne pourrez pas revenir en arrière ! Il est vital que vous fassiez de bonnes sauvegardes des dossiers moodledata et de la base de données au cas où vous auriez des problèmes avec la mise à jour. Si vous n'êtes pas sûr de savoir comment faire, lisez Sauvegarde de site ou demandez dans les forums moodle.org (en expliquant quel est votre système d'exploitation).

  • Lisez les Notes de mise à jour de Moodle 2.3
  • Vérifiez que votre serveur respecte tous les prérequis nécessaires pour installer cette version de Moodle, via Administration > Serveur > Environnement.
  • Faites une sauvegarde complète de la base de données !
  • Faites une sauvegarde complète de votre dossier moodledata !
  • Sauvegardez également votre dossier moodle
  • Vérifiez vos sauvegardes soigneusement !
  • Si vous utilisez un accélérateur PHP, videz son cache (Voir la documentation de l'accélérateur PHP que vous utilisez).

Problèmes qui pourraient vous affecter

Deux modules d'activité Devoir

Un nouveau module d'activité Devoir a été ajouté dans Moodle 2.3. L'ancien existe toujours (nommé Devoir 2.2) et les sites mis à jour depuis une version plus ancienne auront donc les deux. Il est recommandé que les administrateurs mettent à jour tous les devoirs existants afin d'utiliser le nouveau module devoir aussi tôt que possible, comme décrit dans l'outils de mise à jour des devoirs, puis désactivent l'ancien module devoir, afin d'éviter la confusion entre les deux modules devoir.

Google registration required for Google Docs and Picasa plugins

Due to a change in Google's service, Moodle 2.3 has switched to a more secure and more user-friendly system for communicating with Google called 'OAuth 2.0'. As a result, any Google Docs and Picasa plugins (the Google Docs and Picasa repositories and the Google Docs and Picasa portfolios) used previously on the site will be disabled when the site is upgraded.

To re-enable these plugins, an administrator must register their site with Google, as described in Google OAuth 2.0 setup, and obtain a client ID and secret. The client ID and secret can then be used to configure all Google Docs and Picasa plugins.

Correction des thèmes de droite vers gauche

Moodle 2.3 intègre plusieurs corrections pour les thèmes de droite vers gauche (MDL-30337) et les sites utilisant de tels langues comme l'Arabe et l'Hébreux devraient faire des tests additionnels, particulièrement avec des thèmes personnalisés afin de s'assurer que tout fonctionne bien.

Vérifier le schéma de la base de données

Si votre site Moodle a été mis à jour depuis de nombreuses versions antérieures (surtout avant 2.0), il risque d'y avoir quelques problèmes avec le schéma de la base de données (par rapport à une nouvelle installation 2.2). Cela peut entraîner l'échec de la mise à jour. Si votre site a commencé avant Moodle 2.0, vous devriez vérifier et corriger le schéma de base de données avant la mise à jour.

Vous devriez également :

Mettre à jour

Maintenant que vous avez satisfait les exigences de Moodle 2.3 suivez les instructions sur la page mise à jour de Moodle.

Sur les serveurs Linux, Moodle 2.3 prend en charge l'exécution de la mise à jour en ligne de commande, plutôt que via un navigateur Web. Ceci est susceptible d'être plus fiable, en particulier pour les grands sites.

Après la mise à jour

Le fichier config.php de votre installation 2.2 devrait fonctionner correctement, mais si vous regardez le fichier config-dist.php fourni avec Moodle 2.3, vous verrez qu'il y a plus d'options (ou des options différentes) disponibles (par exemple les pilotes de base de données et paramètres). C'est une bonne idée d'adapter votre ancien fichier config.php en vous basant sur le fichier config-dist.php fourni avec Moodle 2.3.

Voir aussi