Installation de AMP

Attention : vous consultez actuellement la documentation dédiée aux versions 1.x de Moodle. La documentation pour les versions 2.x de Moodle est consultable ici : Installation de AMP et celle pour Moodle 3.x est consultable là : Installation de AMP.

Moodle est écrit dans un langage de scripts appelé PHP, et conserve la plupart des données qu'il utilise dans une base de données. Le gestionnaire de base de données que nous recommandons est MySQL. Avant d'installer Moodle, vous devez disposer d'une installation de PHP et d'un gestionnaire de base de données qui fonctionnent, de façon que votre ordinateur soit une plateforme web fonctionnelle. L'installation de tels logiciels peut être complexe. Cette page a été écrite pour essayer de rendre ce processus aussi simple que possible pour différentes plateformes :

Hôtes web

Le fonctionnement des nombreux hôtes web diffère malheureusement considérablement d'un hôte à l'autre. Certains d'entre eux seront d'accord d'installer Moodle pour vous.

La plupart vous offre une interface web (tableau de bord) vous permettant de contrôler votre site web, de créer des bases de données et de mettre en place des crons. Certains vous donnent accès à une interface terminal par ssh, de sorte que vous pouvez utiliser la ligne de commande pour effectuer des opérations.

Parcourez le Guide d'installation et effectuez les étapes décrites l'une après l'autre. Si vous êtes coincé, demandez de l'aide à votre fournisseur web.

Mac OS X

La façon la plus simple utilise l'installeur complet pour Mac OS X téléchargeable sur moodle.org : http://download.moodle.org/.

Une autre solution est d'utiliser le serveur Apache fourni par Apple, et d'y ajouter PHP et MySQL avec les paquets de Marc Liyanage. Les deux pages ci-dessous contiennent d'excellentes instructions pour l'installation, que nous n'allons pas recopier ici :

Une fois ces logiciels installés, le Guide d'installation pourra être facilement suivi.

Red Hat Linux

Vous devez installer tous les paquets RPM pour Apache, PHP et MySQL. Un paquet souvent oublié est le paquet php-mysql, nécessaire pour la communication entre PHP et MySQL.

Une fois ces logiciels installés, le Guide d'installation pourra être facilement suivi.

Une marche à suivre plus détaillée est disponible ici : RedHat Linux installation.

Windows

La façon la plus simple utilise un des installeurs complets pour Windows téléchargeable sur moodle.org : http://download.moodle.org/.

Vous pouvez aussi utiliser un paquet comme EasyPHP, qui regroupe tous les éléments logiciels nécessaires en une seule application Windows. La version EasyPHP 1.8 utilise actuellement (le 4 octobre 2006) les versions suivantes, qui ne sont pas des plus récentes :

  1. apache 1.3.33 (la version stable actuelle est la 2.2.3)
  2. php 4.3.10 (la version stable actuelle est la 5.1.6)
  3. mysql 4.1.9 (la version actuelle est la 5.0.24a)
  4. phpmyadmin 2.6.1

Voici une marche à suivre détaillée pour installer Moodle de cette façon, avec XAMPP ou avec IIS sur Windows 2003 : Installation Windows.

Windows Vista et Windows 7

Pour ceux qui rencontrent des difficultés pour installer en local les "packages for Windows" sur Vista et Windows 7, une solution simple est d'utiliser http://bitnami.org/stack/moodle (amazon.com).

Tester PHP

Lorsque vous avez installé votre serveur web et PHP, vous pouvez créer un fichier (par exemple phpinfo.php) à la racine de votre site web, contenant la simple ligne suivante

  <?phpinfo()?>

En appelant ce fichier à travers un navigateur web, grâce à l'URL http://localhost/phpinfo.php, vous devriez voir une page indiquant de nombreuses informations sur PHP, comme ceci.

Voir aussi