Environnement

Attention : vous consultez actuellement la documentation dédiée aux versions 1.x de Moodle. La documentation pour les versions 2.x de Moodle est consultable ici : Environnement et celle pour Moodle 3.x est consultable là : Environnement.

Cet article a besoin d'une mise à jour. Veuillez SVP le mettre à jour et retirer cette notice une fois la mise à jour effectuée. Si le bloc "Autres langues" (voir pied de page), comprend un lien "English", vous pouvez vous inspirer du contenu anglais.



Emplacement : Administration > Serveur > Environnement

Ce réglage permet aux administrateurs de comparer les logiciels de leur serveur avec les pré-requis minimaux pour l'hébergement d'une version particulière de Moodle avant de procéder à la mise à jour.

Note : certaines extensions de PHP sont incluses en standard dans les dernières versions de PHP, en fonction des plateformes :

  • Iconv est intégré depuis PHP 5.0 sous Windows [1]
  • Tokenizer est intégré depuis PHP 4.3.0 [2]
  • Ctype est intégré depuis PHP 4.2.0 [3]

Moodle 1.5

Moodle1.5

  • MySQL : la version 3.23 ou ultérieure est requise
  • PHP : la version 4.1.0 ou ultérieure est requise
  • L'extension php mbstring est recommandée

Moodle 1.6 et 1.7

Moodle1.6


  • MySQL version 4.1.12 ou ultérieure est requis pour les sites utilisant exclusivement l'encodage ISO-Latin-1 ; la version 4.1.16 ou ultérieure est requise lors de l'utilisation d'autres encodages ; ou sinon, PostgreSQL 7.4.x est requis
  • PHP : la version 4.3.0 ou ultérieure (ou 5.1 ou ultérieure, mais n'utilisez pas les versions 5.0.0 à 5.0.6, qui étaient fortement boguées) est requise
  • L'extension php iconv est recommandée
  • L'extension php mbstring est recommandée

Moodle 1.8

Moodle1.8


  • MySQL version 4.1.16 ou ultérieure est requis, ou PostgreSQL version 7.4 ou ultérieure
  • PHP : la version 4.3.0 ou ultérieure (ou 5.1 ou ultérieure, mais n'utilisez pas les versions 5.0.0 à 5.0.6, qui étaient fortement boguées) est requise
  • Unicode est requis
  • L'extension php curl est recommandée
  • L'extension php iconv est recommandée
  • L'extension php mbstring est recommandée
  • L'extension php openssl est recommandée
  • L'extension php tokenizer est recommandée
  • L'extension php xmlrpc est recommandée
  • L'extension php ctype est recommandée

Moodle 1.9

Moodle1.9


PHP

  • PHP : la version 4.3.0 ou ultérieure (ou 5.1 ou ultérieure, mais n'utilisez pas les versions 5.0.0 à 5.0.6, qui étaient fortement boguées) est requise
  • Paramètres PHP : Vérifiez ces paramètres dans votre fichier php.ini ou. Htaccess (si vous utilisez Apache). Pour les paramètres qui utilisent ON / OFF comme valeurs, vous pouvez remplacer 1 pour ON et 0 pour OFF si vous préférez.
    • register_globals doit être sur OFF.
    • safe_mode doit être sur OFF.
    • memory_limit devrait être au moins à 16M (32M est recommandé pour Moodle 1.7 et 40M pour Moodle 1.8 ou ultérieure). Les grands sites pourraient avoir besoin de plus de 128M. PHP 5.2.x exige des valeurs plus élevées de memory_limit que les versions précédentes de PHP. Les systèmes d'exploitation 64 bits nécessitent davantage de mémoire.
    • session.save_handler o doit être positionnée à "FILES".
    • magic_quotes_gpc doit être OFF.
    • magic_quotes_runtime doit être OFF.
    • file_uploads doit être sur ON.
    • session.auto_start doit sur OFF.
    • session.bug_compat_warn doit sur OFF.
  • Extensions et bibliothèques PHP
    • L'extension mbstring est recommandée.
    • L'extension iconv est recommandée.
    • La bibliothèque GD et la bibliothèque ainsi que les extensions FreeType 2 sont nécessaires pour être en mesure de visualiser les graphiques dynamiques que les pages de log permettent. (Le support Freetype est disponible en tant qu'extension GD pour les versions 5.x de PHP).
    • L'extension MySQL est nécessaire si vous utilisez la base de données MySQL. Notez que dans certaines distributions Linux (notamment Red Hat), il s'agit d'une installation optionnelle.
    • L'extension pgsql est nécessaire si vous utilisez la base de données PostgreSQL.
    • L'extension curl est recommandée.
    • L'extension tokenizer est recommandée.
    • Les extensions curl et openssl sont nécessaires pour la fonctionnalité de réseau Moodle.
    • L'extension xmlrpc est requise pour la fonctionnalité de réseau Moodle.
    • L'extension ctype est recommandée.
    • d'autres extensions PHP pourraient également être nécessaires.

Base de données (au choix)

  • MySQL 4.1.16,
  • PostgreSQL 8.0,
  • MSSQL 9.0,
  • Oracle 9.0.

L'une d'entre elle est requise.

Moodle 2.0

Moodle2.0


Hardware

  • Espace disque: 160 Mo min
  • Mémoire vive (RAM): 256 Mo min, 1 Go recommandé (50 utilisateurs simultanés pour 1 Go de RAM).

Software

  • Serveur Web tels que Apache ou IIS.
  • Langage de script PHP. Les exigences précises de PHP pour le fonctionnement de Moodle 2.0 sont ci-dessous.

Configuration de PHP

  • Version: 5.2.8 ou plus récent, il ne sera pas supporté de versions antérieures.
  • Paramètres PHP : vérifiez ces paramètres dans votre fichier php.ini ou .htaccess (si vous utilisez Apache). Pour les paramètres qui utilisent ON / OFF comme valeurs, vous pouvez remplacer 1 pour ON et 0 pour OFF si vous préférez.
    • register_globals doit être sur OFF.
    • safe_mode doit être sur OFF.
    • memory_limit devrait être au moins à 128M. Les grands sites pourraient avoir besoin de plus de 128M. PHP 5.2.x exige des valeurs plus élevées pour memory_limit que les versions précédentes. Les systèmes d'exploitation 64 bits nécessitent davantage de mémoire.
    • session.save_handler o doit être positionnée à "FILES".
    • magic_quotes_gpc devrait être sur OFF. Contrairement aux versions précédentes de Moodle.
    • magic_quotes_runtime doit être OFF.
    • file_uploads doit être sur ON.
    • session.auto_start doit sur OFF.
    • session.bug_compat_warn doit sur OFF.
  • Extensions et bibliothèques PHP
    • L'extension mbstring est recommandée.
    • L'extension iconv est recommandée.
    • La bibliothèque GD et la bibliothèque ainsi que les extensions FreeType 2 sont nécessaires pour être en mesure de visualiser les graphiques dynamiques que les pages de log permettent. (Le support Freetype est disponible en tant qu'extension GD pour les versions 5.x de PHP).
    • L'extension MySQL est nécessaire si vous utilisez la base de données MySQL. Notez que dans certaines distributions Linux (notamment Red Hat), il s'agit d'une installation optionnelle.
    • L'extension pgsql est nécessaire si vous utilisez la base de données PostgreSQL.
    • Les extensions PDO et PDO_SQLITE sont nécessaires pour accéder aux bases de données SQLite 3(expérimental).
    • L'extension curl est recommandée.
    • L'extension tokenizer est recommandée.
    • Les extensions curl et openssl sont nécessaires pour la fonctionnalité de réseau Moodle.
    • L'extension xmlrpc est requise pour la fonctionnalité de réseau Moodle.
    • L'extension ctype est recommandée.
    • d'autres extensions PHP pourraient également être nécessaires pour supporter des fonctionnalités optionnelles de Moodle, en particulier l'authentification externe et / ou l'inscription (par exemple l'extension LDAP pour l'authentification LDAP et l'extension sockets pour le serveur Chat).

Base de données

Un serveur de base de données MySQL ou PostgreSQL est pleinement compatible et recommandé pour une utilisation avec n'importe quelle version de Moodle. MySQL est le choix de beaucoup de gens car il est très populaire, mais il y a des arguments en faveur de PostgreSQL, surtout si vous prévoyez un déploiement à grande échelle. Sinon, sont supportés par Moodle 2.0 :

  • MySQL 5.0.25 (stockage InnoDB fortement recommandé) ou,
  • Postgres 8.3 ou,
  • MSSQL 9.0 ou,
  • Oracle 10.2,
  • SQLite 3 (expérimental).

Moodle 2.1

Moodle2.1


  • PHP 5.3.2 ou plus récent.

Voir aussi