PHP-Erweiterung ctype

Wechseln zu: Navigation, Suche

Hinweis: Sie sind auf den Seiten der Moodle 1.9 Dokumentation. Die Dokumentation der aktuellsten Moodle-Version finden Sie hier: PHP-Erweiterung ctype.

Hinweis: Ab der PHP-Version 4.2.0 beinhaltet PHP schon die Erweiterung ctype. Die manuelle Aktivierung in der php.ini ist nicht mehr erforderlich.


Wenn Sie bei älteren PHP-Versionen auf Unix die openssl-Programmbibliothek direkt in PHP einbinden wollen, gehen Sie wie folgt vor:

  1. Kompilieren Sie PHP aus dem Quellcode.
  2. Fügen Sie hierbei --enable-ctype zur Befehlsseite hinzu, bevor Sie die Befehle configure und compile absetzen.
  3. Analog kann man natürlich auch die Erweiterung ctype wieder deaktivieren. Fügen Sie hierfür --disable-ctype zur Befehlsseite hinzu, bevor Sie den Befehl configure absetzen.

Siehe auch