Difference between revisions of "Acceptance testing/Browsers/Working combinations of OS+Browser+selenium"

Jump to: navigation, search
(Working combinations of OS+Browser+selenium)
m (Moodle 3.4 and up)
Line 47: Line 47:
 
| N/A
 
| N/A
 
| Any other valid combination should work ok, normally.<br/>(Here there is a [https://github.com/SeleniumHQ/docker-selenium/releases good list] of them, as reference)
 
| Any other valid combination should work ok, normally.<br/>(Here there is a [https://github.com/SeleniumHQ/docker-selenium/releases good list] of them, as reference)
 +
|-
 +
| colspan="6"|General note: Many of the combinations below, for Moodle 3.1 and up, should continue working acceptably well for Moodle 3.4 and up. Just the ones above are actively being used now (CI infrastructure, developers...), hence, verified to be running ok. Feel free to add any other working combination above this note!
 
|}
 
|}
  

Revision as of 18:50, 14 March 2019

Working combinations of OS+Browser+selenium

As OS, Browsers and Selenium keeps updating, some combination might fail on different Moodle releases.

Following combinations have been tested at the time of release of Moodle version and will be supported for that combination.

Moodle 3.4 and up

OS Browser Selenium Server Chrome Driver IE Driver Notes
Linux - Debian Stretch Firefox 47.0.1 3.141.59 N/A N/A Requires special behat config (more info here)
Linux - Debian Stretch Chrome 66 3.11.0 2.38 N/A Any other valid combination should work ok, normally.
(Here there is a good list of them, as reference)
MacOS X Firefox 47.0.1 3.141.59 N/A N/A Requires special behat config (more info here)
MacOS X Chrome 72 3.141.59 2.46 N/A Any other valid combination should work ok, normally.
(Here there is a good list of them, as reference)
Windows Chrome 72 3.141.59 72.0.3626.69 N/A Any other valid combination should work ok, normally.
(Here there is a good list of them, as reference)
General note: Many of the combinations below, for Moodle 3.1 and up, should continue working acceptably well for Moodle 3.4 and up. Just the ones above are actively being used now (CI infrastructure, developers...), hence, verified to be running ok. Feel free to add any other working combination above this note!

Moodle 3.2 and 3.3

OS Browser Selenium Server Chrome Driver IE Driver
Linux - Ubuntu 16.04 Firefox 47.0.1 2.53.1 N/A N/A
Linux - Ubuntu 16.04 Chrome 53.0 3.0.1 2.25 N/A
Linux - Ubuntu 16.04 Phantomjs 2.1.1 2.53.1 N/A N/A
Windows 7/10 Firefox 47.0.1 2.53.1 N/A N/A
Windows 7/10 Chrome v53.0 3.0.1 2.25 N/A
MacOS X Firefox 47.0.1 2.53.1 N/A N/A
MacOS X Chrome v53.0 3.0.1 2.25 N/A

Moodle 3.1

OS Browser Selenium Server Chrome Driver IE Driver
Linux - Ubuntu 16.04 Firefox 47.0.1 2.53.1 N/A N/A
Linux - Ubuntu 16.04 Chrome 51.0 2.53.1 2.22 N/A
Linux - Ubuntu 16.04 Phantomjs 2.1.1 2.53.1 N/A N/A
Windows 7/10 Firefox 47.0.1 2.53.1 N/A N/A
Windows 7/10 Chrome v51.0 2.53.1 2.22 N/A
MacOS X Firefox 47.0.1 2.53.1 N/A N/A
MacOS X Chrome v51.0 2.53.1 2.22 N/A
MacOS X PhantomJS 2.1.1 2.53.1 N/A N/A

Moodle 3.0 and lower

OS Browser Selenium Server Chrome Driver IE Driver
Linux - Ubuntu 14.10 Firefox 42.0 2.47.1 N/A N/A
Linux - Ubuntu 14.10 Chrome 46.0 2.47.1 2.19.346067 N/A
Linux - Ubuntu 14.10 Phantomjs 2.0.0 2.47.1 N/A N/A
Windows 7/10 Firefox 41.0 2.47.1 N/A N/A
Windows 7/10 Chrome 47.0 2.47.1 2.20 N/A
MacOS X Firefox 41.0 2.47.1 N/A N/A
MacOS X Chrome 46.0 2.47.1 2.20 N/A
MacOS X Chrome 48.0 2.51.0 2.21 N/A
MacOS X PhantomJS - 2.0.0 & 2.1.1 2.48.2 N/A N/A