Настройки PHP для разных версий Moodle

Перейти к: навигация, поиск

В зависимости от версии, Moodle предъявляет следующие требования к PHP:

    • Для Moodle версии 1.4 или выше: поддерживаются PHP4 (версия 4.1.0 или выше) или PHP5 (версия 5.1.0 или выше).
    • Для Moodle версии 1.6 или выше: поддерживаются PHP4 (версия 4.3.0 или выше) или PHP5 (версия 5.1.0 или выше).
    • В версиях 2.0 и выше Moodle будет поддерживать только PHP5 (версия 5.2.8 или выше), PHP4 поддерживаться не будет.

Настройки PHP

      • safe_mode должна быть отключена (OFF, проверьте php.ini или конфигурационный файл Apache).
      • memory_limit должна иметь значение по-крайней мере 16M (32M рекомендуется для Moodle 1.7 и 40M для Moodle 1.8 или выше). Большие сайты могут потребовать более 128M. PHP 5.2.x требует больших значений memory_limit чем предыдущие версии PHP. 64bit операционные системы еще более требовательны к памяти.
      • session.save_handler должно иметь значение files.
    • Библиотеки и расширения PHP
      • mbstring обязателен для Moodle 1.6 и выше. Это расширение предназначено для работы с многобайтными строками и особенно важно для русскоязычных инсталяций.
      • iconv обязателен для Moodle 1.6 и выше.
      • библиотека GD и FreeType 2 необходимы для создания графиков, диаграмм и для построения страниц логов.
      • Расширение mysql необходимо, если вы используете MySQL.
      • Расширение pgsql необходимо, если вы используете PostgreSQL.
      • Расширение zlib необходимо для работы с архивами zip.
      • Расширение curl рекомендуется для Moodle 1.8 и выше.
      • Расширение tokenizer рекомендуется для Moodle 1.8 и выше.
      • Расширения curl и openssl необходимы для функционирования Moodle network - сетевое взаимодействия нескольких инсталяций Moodle (для Moodle 1.8 и выше).
      • Могут потребоваться другие расширения PHP, особенно если используется внешняя аутентификация и/или запись на курсы (например, расширение LDAP для аутентификации с использованием LDAP или расширение sockets для Chat-сервера).