Notas de Moodle 1.9.8

Saltar a: navegación, buscar

Fecha de la versión: 25 de Marzo de 2010

Esta página muestra información (en inglés) de las mejoras y soluciones de problemas que incorpora.

Nota especial

  • Si está utilizando algún sistema no estándar de autenticación podría experimentar problemas con las sesiones no siendo capaz de acceder al sitio. Si esto sucede, añada la siguiente línea en su fichero config.php para permitir el acceso.
$CFG->regenloginsession = false;

Destacado

  • MDL-16658 - Nuevo permiso moodle/restore:createuser para controlar cuándo un usuario puede crear usuarios al restaurar un curso.
  • MDL-21174 - La carga masiva de imágenes de usuarios ahora excluye a los usuarios borrados.
  • MDL-20125 - Nuevos ajustes para el bloque de enlaces a secciones.
  • MDL-21868 - Solucionado problema en la actualización a 1.9.7+ en MS SQL.
  • MDL-21606 - Solucionados problemas del tema "Chamaleon" en navegadores Firefox 3.6.
  • MDL-21343 - Solucionado problema algunos ajustes de la Autenticación LDAP que no eran mostrados.
  • MDL-19392 y MDL-21332 - Problemas con algunos objetos AICC
  • MDL-21045 - Las parametrización general del libro de calificaciones (letras, categorias...) ahora son incluídas en la restauración de cursos independientemente de si los usuarios han sido incluídos o no.
  • MDL-20122 - La restauración del módulo SCORM ahora retiene completamente los ajustes del mismo.
  • MDL-20819 - Solucionado problemas en la generación de estadísticas.
  • MDL-21029 - Solucionado problema en los enlaces generados por el filtro glosario.
  • MDL-20810 - Importación de preguntas al módulo HotPot solucionada.

Problemas de seguridad

  • MSA-10-0001 Vulnerabilidad en el limpiador de texto KSES
  • MSA-10-0002 Vulnerabilidad XSS en el módulo phpcas
  • MSA-10-0003 Control de acceso a nombres completos
  • MSA-10-0004 Mejorado el control de acceso en la restauración
  • MSA-10-0005 Validación incorrecta de información en formularios
  • MSA-10-0006 Inyección SQL en el módulo wiki
  • MSA-10-0007 Vulnerabilidad XSS-reflexivo en el motor de búsqueda global
  • MSA-10-0008 Vulnerabilidad XSS-persistente al utilizar la funcionalidad de "acceder como"
  • MSA-10-0009 Solucionado problema de fijado de sessión, vía ajuste que lo previene por defecto

Nuevos paquetes de idioma

  • Asturiano - Xosé Nel Caldevilla Vega
  • Zulú - iCyber E-Learning Solutions

(Vea los créditos de las traducciones para detalles adicionales)


Ver también