Notes de mise à jour de Moodle 3.1.15

Cette version de Moodle n'est plus entièrement supportée. Généralement, seuls les correctifs de sécurité, de confidentialité des données et de pertes de données ont été intégrés dans les dernières versions de cette branche. Vous êtes encouragé à mettre à jour vers une version entièrement supportée de Moodle.

Date de sortie : 12 novembre 2018

Vous pouvez consulter la liste des détails sur les évolutions et corrections de bogues de cette version 3.1.15 (en anglais).

warning.png Avertissement : Pour les sites utilisant un thème ou un formulaire de connexion personnalisé (voire une authentification SSO), depuis Moodle 3.1.15 le formulaire d'authentification doit inclure un nouveau champ de jeton de connexion (sinon la connexion sera impossible). Pour trouver des détails sur les changements requis, voir la documentation dédiée (en anglais).

Corrections et améliorations

  • MDL-63421 - Vérification de l'environnement pour les versions ne prenant pas en charge PHP 7.3

Sécurité

  • MSA-18-0020 Vulnérabilité CSRF dans le formulaire de connexion

Voir aussi