Moodle et PHP

PHP7 est sorti le 3 décembre 2015 et a apporté des améliorations de performance significatifs par rapport à PHP5. Tout le monde veut en bénéficier, mais les standards du langage ont évolué et le code écrit pour PHP5 pourrait ne pas fonctionner avec PHP7. Le cœur de Moodle et les plugins devraient adapter leur code afin de fonctionner de la même manière avec les deux versions de PHP.

Voir Détails sur Moodle et PHP 7 (en anglais) pour plus de détails sur ce qui a changé, et des recommandations pour les développeurs de plugins.

Vous pouvez également consulter les demandes ci-dessous, qui rassemblent tout ce qui a été fait sur Moodle pour apporter la compatibilité PHP. (Note : vous devez être authentifié sur le traqueur pour voir les détails)

MDL-50565 - PHP 7.0 peut être utilisé avec Moodle 3.0.1, Moodle 3.1 et les versions suivantes. C'est aussi la version minimum supportée par Moodle 3.4.

MDL-55120 - PHP 7.1 peut être utilisé avec Moodle 3.2 et les versions suivantes. C'est aussi la version minimum supportée par Moodle 3.7.

MDL-60279 - PHP 7.2 peut être utilisé avec Moodle 3.4 et les versions suivantes. C'est aussi la version minimum supportée par Moodle 3.9.

MDL-63420 - PHP 7.3 peut être utilisé avec Moodle 3.6.4, Moodle 3.7 et les versions suivantes.

MDL-66260 - PHP 7.4 peut être utilisé avec Moodle 3.8.3, Moodle 3.9 et les versions suivantes.

Voir aussi

La version anglaise de cette page