Oracle

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.3. Up-to-date documentation for the latest stable version of Moodle is probably available here: Oracle.


Moodle will technically work on Oracle, as it's supported by our database framework and it passes our basic unit testing. Some very large institutions use it successfully.

However, we do not recommend it for any new installations because it is generally slow, and hardly any core Moodle developers use it for development. Oracle support relies 100% on volunteer fixes.

Unless you are being forced somehow to use Oracle, we recommend Postgres or MariaDB for new Moodle installations.

See also