Talk:Installing Moodle on Debian based distributions

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.1. Up-to-date documentation for the latest stable version of Moodle is probably available here: Installing Moodle on Debian based distributions.

TODO Suggest that the mysql secure utility is used. I refer to it in my Amazon EC2 install page. Copy & paste from there. Mention the various extra that need to be installed php-pear etc. Test php by using a phpinfo page

"Secure MySQL server"

Debian (and Ubuntu) MySQL server installation prompts the user to set a password for MySQL root. You can see the corr. dialog in the section MySQL, commented as (set the mysql-root password). So "mysqladmin -u root password 'new-password'" thing is obsolete. Visvanath Ratnaweera 01:40, 17 February 2012 (WST)

PHP modules and phpinfo()

Yes, the list of the necessary PHP modules is incomplete.

I want to count them seperately for each Moodle version. The list for 1.9 is there, the others will come as I do a test installation for each version.

Yes, I should add the story of "phpinfo();" single liner. Will do.

Thanks for the feedback. Visvanath Ratnaweera 01:46, 17 February 2012 (WST)