Opaque question type

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.0. Up-to-date documentation for the latest stable version of Moodle may be available here: Opaque question type.


Recent versions of the Opaque question type is compatible with Moodle 2.1 and later.

The Opaque question type can be used to connect to STACK and OpenMark question engines.

Installing the Opaque question type

The Opaque question type comes in two parts: a question type, that needs to be installed into the question/type/opaque folder, and a question behaviour that needs to be installed into the question/behaviour/opaque folder.

The two projects on github:

explain how to get the code using either git clone or by downloading a zip file.

After getting the code, you need to visit the admin notification page of your Moodle to let the plugins install themselves.

Configuring the question type

After installing the plugins, go to Site administration / Plugins / Question types / Opaque and add an engine. This requires knowing the URL of the question engine you want to connect to.

Creating an Opaque question

This works just like any other question type - select 'Opaque' from the Create new question dropdown on the question bank screen.

The Opaque editing form has very few fields, since the question is mostly defined by the remote engine, we just have to say which engine to connect to, and the question id and version.

Then you can add you new question to a quiz, and try it out. Or you could just preview it.

See also