動作環境

環境から転送)
移動先: 案内, 検索

ロケーション: 「サイト管理 > サーバ > 動作環境」

動作環境ページでは、Moodleの現在および将来のバージョンのシステム要件に対して、あたたのサイトが合致しているか確認することができます。Moodleのアップグレード前にシステム要件をご確認ください。

Moodle バージョン 1.5.3

  • MySQLバージョン 3.23またはそれ以上。
  • PHPバージョン 4.1.0またはそれ以上。
  • php_extension mbstringのインストールおよび有効化をお勧めします。

Moodle バージョン 1.6

  • Latin-1のみ使用する場合、MySQLバージョン 4.1.12またはそれ以上。他の言語を使用する場合、MySQLバージョン 4.1.16、PostgreSQL 7.4.xまたはそれ以上。
  • PHPバージョン 4.3.0またはそれ以上 (バグが含まれていますので、バージョン5.0.0~5.0.6は使用しないでください)
  • php_extension iconvのインストールおよび有効化をお勧めします。
  • php_extension mbstringのインストールおよび有効化をお勧めします。

Moodle バージョン 1.8

  • MySQLバージョン 4.1.16またはそれ以上、PostgreSQL 7.4.xまたはそれ以上。
  • PHPバージョン 4.3.0またはそれ以上 (バグが含まれていますので、バージョン5.0.0~5.0.6は使用しないでください)
  • ユニコードが必須です。
  • The php_extension curlのインストールおよび有効化をお勧めします。
  • The php_extension iconvのインストールおよび有効化をお勧めします。
  • The php_extension mbstringのインストールおよび有効化をお勧めします。
  • The php_extension opensslのインストールおよび有効化をお勧めします。
  • php_extension tokenizerのインストールおよび有効化をお勧めします。

Moodle バージョン 1.9

  • MySQLバージョン 4.1.16またはそれ以上、PostgreSQL 8.0またはそれ以上。

Moodle バージョン 2.0

  • PHPバージョン 5.2.8 またはそれ以上。