Notes de mise à jour de Moodle 2.4

Attention : vous consultez actuellement la documentation dédiée aux versions 2.x de Moodle. La documentation pour les versions 3.x de Moodle est consultable ici : Notes de mise à jour de Moodle 2.4.

Cette version de Moodle n'est plus supportée ! Vous devriez mettre à jour vers une version supportée de Moodle.

Remarque : la traduction de cette page n'est pas terminée. N'hésitez pas à traduire tout ou partie de cette page ou à la compléter. Vous pouvez aussi utiliser la page de discussion pour vos recommandations et suggestions d'améliorations.

Remarque : cet article est en cours de rédaction. N'hésitez pas à le compléter. Veuillez utiliser la page de discussion ou un forum adéquat de Moodle en français pour vos recommandations et suggestions d'améliorations.


Moodle 2.4

Date de sortie : 3 décembre 2012

Vous pourrez consulter la liste des détails sur les évolutions et corrections de bogues de cette version 2.4 (en anglais).

De grand remerciements à toutes les personnes ayant travaillé sur les nouvelles fonctionnalités de cette version.

Un merci spécial à l'équipe d'intégration de Moodle HQ qui a travaillé en lien avec tous les développeurs pour relire, tester et aider à améliorer le code avant de l'intégrer dans le cœur de Moodle :

  • Eloy Lafuente
  • Sam Hemelryk
  • Dan Poltawski
  • Aparup Bannerjee

Enfin, merci à tous les testeurs de Moodle HQ et de la communauté, qui ont contribué à produire notre plus intéressante version stable !

Prérequis

  • Navigateur internet minimal recommandé : Mozilla Firefox 4, Internet Explorer 8 (IE 10 requis pour le glisser-déposer de fichier vers Moodle), Safari 5, Google Chrome 11, Opera 9
  • Versions PHP : 5.3.2 minimum. PHP 7 n'est pas supporté !
  • Versions de base de données : Postgres 8.3, MySQL 5.1.33 (MDL-33984), MSSQL 2005 ou Oracle 10.2
  • Mise à jour de Moodle : Moodle 2.2 minimum est nécessaire (si vous avez une version plus ancienne, passez d'abord à Moodle 2.2)

Note : le support d'IE8 sera abandonné après Moodle 2.5 (juin 2013). Cela signifie qu'IE8 fonctionnera probablement encore avec Moodle 2.6, mais les développeurs ne seront pas tenus de tester leur nouveau code sur ce navigateur. Moodle, comme la plupart des sites web du monde et des producteurs de navigateur, vous encourage à mettre à jour vos navigateurs internet pour améliorer la sécurité et les fonctionnalités, tout en nous épargnant un temps précieux. Voyez par exemple ce que Google fait.

Nouvelles fonctionnalités majeures

Améliorations de performance

Plusieurs améliorations ont été faites afin d'améliorer les performances de différentes manières. Certaines demandent une configuration par l'administrateur pour en tirer partie mais utilisées correctement, elles peuvent permettre de tirer meilleure partie de votre matériel pour plus de vitesse et d'étudiants.

  • MDL-33018 - Nouvel index de contexte pour améliorer largement les performances système sur les grosses installations PostgreSQL.
  • MDL-30643 - Amélioration des performances des statistiques quotidiennes, qui devrait avoir un impact surtout pour les gros sites.
  • MDL-33017 - Significant size reduction of navigation widget.
  • MDL-25290 - Création d'un "Cache Moodle Universel" (MUC) au coeur de Moodle.
  • MDL-34343 - Cache des méta-informations de base de données.
  • MDL-34399 - Cache des éléments liés aux questions.
  • MDL-36211 - Améliorations de performances en ne verrouillant pas les sessions des visiteurs anonymes et non authentifiés.

Ces résultats montrent les résultats par défaut, sans réglages spécifiques ni ajout d'éléments utilisant MUC (qui devraient encore améliorer les choses).

Base de données (-19.2%) Temps nécessaire (-4.1%) Fichiers inclus (-4.5%)
24release database usage.png 24release time used.png 24release files included.png
Kilo Octets téléchargés (-15.2%) Taille de session (+5.1%) Appels getstring() (-12.5%)
24release kilobytes downloaded.png +0,91 Ko par utilisateur (+5,1%) 24release getstring calls.png

Mise à jour des plugins depuis Moodle

Plugins de format de cours

Moodle a toujours supporté l'utilisation de plusieurs formats de cours, mais maintenant les développeurs ont encore plus de flexibilité qu'avant. Les formats de cours peuvent fournir leur propres paramètres pour les cours et sections, et avoir plus de contrôle sur toutes les pages d'un cours Moodle.

Nous espérons que la communauté créera d'intéressants formats de cours dans le futur. (Notez que dans Moodle 2.4, les formats de cours standards n'ont pas été modifiés).

Icônes

Les icônes par défaut utilisées pour les activités et les actions d'édition ont été mises à jour pour la première fois depuis Moodle 1.0. Elles ne sont pas seulement un peu plus grosses et colorées, elles sont au format SVG et supportent tout changement de taille sur tout périphérique, en conservant toujours un bel aspect. Développeurs : consultez Icônes Moodle 2.4.

Thèmes

  • MDL-34299 - Toutes les pages sont maintenant délivrées avec le type HTML5 par défaut. Ceci permet d'améliorer l'utilisabilité, d'ajouter de nouvelles fonctionnalités, de permettre aux développeurs d'utiliser des balises iframe fiables au lieu de bricoler avec l'incorporation d'objets, de simplifier le code JavaScript grâce aux attributs, etc.
  • MDL-36487, MDL-36481 - Amélioration de la compatibilité avec Internet Explorer 8 à 10.
  • MDL-34915 - SimpleYUI permet un style de code analogue JQuery ; il est spécifiquement destiné aux concepteurs de thèmes.
  • Multiples corrections et améliorations pour les langues écrites de droite à gauche.
  • MDL-36544 - Suppression des directives spéciales border-radius des blocs de description de cours/site, dans le thème standard.
  • MDL-34257, MDL-31365 - New 'secure' page layout type, for use with the quiz's 'Full screen pop-up with some JavaScript security' setting. Si vous ne mettez pas à jour votre thème vous pourriez avoir des problèmes

Amélioration de l'intégration de l'éditeur TinyMCE

L'intégration de l'éditeur TinyMCE a été largement améliorée :

  • MDL-33041 - Support configurable de plugins permettant d'étendre les possibilités de l'éditeur standard TinyMCE.
  • MDL-35172 - Nouveaux paramètres de l'éditeur TinyMCE permettant à l'administrateur de paramétrer la barre d'outils, activer/désactiver les icônes telles que l'insertion d'équation et d’émoticône.
  • MDL-35955 - Support du correcteur orthographique intégré au navigateur internet.
  • MDL-34875 - Autres corrections et améliorations mineures.

(Développeurs, voyez Plugins TinyMCE)

Améliorations des inscriptions

  • MDL-31437 - Cohorts can now be synchronised to course groups!
  • MDL-35071 - Completely reworked support for enrolment restore, fully implemented in manual, self, cohort and database plugins.
  • MDL-35064 - Option de passer les utilisateurs en inscription manuelle lors de la désinstallation de leur méthode d'inscription.
  • MDL-35062, MDL-35063 - New configurable expiration action in self and manual enrolment plugins.
  • MDL-28980, MDL-35843 - Pending expiration notification in self and manual enrolment plugins.
  • MDL-23875 - Self enrolment can be restricted to cohort members.
  • MDL-35061 - Plus de champs personnalisés dans la table d'inscription.
  • MDL-34696 - Autres corrections et améliorations mineures.

Intégration de calendriers externes

La fonctionnalité qui avait le plus de votes dans le traqueur est en place !

Support complet des noms de fichier Unicode dans les archives Zip

  • MDL-33710 - Moodle créé des archives Zip valides avec des noms de fichier Unicode.
  • MDL-33753 - Moodle extrait depuis la plupart des archives Zip avec des noms de fichier Unicode.

Notez que la fonction intégrée zip/unzip de Windows n'est pas compatible Unicode. Il est possible d'extraire les zips Windows si vous définissez la même langue dans Moodle et Windows. Windows ne peut pas extraire des fichiers depuis des archives Zip avec des noms de fichier Unicode, utilisez plutôt d'autres outils tels que 7-Zip, WinZip ou WinRar.

Amélioration du module Devoir

Un nombre significatif - et attendu - d'améliorations du module Devoir ont été apportées :

  • MDL-31284 - Devoir de groupe - Il est maintenant possible de définir un devoir sur lequel un groupe travaillera de façon collaborative, et recevra une évaluation commune (ou individuelle).
  • MDL-31291 - Évaluation anonyme (sans connaitre l'identité de l'étudiant lors de l'évaluation) - les noms des étudiants sont remplacés par des nombres aléatoires.
  • MDL-31295 - Submission date extensions - Teachers can set a cut-off date (and time) beyond which submissions will no longer be accepted. They can also grant extensions for those who miss the deadline.
  • MDL-31288 - Submission statement - It will be possible to set a submission statement so students have to check a box promising their work is original before submitting it.
  • MDL-31276 - Offline marking - Teachers can download all assignments plus the grading sheet, view, grade and give feedback offline and then upload back to Moodle and have the grades/files/comments transferred into Moodle's gradebook.

Autres éléments importants

Améliorations du module Atelier

  • MDL-36135 Full support for alternative grading evaluation methods.
  • MDL-26349 Final grades are displayed to workshop participants when the activity is closed.
  • MDL-35421 Ability to define a conclusion text to be displayed to workshop participants when the activity is closed.
  • MDL-36209 Teachers can assess submissions in the grading evaluation phase without the need to switch to the assessment phase.

Autres éléments

Sécurité

Tous les correctifs de sécurité intégrés dans les versions 2.2.x et 2.3.x ont été intégrés dans cette version 2.4.

Développeurs : changements dans les API

Les descriptions abrégées des changements dans les API sont toujours conservées à jour dans un fichier "upgrade.txt" de chaque plugin. Nous faisons cela afin d'être certain que l'information soit exacte par rapport à la version utilisée. Les changements de cette version sont :

Core
http://git.moodle.org/gw?p=moodle.git;a=blob;f=lib/upgrade.txt;hb=master
Authentication Plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=auth/upgrade.txt;hb=master
Backup
http://git.moodle.org/gw?p=moodle.git;a=blob;f=backup/upgrade.txt;hb=master
Calendar
http://git.moodle.org/gw?p=moodle.git;a=blob;f=calendar/upgrade.txt;hb=master
Course formats
http://git.moodle.org/gw?p=moodle.git;a=blob;f=course/format/upgrade.txt;hb=master
Enrolment plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=enrol/upgrade.txt;hb=master
TinyMCE plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=lib/editor/tinymce/upgrade.txt;hb=master
Activity modules
http://git.moodle.org/gw?p=moodle.git;a=blob;f=mod/upgrade.txt;hb=master Voir aussi Icônes Moodle 2.4 pour plus d'informations sur les nouvelles icônes.
Chat module
http://git.moodle.org/gw?p=moodle.git;a=blob;f=mod/chat/upgrade.txt;hb=master
Quiz access rules
http://git.moodle.org/gw?p=moodle.git;a=blob;f=mod/quiz/accessrule/upgrade.txt;hb=master
Portfolio plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=portfolio/upgrade.txt;hb=master
Question format plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=question/format/upgrade.txt;hb=master
Question types
http://git.moodle.org/gw?p=moodle.git;a=blob;f=question/type/upgrade.txt;hb=master
Repository plugins
http://git.moodle.org/gw?p=moodle.git;a=blob;f=repository/upgrade.txt;hb=master
Tags
http://git.moodle.org/gw?p=moodle.git;a=blob;f=tag/upgrade.txt;hb=master
Themes
http://git.moodle.org/gw?p=moodle.git;a=blob;f=theme/upgrade.txt;hb=master

Changements dans les API centrales

  • MDL-36145 - Dernière version YUI 3.7.3, incluant le support d'IE 10.
  • MDL-34741 - L'intégration personnalisée de YUI2 a été remplacée par 2in3. Les anciens codes doivent être adaptés pour utiliser les modules YUI3, les dépendances 2in3 ou SimpleYUI.
  • MDL-31973 - Component field in group_members table. Group membership can be linked to other plugins.
  • MDL-8249 - Amélioration de l'API pour la traduction et la personnalisation des rôles. Voir http://git.moodle.org/gw?p=moodle.git;a=blob;f=enrol/upgrade.txt;hb=master
  • MDL-34960 - Abandon du support de l'API Google Maps V2, remplacé par la V3.
  • MDL-35218 - Amélioration des fonctions liées aux cours.
  • MDL-35506 - PostgreSQL annule les transactions en cas d'erreur
  • MDL-34648 - Une nouvelle capacité a été ajoutée pour contrôler le déplacement de section dans un cours
  • MDL-31926 - The function obfuscate_mailto allows a link to include a subject
  • Dernières versions de librairies tiers : ADOdb 5.17, Flowplayer 3.2.14, phpMailer 5.2.1, TCPDF 5.9.181.

Changements dans les API de plugins

  • MDL-34270 - La possibilité d'ajouter des blocs aux pages Mon Moodle et aux pages de cours est maintenant contrôlée par des capacités.
  • MDL-17444 - Local plugins now have backup and restore hooks
  • MDL-27799 - Question type constants have been removed from the question import/export code

Tests unitaires

Les tests unitaires sont maintenant requis dans la plupart des demandes d'évolution.

  • MDL-36701 - Composer dependency manager support.
  • MDL-33180 - Le support de SimpleTest est abandonné, utilisation de PHPUnit en remplacement.
  • MDL-35479 - New debugging support in PHPUnit tests - simplified testing of code that uses debugging().
  • MDL-36031 - Message redirection in PHPUnit tests - simplified testing of code that sends messages.
  • MDL-36703 - Basic enrolment support in data generator.
  • Plus de tests unitaires pour les cohortes, les inscriptions et d'autres éléments...

Plugins d'authentification

  • MDL-34685 Les plugins d'authentification peuvent mettre en place des champs de formulaires personnalisés.

Voir aussi