Upgrading FAQ

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.5. Up-to-date documentation for the latest stable version of Moodle may be available here: Upgrading FAQ.

Notice: Moodle Docs will be switched to read-only mode starting on Tuesday 17 October 14:00 UTC for server maintenance. The estimated read-only period should not take more than 24 hours.

How do I upgrade from 1.9 to 2.5?

1.9.x -> 1.9.latest -> 2.2.latest -> 2.5

(It is better to upgrade to latest current stable before going to next branch, the same for add-on plugins; upgrading from early stable branches usually works but there is no guarantee.)

How do I upgrade Moodle? Do I just overwrite the files?

Do NOT overwrite files, as it may cause strange errors. Read the Upgrading documentation before proceeding.

I obtain the message "Upgrade already running in this session, please wait!"

Most likely you refreshed the page before the completion message. If you are absolutely sure that there are no upgrade processes active (php and/or mysql), you can click on "!!!" and restart the upgrade.

Note: If you click on "'!!!" or try to restart the upgrade from another browser, there is a chance that your data in the database could be corrupted. If this happens, you will need to restore the database from sql dump and then restart the upgrade and wait - the process can take several hours on large sites.

Can I upgrade more than one version at a time?

You can only upgrade to Moodle 2.5 from Moodle 2.2.

You can only upgrade to Moodle 2.2 from Moodle 1.9 or later.

For information on upgrading from versions of Moodle prior to 1.9, see the section 'Upgrading more than one version' in the Moodle 2.2 documentation Upgrading.

See also