Hinweis: Sie sind auf den Seiten der Moodle 2.5 Dokumentation. Die Dokumentation der aktuellsten Moodle-Version finden Sie hier: Aktualisierung von Moodle.

Aktualisierung von Moodle: Unterschied zwischen den Versionen

Aus MoodleDocs
Wechseln zu:Navigation, Suche
K (Tipp-Fehler korrigiert)
Zeile 1: Zeile 1:
 
{{Installation}}
 
{{Installation}}
  
'''Bevor Sie irgend etwas anderes tun, lesen Sie den Artikel [[Auf Moodle 2.2 aktualisieren]].'''
+
Dieser Artikel beschreibt, wie Sie Moodle aktualisieren. Eine Übersicht über die einzelnen Schritte finden Sie unter [[Aktualisierung in Kürze]].
 
Moodle ist so konzipiert, dass man das System einfach und problemlos von einer Version auf die nächste aktualisieren kann. Die Vorgehensweise ist folgende:
 
*[[Sicherung der Moodle-Installation]]
 
*Ersetzen der alten Moodle-PHP-Skripte durch die neuen.
 
*Als Administrator/in auf der Seite ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Mitteilungen'' den Aktualisierungsprozess anstoßen.
 
 
 
In diesem Artikel werden die einzelnen Schritte einer Aktualisierung detailliert beschrieben.
 
 
 
Manchmal muss man Besonderheiten beachten, wenn man auf eine bestimmte Moodle-Version aktualisiert. Informationen dazu finden Sie auf der [https://docs.moodle.org/dev/Releases Release Page]. Wenn Sie zusätzliche Plugins installiert oder Codeanpassungen vorgenommen haben, müssen Sie ebenfalls sorgfältig vorgehen.
 
 
 
Wenn Sie Moodle über das cpanel aktualisieren, beachten Sie folgendes [http://ic.eflclasses.org/tutorials/howtoupgrademoodlewithcpanel.swf Video]. Es ist nicht mehr aktuell, kann aber dennoch einen groben Einblick geben.
 
 
 
 
 
==Bevor Sie Ihre Produktiv-Installation aktualisieren==
 
Wir empfehlen dringend, eine Kopie Ihrer aktuellen Installation auf einem anderen Server zu erstellen (siehe [[Moodle Migration]]) und die Aktualisierung dort testweise durchzuführen. Wenn Sie diesen Weg nicht gehen wollen, stellen Sie wenigstens sicher, dass Sie gute [[Sicherung der Moodle-Installation|Sicherungen]] haben. Wenn die Aktualisierung schief geht, benötigen Sie die Sicherungen, um Ihr altes Moodle wiederherzustellen.
 
  
 
==Voraussetzungen prüfen==
 
==Voraussetzungen prüfen==
 +
Prüfen Sie die Systemanforderungen für die Moodle-Version 2.5 unter Block ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Server > [[Serverinformationen]]''.
  
Nehmen Sie sich die Zeit und lesen Sie noch einmal den Artikel [[Installation von Moodle]]. Prüfen Sie die Systemanforderungen für die Moodle-Version, auf die Sie aktualisieren möchten, unter Block ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Server > [[Serverinformationen]]''.
+
'''Hinweis''': Beachten Sie, dass Sie nur von Moodle 2.2. oder neueren Versionen auf Moodle 2.5 aktualisieren können. Wenn Ihr Moodle älter ist als 2.2, dann müssen Sie erst auf [https://docs.moodle.org/22/de/Auf_Moodle_2.2_aktualisieren Moodle 2.2. aktualisieren].
  
==Wartungsmodus aktivieren==
+
==Bevor Sie Ihr Produktivsystem aktualisieren==
Bevor Sie mit der Aktualisierung beginnen, schalten Sie die Moodle-Site in den [[Wartungsmodus]], um zu verhindern, dass sich Nutzer/innen anmelden.
+
'''Wir empfehlen Ihnen dringend, die Aktualisierung auf einer Kopie Ihres Produktivsystems zu testen, um sicherzustellen, dass alles wie gewünscht funktioniert.'''
  
 
==Wichtige Daten sichern==
 
==Wichtige Daten sichern==
Zeile 37: Zeile 23:
 
'''Tipp''': Prüfen Sie auch, ob Sie Ihre Sicherungen wiederherstellen können, sonst nützen sie nichts!
 
'''Tipp''': Prüfen Sie auch, ob Sie Ihre Sicherungen wiederherstellen können, sonst nützen sie nichts!
  
==Neue Moodle-Software installieren==
+
==Wartungsmodus aktivieren==
Die Aktualisierung von Moodle kann ein ganz einfacher, aber auch ein komplizierterer Prozess sein. Wenn Sie keine zusätzlichen Plugins haben und z.B. von Moodle 2.x.1 auf Moodle 2.x.3 aktualisieren, sollte dies ohne Probleme funktionieren. Dennoch sollten Sie auch in diesem Fall alle relevanten Daten sichern.
+
Bevor Sie mit der Aktualisierung beginnen, schalten Sie die Moodle-Site in den [[Wartungsmodus]], um zu verhindern, dass sich Nutzer/innen anmelden.
 +
 
 +
==Prüfen Sie, ob es Aktualisierungen für Ihre Plugins gibt==
 +
Wenn Sie die [[Automatische Aktualisierungen|Automatische Aktualisierung]] aktiviert haben, dann können Sie die installierten Plugins automatisch während der Aktualisierung von Moodle aktualisieren. Prüfen Sie auf der Seite ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Plugins > Übersicht'', ob Aktualisierungen vorhanden sind.
 +
 
 +
Wenn Sie Plugins manuell aktualisieren, dann ist es ein guter Zeitpunkt zu prüfen, ob es eine Moodle 2.6 Version für die Plugins gibt, die Sie früher auf Ihrer Moodle-Site installiert haben. Wenn das der Fall ist, laden Sie diese neue(n) Plugin-Version(en) herunter, kopieren Sie sie an die richtige Stelle im Moodle-Code-Verzeichnis (siehe [[Plugins installieren]]).  
 +
 
 +
Die Aktualisierung des Plugins erfolgt dann im Verlauf der Aktualisierung von Moodle.
 +
 
 +
Wenn ein veraltetes Plugin den Abbruch der Aktualisierung verursacht, dann löschen Sie den entsprechenden Code direkt auf dem Moodle-Server, anstatt das Plugin in Moodle zu deinstallieren.
 +
 
 +
== Neue Moodle-Version installieren ==
 +
Laden Sie sich das Moodle 2.5 Paket von[http://download.moodle.org herunter oder verwenden Sie den Befehl
  
'''Achtung''': Überschreiben Sie niemals eine alte Installation, wenn Sie nicht genau wissen, was Sie da tun! Am besten, Sie benennen Ihr altes [[Moodle-Verzeichnis]] (wo die PHP-Skripte von Moodle gespeichert sind) um und legen ein neues, leeres Verzeichnis mit dem alten Namen an.
+
    wget http://sourceforge.net/projects/moodle/files/Moodle/stable25/moodle-latest-25.tgz
  
 
=== Standardpaket verwenden ===
 
=== Standardpaket verwenden ===
Laden Sie sich das [http://download.moodle.org/ aktuellste Standardinstallationspaket] herunter.
+
* Benennen Sie das alte Moodle-Verzeichnis um (z.B. ''/moodle'' -> ''/moodleold'').
* Aktivieren Sie den [[Wartungsmodus]].
+
* Entpacken Sie den neuen Code und kopieren Sie ihn in das Verzeichnis, in dem die alten Moodle-Skripte vorher lagen (z.B. ''/moodle'').
* Benennen Sie das alte Moodle-Verzeichnis um (z.B. ''/moodle'' -> ''/moodleold''), und entpacken Sie den neuen Code und kopieren Sie ihn in das Verzeichnis, wo die alten Moodle-Skripte vorher lagen (z.B. ''/moodle'').
 
 
* Kopieren Sie Ihre alte [[Moodle-Konfigurationsdatei]] ''config.php'' zurück ins Moodle-Verzeichnis (z.B. ''/moodle'').
 
* Kopieren Sie Ihre alte [[Moodle-Konfigurationsdatei]] ''config.php'' zurück ins Moodle-Verzeichnis (z.B. ''/moodle'').
 
* Wenn Sie zusätzliche Plugins installiert hatten, laden Sie die entsprechenden neuen Versionen herunter und entpacken Sie diese in den passenden Verzeichnissen (siehe [[Plugins installieren]]). Stellen Sie sicher, dass die Versionen der Plugins zur neuen Moodle-Version passen.
 
* Wenn Sie zusätzliche Plugins installiert hatten, laden Sie die entsprechenden neuen Versionen herunter und entpacken Sie diese in den passenden Verzeichnissen (siehe [[Plugins installieren]]). Stellen Sie sicher, dass die Versionen der Plugins zur neuen Moodle-Version passen.
* Gehen Sie auf die Seite ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Mitteilungen'', um den Aktualisierungsprozess anzustoßen.
+
* Kopieren Sie Ihr [[Moodle-Datenverzeichnis]].
* Nach erfolgreicher Aktualisierung schalten Sie den Wartungsmodus wieder aus, damit sich Ihre Nutzer/innen wieder anmelden können.
+
 
 +
Unter Linux würden diese Schritte so aussehen:
 +
 
 +
Moodle-Verzeichnis umbenennen und neuen Code entpacken:
 +
    mv moodle moodle.backup
 +
    tar xvzf moodle-2.5.tgz
 
   
 
   
 +
Alte Moodle-Konfigurationsdatei kopieren und zusätzliche Plugins kopieren:
 +
    cp moodle.backup/config.php moodle
 +
    cp -pr moodle.backup/theme/mytheme moodle/theme/mytheme
 +
    cp -pr moodle.backup/mod/mymod moodle/mod/mymod
 +
 +
Die Moodle-Konfigurationsdatei für den Webserver lesbar machen:
 +
    chmod 740 admin/cli/cron.php (some configurations need chmod 750 or chmod 755)
 +
 
=== Git verwenden===
 
=== Git verwenden===
  
 
Sie können auch das [[Git für Administratoren|Git]] verwenden, um Moodle zu aktualisieren.  
 
Sie können auch das [[Git für Administratoren|Git]] verwenden, um Moodle zu aktualisieren.  
  
==Aktualisierte Version testen==
+
===Aktualisierung von Kommandozeile===
 +
 
 +
Sie können Moodle auch [[Administration über Kommandozeile|von der Kommandozeile aktualisieren]].
 +
 
 +
==Aktualisierung abschließen==
 +
Jetzt müssen Sie noch den eignetlichen Aktualisierungsprozess in Moodle anstoßen. Gehen Sie dazu auf die Seite ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Mitteilungen''.
 +
 
 +
Moodle erkennt automatisch, dass eine neuere Version auf den Server hochgeladen wurde und startet die Aktualisierung der [[Moodle-Datenbank]] und des [[Moodle-Datenverzeichnis]]ses. Wenn irgendetwas nicht automatisch aktualisiert werden kann, sehen Sie entsprechende Hinweise und Anleitungen, was Sie tun sollen.
 +
 
 +
Wenn alles erfolgreich und ohne Fehlermeldungen durchläuft, dann können Sie mit Ihrer neuen Moodle-Version sofort loslegen!
 +
 
 +
'''Hinweis''': Wenn Sie mit mehreren Servern arbeiten, dann sollten Sie nach der Aktualisierung auf allen Servern den Cache löschen: Klicken Sie dazu im Block  ''[[Einstellungen-Block|Einstellungen]] > Website-Administration > Entwicklung > Cache löschen''.
 +
 
 +
===Fatal error: Maximum execution time of 30 seconds exceeded...===
 +
Wenn Sie neben dem englischen Sprachpaket weitere Sprachpakete verwenden, dann kann dieser Fehler auftreten, weil die Aktualisierung des Sprachpakets zu lange dauert. In diesem Fall erhöhen Sie inder PHP-Konfigurationsdatei ''php.ini'' den Wert <pre>max_execution_time = 160</pre>. Dann haben die Moodle-Skripte genügend Zeit, die Sprachpakete zu aktualisieren.
 +
Alternativ können Sie Ihre Moodle-Site vor der Aktualisierung auf englisch umstellen und danach wieder auf die gewünschte Sprache zurückstellen. Siehe dieser Diskussionsbeitrag auf moodle.org: https://moodle.org/mod/forum/discuss.php?d=119598.
  
Wenn Sie prüfen möchten, ob das Datenbank-Schema Ihrer aktualisierten [[Moodle-Datenbank]] mit dem Datenbank-Schema einer Neuinstallation übereinstimmt, dann finden Sie nähere Informationen dazu im Artikel [[Datenbank-Schema prüfen]].
+
==Nach der Aktualisierung==
 +
Die Moodle-Konfigurationsdatei ''config.php'' sollte gut funktionieren. Wenn Sie sich jedoch die mitgelieferte Konfigurationsdatei ''config-dist.php'' ansehen, dann finden Sie dort weitere/andere Optionen (z.B. Datenbanktreiber und -einstellungen). Es ist eine gute Idee, die neuen Werte aus der ''config-dist.php'' in Ihre ''config.php'' zu übernehmen.
  
==Mehrere Versionen bei der Aktualisierung überspringen==
+
==Mögliche Probleme in Moodle 2.5==
Normalerweise können Sie von einer Moodle-Version auf eine beliebige neuere Version aktualisieren, z.B. von 2.0 auf 2.1 oder von 1.9 auf 2.2.
+
{{Neu}}
 +
===Einstellungen-Block===
 +
{{Zum Übersetzen}}
 +
 
 +
===Moodle 2.3 und 2.4 Verbesserungen===
 +
Je nachdem, von welcher Moodle-Version aus Sie auf Moodle 2.5 aktualisieren, empfehlen wir die entsprechenden Abschnitt "Mögliche Probleme in Moodle 2.x" in der jeweiligen Dokumentation zu lesen:
 +
* [https://docs.moodle.org/23/de/Aktualisierung_von_Moodle#Mögliche_Probleme_in_Moodle_2.3 Auf Moodle 2.3 aktualisieren]
 +
* [https://docs.moodle.org/24/de/Aktualisierung_von_Moodle#Mögliche_Probleme_in_Moodle_2.4 Auf Moodle 2.4 aktualisieren]
 +
 
 +
==Von Moodle 2.5 auf Moodle 2.5.1 aktualisieren==
 +
Um sicherzustellen, dass die Rechte bei Auszeichnungen richtig gesetzt sind, prüfen und setzen Sie für alle Rollen die Rechte, in denen die Zeichenkette <pre>badges</pre> vorkommt:
 +
*[[Capabilities/moodle/badges:manageownbadges|moodle/badges:manageownbadges]]
 +
*[[Capabilities/moodle/badges:viewotherbadges|moodle/badges:viewotherbadges]]
 +
*[[Capabilities/moodle/badges:awardbadge|moodle/badges:awardbadge]]
 +
*[[Capabilities/moodle/badges:configurecriteria|moodle/badges:configurecriteria]]
  
Wenn die Versionssprünge jedoch zu groß sind, kann es zu Problemen kommen (z.B. von 1.6 auf 2.2). Beachten Sie daher folgende Einschränkungen:
 
* Sie müssen auf eine Version 1.9.x aktualisieren, bevor Sie auf 2.y aktualisieren.
 
* Sie müssen auf eine Version 2.2.x aktualisieren, bevor Sie auf 2.3 aktualisieren.
 
  
 
==Siehe auch==
 
==Siehe auch==
* [[Serverinformationen]]
+
* [[Installation]]
* [[Installation FAQ]]
 
 
* [http://moodle.org/mod/forum/view.php?id=28 Forum zur Installation] im Kurs ''Using Moodle'' auf moodle.org
 
* [http://moodle.org/mod/forum/view.php?id=28 Forum zur Installation] im Kurs ''Using Moodle'' auf moodle.org
 
+
* [http://docs.moodle.org/dev/Moodle_2.6_release_notes Moodle 2.6 Release Notes] (englisch)
Aktualisierung auf eine bestimmte Version:
+
* [http://docs.moodle.org/dev/Upgrade_API Upgrade API] (englisch)
*[[Auf Moodle 2.2 aktualisieren]]
 
*[https://docs.moodle.org/21/de/Auf_Moodle_2.1_aktualisieren Auf Moodle 2.1 aktualisieren]
 
*[https://docs.moodle.org/20/de/Auf_Moodle_2.0_aktualisieren Auf Moodle 2.0 aktualisieren]
 
*[https://docs.moodle.org/19/de/Auf_Moodle_1.9_aktualisieren Auf Moodle 1.9 aktualisieren]
 
*[https://docs.moodle.org/19/de/Auf_Moodle_1.8_aktualisieren Auf Moodle 1.8 aktualisieren]
 
*[https://docs.moodle.org/19/de/Auf_Moodle_1.7_aktualisieren Auf Moodle 1.7 aktualisieren]
 
*[https://docs.moodle.org/19/de/Auf_Moodle_1.6_aktualisieren Auf Moodle 1.6 aktualisieren]
 
 
 
Diskussionsbeiträge im Kurs ''Using Moodle'' auf moodle.org:
 
*[http://moodle.org/mod/forum/discuss.php?d=104887 Best practices for QA]
 
*[http://moodle.org/mod/forum/discuss.php?d=198123 Language customizations lost on upgrade]
 
  
  

Version vom 25. Februar 2015, 12:12 Uhr


Dieser Artikel beschreibt, wie Sie Moodle aktualisieren. Eine Übersicht über die einzelnen Schritte finden Sie unter Aktualisierung in Kürze.

Voraussetzungen prüfen

Prüfen Sie die Systemanforderungen für die Moodle-Version 2.5 unter Block Einstellungen > Website-Administration > Server > Serverinformationen.

Hinweis: Beachten Sie, dass Sie nur von Moodle 2.2. oder neueren Versionen auf Moodle 2.5 aktualisieren können. Wenn Ihr Moodle älter ist als 2.2, dann müssen Sie erst auf Moodle 2.2. aktualisieren.

Bevor Sie Ihr Produktivsystem aktualisieren

Wir empfehlen Ihnen dringend, die Aktualisierung auf einer Kopie Ihres Produktivsystems zu testen, um sicherzustellen, dass alles wie gewünscht funktioniert.

Wichtige Daten sichern

Detaillierte Informationen dazu finden Sie im Artikel Sicherungen.

Im wesentlichen müssen Sie drei Bereiche sichern:

  1. Moodle Software (PHP-Skripte von Moodle)
  2. Moodle-Datenverzeichnis
  3. Moodle-Datenbank

Erfahrene Administrator/innen wissen, dass es bei größeren Aktualisierungen immer wichtig ist, diese Daten zu sichern. Generell ist es eine gute Idee, diese Daten täglich automatisch zu sichern. Wenn Sie eine Standardinstallation von Moodle betreiben (ohne zusätzliche Plugins, ohne eigene Codeanpassungen), dann läuft die Aktualisierung normalerweise reibungslos durch.

Tipp: Prüfen Sie auch, ob Sie Ihre Sicherungen wiederherstellen können, sonst nützen sie nichts!

Wartungsmodus aktivieren

Bevor Sie mit der Aktualisierung beginnen, schalten Sie die Moodle-Site in den Wartungsmodus, um zu verhindern, dass sich Nutzer/innen anmelden.

Prüfen Sie, ob es Aktualisierungen für Ihre Plugins gibt

Wenn Sie die Automatische Aktualisierung aktiviert haben, dann können Sie die installierten Plugins automatisch während der Aktualisierung von Moodle aktualisieren. Prüfen Sie auf der Seite Einstellungen > Website-Administration > Plugins > Übersicht, ob Aktualisierungen vorhanden sind.

Wenn Sie Plugins manuell aktualisieren, dann ist es ein guter Zeitpunkt zu prüfen, ob es eine Moodle 2.6 Version für die Plugins gibt, die Sie früher auf Ihrer Moodle-Site installiert haben. Wenn das der Fall ist, laden Sie diese neue(n) Plugin-Version(en) herunter, kopieren Sie sie an die richtige Stelle im Moodle-Code-Verzeichnis (siehe Plugins installieren).

Die Aktualisierung des Plugins erfolgt dann im Verlauf der Aktualisierung von Moodle.

Wenn ein veraltetes Plugin den Abbruch der Aktualisierung verursacht, dann löschen Sie den entsprechenden Code direkt auf dem Moodle-Server, anstatt das Plugin in Moodle zu deinstallieren.

Neue Moodle-Version installieren

Laden Sie sich das Moodle 2.5 Paket von[http://download.moodle.org herunter oder verwenden Sie den Befehl

   wget http://sourceforge.net/projects/moodle/files/Moodle/stable25/moodle-latest-25.tgz

Standardpaket verwenden

  • Benennen Sie das alte Moodle-Verzeichnis um (z.B. /moodle -> /moodleold).
  • Entpacken Sie den neuen Code und kopieren Sie ihn in das Verzeichnis, in dem die alten Moodle-Skripte vorher lagen (z.B. /moodle).
  • Kopieren Sie Ihre alte Moodle-Konfigurationsdatei config.php zurück ins Moodle-Verzeichnis (z.B. /moodle).
  • Wenn Sie zusätzliche Plugins installiert hatten, laden Sie die entsprechenden neuen Versionen herunter und entpacken Sie diese in den passenden Verzeichnissen (siehe Plugins installieren). Stellen Sie sicher, dass die Versionen der Plugins zur neuen Moodle-Version passen.
  • Kopieren Sie Ihr Moodle-Datenverzeichnis.

Unter Linux würden diese Schritte so aussehen:

Moodle-Verzeichnis umbenennen und neuen Code entpacken:

   mv moodle moodle.backup
   tar xvzf moodle-2.5.tgz

Alte Moodle-Konfigurationsdatei kopieren und zusätzliche Plugins kopieren:

   cp moodle.backup/config.php moodle
   cp -pr moodle.backup/theme/mytheme moodle/theme/mytheme
   cp -pr moodle.backup/mod/mymod moodle/mod/mymod

Die Moodle-Konfigurationsdatei für den Webserver lesbar machen:

   chmod 740 admin/cli/cron.php (some configurations need chmod 750 or chmod 755)

Git verwenden

Sie können auch das Git verwenden, um Moodle zu aktualisieren.

Aktualisierung von Kommandozeile

Sie können Moodle auch von der Kommandozeile aktualisieren.

Aktualisierung abschließen

Jetzt müssen Sie noch den eignetlichen Aktualisierungsprozess in Moodle anstoßen. Gehen Sie dazu auf die Seite Einstellungen > Website-Administration > Mitteilungen.

Moodle erkennt automatisch, dass eine neuere Version auf den Server hochgeladen wurde und startet die Aktualisierung der Moodle-Datenbank und des Moodle-Datenverzeichnisses. Wenn irgendetwas nicht automatisch aktualisiert werden kann, sehen Sie entsprechende Hinweise und Anleitungen, was Sie tun sollen.

Wenn alles erfolgreich und ohne Fehlermeldungen durchläuft, dann können Sie mit Ihrer neuen Moodle-Version sofort loslegen!

Hinweis: Wenn Sie mit mehreren Servern arbeiten, dann sollten Sie nach der Aktualisierung auf allen Servern den Cache löschen: Klicken Sie dazu im Block Einstellungen > Website-Administration > Entwicklung > Cache löschen.

Fatal error: Maximum execution time of 30 seconds exceeded...

Wenn Sie neben dem englischen Sprachpaket weitere Sprachpakete verwenden, dann kann dieser Fehler auftreten, weil die Aktualisierung des Sprachpakets zu lange dauert. In diesem Fall erhöhen Sie inder PHP-Konfigurationsdatei php.ini den Wert

max_execution_time = 160

. Dann haben die Moodle-Skripte genügend Zeit, die Sprachpakete zu aktualisieren.

Alternativ können Sie Ihre Moodle-Site vor der Aktualisierung auf englisch umstellen und danach wieder auf die gewünschte Sprache zurückstellen. Siehe dieser Diskussionsbeitrag auf moodle.org: https://moodle.org/mod/forum/discuss.php?d=119598.

Nach der Aktualisierung

Die Moodle-Konfigurationsdatei config.php sollte gut funktionieren. Wenn Sie sich jedoch die mitgelieferte Konfigurationsdatei config-dist.php ansehen, dann finden Sie dort weitere/andere Optionen (z.B. Datenbanktreiber und -einstellungen). Es ist eine gute Idee, die neuen Werte aus der config-dist.php in Ihre config.php zu übernehmen.

Mögliche Probleme in Moodle 2.5

Neu
in Moodle 2.5!

Einstellungen-Block

Baustelle.png Diese Seite ist noch nicht vollständig übersetzt.


Moodle 2.3 und 2.4 Verbesserungen

Je nachdem, von welcher Moodle-Version aus Sie auf Moodle 2.5 aktualisieren, empfehlen wir die entsprechenden Abschnitt "Mögliche Probleme in Moodle 2.x" in der jeweiligen Dokumentation zu lesen:

Von Moodle 2.5 auf Moodle 2.5.1 aktualisieren

Um sicherzustellen, dass die Rechte bei Auszeichnungen richtig gesetzt sind, prüfen und setzen Sie für alle Rollen die Rechte, in denen die Zeichenkette

badges

vorkommt:


Siehe auch