Talk:License

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.0. Up-to-date documentation for the latest stable version is available here: License.

Fix link please

The GPL link at the bottom of every MoodleDoc content page links here and then we send them to DEV. This might be a case for translocation from that page to here and lock the page. Or the GPL link should go directly to the DEV side of the house. Notice that when in edit mode on this page, the GNU General Public License link goes to the right place. --chris collman 22:37, 27 October 2011 (WST)

Thanks Chris for pointing this out. I've implemented your suggestion of redirecting the page to dev:License. --Helen Foster 14:56, 28 October 2011 (WST)

License in basque

eu:Lizentzia --Abel Camacho 03:05, 31 January 2007 (CST)

Done, as requested, thanks for the translation :-) --Helen Foster 08:30, 30 July 2007 (CDT)

Typo

GNU GENERAL PUBLIC LICENCE should be GNU GENERAL PUBLIC LICENSE

-Dan Fuhry 09:05, 8 March 2006 (WST)

Thanks Dan, it's been changed. --Helen Foster 16:17, 10 March 2006 (WST)

French link

You could add the link to the french MoodleDocs : [[fr:Licence]]. Thanks in advance !

-- Nicolas Martignoni 01:57, 29 September 2006 (CDT)

Done, as requested, thanks for the translation :-) --Helen Foster 02:09, 29 September 2006 (CDT)

Links explaining /clarifying GPL for novices

Would be a good idea to add some links like this to the bottom of the page or to another place/page?

http://www.itmanagersjournal.com/feature/12878

--Eloy Lafuente (stronk7) 12:23, 12 November 2006 (CST)

Upgrading to GPL v3.0

The main reason I think we should upgrade is the patent-related stuff.

Any comments from anyone who thinks it would be a BAD idea to upgrade all our licenses to GPL v3?

If we do upgrade, any GPL v2 code we have needs to be checked to make sure that it contains "version 2 of the License, or (at your option) any later version" because version 2 ONLY code can not be included in a version 3 package (they are incompatible).

Martin Dougiamas 22:51, 2 September 2007 (CDT)

After running this command (part of the devscripts Debian package) over CVS HEAD:

 find | xargs -n 100 licensecheck | grep "GPL" | grep -v "or later" | less

I couldn't find anything that was licensed under the GPLv2 without the "or later" bit.

Another script that could be useful is the one I wrote to check for the same thing before we upgraded to GPLv3 in Mahara.

-- Francois Marier 19:26, 12 June 2008 (NZST)