error/admin/unicoderequired

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 1.9. Up-to-date documentation for the latest stable version is available here: error/admin/unicoderequired.

I'm getting this error on a new moodle 1.8.2+ installation (package pulled 2007-09-05). It reads, in full (in horrible light-grey-on-light-red colors):

It is required that you store all your data in Unicode format (UTF-8). New installations must be performed into databases that have their default character set as Unicode. If you are upgrading, you should perform the UTF-8 migration process (see the Admin page).

I'm doing this on a postgresql 7.4 server (debian etch), which apparently does not default to creating the database with a utf8 encoding.

To resolve the issue, i switched to the postgresql user, removed the old database, and recreated the new one, with a utf8 encoding:

postgres@mongoose:~$ dropdb moodle
DROP DATABASE
postgres@mongoose:~$ createdb -E utf8 -O www-data moodle
CREATE DATABASE
postgres@mongoose:~$

I've Jeff Forssell 09:56, 18 November 2008 (CST) gotten the same error message (though black text on bright red), but I'm on a SiteGround Host with MySQL. I thought we'd already gone through the UTF-8 conversion process, so I'm a bit surprised and don't know what to do.

See also