Difference between revisions of "Stable branch support"

Jump to: navigation, search
(dropping support for 1.a.x, 1.6.x, 1.7.x, see also)
 
(Replaced content with "See Releases for all support timeframes.")
 
(8 intermediate revisions by 4 users not shown)
Line 1: Line 1:
{{Template:Work_in_progress}}
+
See [[Releases]] for all support timeframes.
 
 
Unfortunately it's not possible to continue to provide support for older stable branches of Moodle indefinitely due to the amount of work involved. This page describes the process of dropping support for older stable branches.
 
 
 
 
 
==Dropping support for 1.a.x==
 
 
 
# Propose a date in MDLSITE-737 for dropping support for 1.a.x 5 months after the final release
 
# Announce the final release of 1.a.x in the moodle.org news
 
# Update the Moodle version message in the tracker to read: "There will not be another 1.a.x release, but critical bugs may still be backported to the branch until [''date 5 months in advance'']."
 
# After 5 months, release 1.a.x+ and archive all 1.a.x versions
 
==Dropping support for 1.6.x==
 
 
 
# Proposed date for dropping support for 1.6.x: 31 July 2009
 
# Announcement: [http://moodle.org/mod/forum/discuss.php?d=115616 New releases: Moodle 1.9.4, 1.8.8, 1.7.7 and 1.6.9]
 
# 1.6.9+ released and 1.6.x versions archived on 31 July 2009. 16_STABLE closed in the tracker.
 
 
 
==Dropping support for 1.7.x==
 
 
 
# Proposed date for dropping support for 1.6.x: 31 October 2009
 
# Announcement: [http://moodle.org/mod/forum/discuss.php?d=115616 New releases: Moodle 1.9.4, 1.8.8, 1.7.7 and 1.6.9]
 
# 1.7.7+ released and 1.7.x versions archived on 31 October 2009. 17_STABLE closed in the tracker.
 
 
 
==See also==
 
 
 
* MDLSITE-737 Drop support for 1.6.x and 1.7.x versions in the Tracker
 
 
 
[[Category:Processes|Stable branch support]]
 

Latest revision as of 04:21, 10 October 2011

See Releases for all support timeframes.