Difference between revisions of "Release notes template"

Jump to: navigation, search
m (Tips: Clarify the purpose of the git command)
(additional headings)
Line 6: Line 6:
  
 
Here is [https://tracker.moodle.org/secure/IssueNavigator!executeAdvanced.jspa?jqlQuery=project+%3D+mdl+AND+resolution+%3D+fixed+AND+fixVersion+in+%28%22X.X.X%22%29+ORDER+BY+priority+DESC&runQuery=true&clear=true the full list of fixed issues in X.X.X].
 
Here is [https://tracker.moodle.org/secure/IssueNavigator!executeAdvanced.jspa?jqlQuery=project+%3D+mdl+AND+resolution+%3D+fixed+AND+fixVersion+in+%28%22X.X.X%22%29+ORDER+BY+priority+DESC&runQuery=true&clear=true the full list of fixed issues in X.X.X].
 +
 +
==Server requirements==
 +
 +
===Database requirements===
 +
 +
==Client requirements==
 +
 +
===Browser support===
 +
Moodle is compatible with any standards compliant web browser. We regularly test Moodle with the following browsers:
 +
 +
Desktop:
 +
* Chrome
 +
* Firefox
 +
* Safari
 +
* Edge
 +
* Internet Explorer
 +
 +
Mobile:
 +
* MobileSafari
 +
* Google Chrome
 +
 +
For the best experience and optimum security, we recommend that you keep your browser up to date. https://whatbrowser.org
 +
 +
Note: Legacy browsers with known compatibility issues with Moodle 3.5:
 +
* Internet Explorer 10 and below
 +
* Safari 7 and below
  
 
===Major features===
 
===Major features===
Line 12: Line 38:
  
 
===Other highlights===
 
===Other highlights===
 +
 +
''Items to be added soon...''
 +
 +
===For admins===
  
 
''Items to be added soon...''
 
''Items to be added soon...''

Revision as of 14:40, 29 October 2019

Copy and paste this wiki code into the new release notes page and replace all the missing bits.

[[Releases]] > {{FULLPAGENAME}}
 
Release date: Not yet released
 
Here is [https://tracker.moodle.org/secure/IssueNavigator!executeAdvanced.jspa?jqlQuery=project+%3D+mdl+AND+resolution+%3D+fixed+AND+fixVersion+in+%28%22X.X.X%22%29+ORDER+BY+priority+DESC&runQuery=true&clear=true the full list of fixed issues in X.X.X].
 
==Server requirements==
 
===Database requirements===
 
==Client requirements==
 
===Browser support===
Moodle is compatible with any standards compliant web browser. We regularly test Moodle with the following browsers:
 
Desktop:
* Chrome
* Firefox
* Safari
* Edge
* Internet Explorer
 
Mobile:
* MobileSafari
* Google Chrome
 
For the best experience and optimum security, we recommend that you keep your browser up to date. https://whatbrowser.org
 
Note: Legacy browsers with known compatibility issues with Moodle 3.5:
* Internet Explorer 10 and below
* Safari 7 and below
 
===Major features===
 
''Items to be added soon...''
 
===Other highlights===
 
''Items to be added soon...''
 
===For admins===
 
''Items to be added soon...''
 
===For developers===
 
''Items to be added soon...''
 
===Security issues===
 
A number of security related issues were resolved. Details of these issues will be released after a period of approximately one week to allow system administrators to safely update to the latest version.
 
==See also==
*[[Moodle X.X.X-1 release notes]]
 
[[Category:Release notes]]
[[Category:Moodle X.X]]
 
[[fr:Notes de mise à jour de Moodle X.X.X]]
[[es:Notas de Moodle X.X.X]]

Tips

The following git command can be used to find all upgrade.txt files that were modified since the last release, so that links to them can be provided in the release notes - typically in the For developers section.

$ git log --oneline --pretty="format:" --name-only v3.5.0..v3.6.0-beta | grep upgrade.txt | sort | uniq | while read path; do echo "* $path"; done

See e.g. Moodle 3.6 release notes#Component APIs upgrades for how it was used in the past.

Plantilla en Español