Moodle 3.9 release notes

Jump to: navigation, search

Releases > Moodle 3.9 release notes  

Release date: Not yet released - scheduled for Monday 15 June 2020

Here is the full list of fixed issues in 3.9.

If you are upgrading from a previous version, please see Upgrading in the user docs.

Server requirements

Note: Requirements still to be reviewed and updated as necessary!

These are just the minimum supported versions. We recommend keeping all of your software and operating systems up-to-date.

  • Moodle upgrade: Moodle 3.5 or later
  • PHP version: minimum PHP 7.2.0 Note: minimum PHP version has increased since Moodle 3.8. PHP 7.3.x and 7.4.x are supported too. See Moodle and PHP for details.
  • PHP extension mbstring is required (it was recommended)

Database requirements

Note: Requirements still to be reviewed and updated as necessary!

Moodle supports the following database servers. Again, version numbers are just the minimum supported version. We recommend running the latest stable version of any software.

Database Minimum version Recommended
PostgreSQL 9.5 Latest
MySQL 5.6 Latest
MariaDB 10.2.29 Latest
Microsoft SQL Server 2012 Latest
Oracle Database 11.2 Latest

Client requirements

Browser support

Moodle is compatible with any standards compliant web browser. We regularly test Moodle with the following browsers:

Desktop:

  • Chrome
  • Firefox
  • Safari
  • Edge
  • Internet Explorer

Mobile:

  • MobileSafari
  • Google Chrome

For the best experience and optimum security, we recommend that you keep your browser up to date. https://whatbrowser.org

Note: Legacy browsers with known compatibility issues with Moodle 3.9:

  • Internet Explorer 10 and below
  • Safari 7 and below

 

Major features

Other highlights

Security issues

  A number of security related issues were resolved. Details of these issues will be released after a period of approximately one week to allow system administrators to safely update to the latest version.

 

See also