Moodle 3.0 release notes

Revision as of 06:55, 26 October 2015 by Marina Glancy (talk | contribs) (Added standard header and requirements)

Jump to: navigation, search

Releases > Moodle 3.0 release notes

Release date: Monday, 9th November 2015

Here is the full list of fixed issues in 3.0.

See our New Features page for a more user-friendly introduction to Moodle 3.0 with screenshots.

If you are upgrading from previous version, make sure to read the Upgrading documentation.

Server requirements

These are just the minimum supported versions. We recommend keeping all of your software up-to-date.

  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2.11 as a first step)
  • PHP version: minimum PHP 5.4.4 (always use latest PHP 5.4.x or 5.5.x on Windows - http://windows.php.net/download/), PHP 7 is NOT supported
  • Ghostscript should be installed for pdf annotation.

Database requirements

Moodle supports the following database servers. Again, version numbers are just the minimum supported version. We recommend running the latest stable version of any software.

Database Minimum version Recommended
PostgreSQL 9.1 Latest
MySQL 5.5.31 Latest
MariaDB 5.5.31 Latest
Microsoft SQL Server 2008 Latest
Oracle Database 10.2 Latest

Client requirements

Browser support

Browser Minimum version Recommended version Notes
Google Chrome 30.0 Latest
Mozilla Firefox 25.0 Latest
Apple Safari 6 Latest
Microsoft Internet Explorer 9 Latest Version 10 is required for drag-and-drop upload of content from outside the browser into Moodle

Major features

List of features will be coming soon