Difference between revisions of "Moodle 3.3 release notes"

Jump to: navigation, search
(Database requirements)
(Server requirements)
Line 15: Line 15:
 
* Moodle upgrade:  Moodle 2.7 or later (if upgrading from earlier versions, you must upgrade to 2.7.14 as a first step)
 
* Moodle upgrade:  Moodle 2.7 or later (if upgrading from earlier versions, you must upgrade to 2.7.14 as a first step)
 
* PHP version: minimum PHP 5.6.5. ''Note: minimum PHP version has increased since Moodle 3.1''. PHP 7.0.x and 7.1.x are supported but have some [https://docs.moodle.org/dev/Moodle_and_PHP7#Can_I_use_PHP7_yet.3F engine limitations].  
 
* PHP version: minimum PHP 5.6.5. ''Note: minimum PHP version has increased since Moodle 3.1''. PHP 7.0.x and 7.1.x are supported but have some [https://docs.moodle.org/dev/Moodle_and_PHP7#Can_I_use_PHP7_yet.3F engine limitations].  
 +
* PHP extensions '''openssl''' and '''fileinfo''' are now required in Moodle 3.3, they were recommended in 3.2
 +
* If you use PostgreSQL the minimum supported version is now 9.3 (was 9.1 in Moodle 3.2)
  
 
=== Database requirements ===
 
=== Database requirements ===

Revision as of 03:13, 9 May 2017

Releases > Moodle 3.3 release notes

Release date: 15 May 2017 (Not yet released)

Here is the full list of fixed issues in 3.3.

See our New Features page for a more user-friendly introduction to Moodle 3.2 with screenshots.

If you are upgrading from previous version, make sure you read the Upgrading documentation.

Server requirements

These are just the minimum supported versions. We recommend keeping all of your software up-to-date.

  • Moodle upgrade: Moodle 2.7 or later (if upgrading from earlier versions, you must upgrade to 2.7.14 as a first step)
  • PHP version: minimum PHP 5.6.5. Note: minimum PHP version has increased since Moodle 3.1. PHP 7.0.x and 7.1.x are supported but have some engine limitations.
  • PHP extensions openssl and fileinfo are now required in Moodle 3.3, they were recommended in 3.2
  • If you use PostgreSQL the minimum supported version is now 9.3 (was 9.1 in Moodle 3.2)

Database requirements

Moodle supports the following database servers. Again, version numbers are just the minimum supported version. We recommend running the latest stable version of any software.

Database Minimum version Recommended
PostgreSQL 9.3 Latest
MySQL 5.5.31 Latest
MariaDB 5.5.31 Latest
Microsoft SQL Server 2008 Latest
Oracle Database 10.2 Latest

Client requirements

Browser support

Moodle is compatible with any standards compliant web browser. We regularly test Moodle with the following browsers:

Desktop:

  • Chrome
  • Firefox
  • Safari
  • Edge
  • Internet Explorer

Mobile:

  • MobileSafari
  • Google Chrome

For the best experience and optimum security, we recommend that you keep your browser up to date. https://whatbrowser.org

Note: Legacy browsers with known compatibility issues with Moodle 3.3:

  • Internet Explorer 10 and below
  • Safari 7 and below

Major features

Highlights

  • ...

Functional changes

  • ...

API changes

  • ...

Fixes and improvements

  • ...

See also