Difference between revisions of "Latest release notes"

Jump to: navigation, search
(Moodle 1.8.14)
(2.0.1)
Line 1: Line 1:
==Moodle 2.0==
+
==Moodle 2.0.1==
{{:Moodle 2.0 release notes}}
+
{{:Moodle 2.0.1 release notes}}
  
 
==Moodle 1.9.10==
 
==Moodle 1.9.10==

Revision as of 09:11, 28 December 2010

Moodle 2.0.1

Release date: 25th December 2010

Fixes

  • MDL-25346 - Fixed some navigation issues on the user profile page
  • MDL-25656 - Fixed problems with glossary filter
  • MDL-21658 - Web services unit tests for external functions and for ws services servers
  • MDL-25483 - phpmyadmin plugin upgraded to 2.11.11.1 and 3.3.8.1 (separate download)
  • MDL-21671 - Fixed up permission checking when moving course categories

And many more ... see the full list of 80 fixed issues in 2.0.1.


Moodle 1.9.10

Release date: 25th October 2010

Over 110 issues were fixed in 1.9.10. (click to see them)

Security issues

This release upgrades some of the 3rd-party libraries that we use in Moodle. Keeping your Moodle site up to date is, as usual, highly recommended!

  • MSA-10-0017 XSS vulnerability in YUI 2.4.0 through YUI 2.8.1
  • MSA-10-0016 Multiple phpCAS library vulnerabilities
  • MSA-10-0015 Customised HTML Purifier upgraded to 4.2.0


Also notice there was a security problem in the optional phpMyAdmin module:



Moodle 1.8.14

Release date: 3rd December, 2010

Here is the full list of fixed issues in 1.8.14.

Security issues


Also notice there was a security problem in the optional phpMyAdmin module:

Note: This is the last formal release of the 1.8 branch. Support for this branch has been discontinued. We highly recommend you upgrade!


Moodle 1.7.7

Release date: 28th January 2009

Here is the full list of fixed issues in 1.7.7.


Note: This is the last formal release of the 1.7 branch. Support for this branch has been discontinued. We highly recommend you upgrade!


Moodle 1.6.9

Release date: 28th January 2009

Here is the full list of fixed issues in 1.6.9.


Note: This is the last formal release of the 1.6 branch. Support for this branch has been discontinued. We highly recommend you upgrade!


See also

ru:Примечания к версиям