Differenze tra le versioni di "admin/environment/php extension/intl"

Da MoodleDocs.
Riga 10: Riga 10:
 
Per abilitare questa estensione, aggiungere la seguente riga al file php.ini:
 
Per abilitare questa estensione, aggiungere la seguente riga al file php.ini:
  
<code>
+
<code>
extension=php_intl.dll
+
extension=php_intl.dll
</code>
+
</code>
  
  
 
E quindi impostare  ''intl.default_locale''  e  ''intl.error_level'' nel file php.ini.
 
E quindi impostare  ''intl.default_locale''  e  ''intl.error_level'' nel file php.ini.
  
<code>
+
<code>
[intl]
+
[intl]
 
+
intl.default_locale = it_utf8
intl.default_locale = it_utf8
+
intl.error_level = E_WARNING
 
+
</code>
intl.error_level = E_WARNING
 
</code>
 
  
  

Versione delle 10:57, 20 dic 2010

Traduzione di --marco soppelsa 10:52, 20 dic 2010 (UTC) - sito http://marcosoppelsa.weebly.com/index.html -

testo originale https://docs.moodle.org/en/admin/environment/php_extension/intl


L'estensione di internazionalizzazione (Intl) è un wrapper per la libreria ICU, una serie librerie di C/C++ e Java che forniscono il supporto Unicode e globalizzazione per le applicazioni software. Esso permette ai programmatori PHP di eseguire collation di caratteri conformi ad UCA e la corretta formattazione di data/ora/numero/valuta negli script.

MS Windows

Per abilitare questa estensione, aggiungere la seguente riga al file php.ini:


extension=php_intl.dll


E quindi impostare intl.default_locale e intl.error_level nel file php.ini.


[intl]
intl.default_locale = it_utf8
intl.error_level = E_WARNING


La direttiva intl.error_level è facoltativa.

Altri sistemi operativi

Usa il manager dei pacchetti o specificare comando.

  • Debian 5.0 (& Ubuntu) usa: apt-get install php-intl o apt-get install php5-intl
  • CentOS 5.5 (& RedHat) dovrai usare: yum install php-intl