Notas de Moodle 4.00

De MoodleDocs
Revisión del 13:46 8 mar 2022 de German Valero (discusión | contribs.) (tidy up)
(difs.) ← Revisión anterior | Revisión actual (difs.) | Revisión siguiente → (difs.)

Nota: Esta es una traducción de una página de la documentación para desarrolladores (Developer docs), que se considera particularmente importante, y que en su versión original se actualiza frecuentemente. Por ello, se le recomienda que revise la página original en idioma inglés: Moodle 4.0 release notes.

Moodle 4.0

Historia de las versiones > Notas de Moodle 4.00

Fecha de liberación: finales de marzo 2022

Aquí está la lista completa de composturas en 4.0.

Vea nuestra página de las Nuevas características de Moodle 4.0 en la documentación del usuario para una introducción más amistosa, con imágenes, sobre Moodle 4.01.


Si Usted está actualizando desde una versión anterior, asegúrese de leer la documentación sobre Actualización de moodle.

Requisitos del servidor

Nota: ¡Los requisitos siguen siendo revisados y serán actualizado conforme sea necesario!

Estas son solamente las versiones mínimas soportadas. Nosotros recomendamos mantener todo su software y su sistema operativo actualizados.

  • Actualización de Moodle: Moodle 3.6 o más reciente (si actualiza desde una versión más antigua, Usted debe primeramente de actualizar a 3.2 como un primer paso)
  • Versión de PHP: minimo PHP 7.3.0 (¡importante! la versión mínima de PHP se ha incrementado desde Moodle 3.10). PHP 7.4.x también está soportado. Soporte a PHP 8.0 está siendo implementado (vea MDL-70745) y aun no está listo para producción.
  • La extensión PHP sodium es recomendada. Será necesaria en Moodle 4.2. Para más detalles, vea Environment - PHP extension sodium.
  • PHP extension exif is recommended.
  • La extensión PHP max_input_vars se recomienda que sea >= 5000 para instalaciones con PHP 7.x. Es un requisito para instalaciones con PHP 8.x. Para más detlles, vea Environment - max input vars.
  • La extensión PHP mbstring ahora es necesaria (era recomendada anteriormente)

Requisitos de la BasedeDatos

Moodle soporta los siguientes servidores de Base de Datos. Una vez más, los números de las versiones son las versiones mínimas soportadas. Nosotros recomendamos correr la versión estable más reciente de cualquier software.

BasedeDatos Versión mínima Recomendada
PostgreSQL 10 (incrementada desde Moodle 3.11) La más reciente
MySQL 5.7 La más reciente
MariaDB 10.2.29 La más reciente
Microsoft SQL Server 2017 (incrementada desde Moodle 3.10) La más reciente
Oracle Database 11.2 La más reciente

Requisitos del cliente

Soporte para Navegador

Moodle es compatible con cualquier navegador de Internet que cumpla con los estándares actuales. Nosotros regularmente probamos Moodle con los siguientes navegadores:

PC de escritorio:

  • Chrome
  • Firefox
  • Safari
  • Edge

Nota: Moodle 4.0 NO soporta Internet Explorer 11.

Safari 7 e inferiores tienen problemas de compatibilidad conocidos con Moodle 4.0.

Mobile:

  • MobileSafari
  • Google Chrome

Para la mejor experiencia y seguridad óptima, nosotros recomendamos que Usted mantenga actualizado su navegador. https://www.whatsmybrowser.org/

Nota: Pendiente de Traducir. ¡Anímese a traducir esta página!.     ( y otras páginas pendientes)


Principales características

...

Other highlights

Security issues

A number of security related issues were resolved. Details of these issues will be released after a period of approximately one week to allow system administrators to safely update to the latest version.


Vea también

Notas de Moodle 3.11