Diferencia entre revisiones de «Notas de Moodle 3.9»

Saltar a: navegación, buscar
({{Actualizar}})
 
(tidy up)
Línea 5: Línea 5:
 
[[Historia de las versiones]] > {{FULLPAGENAME}}
 
[[Historia de las versiones]] > {{FULLPAGENAME}}
  
Fecha de liberación: ... {{Actualizar}}
+
Fecha de liberación: ...no se ha liberado aun - está planeado para 8 de Junio del 2020
  
Aquí está [https://tracker.moodle.org/secure/IssueNavigator!executeAdvanced.jspa?jqlQuery=project+%3D+mdl+AND+resolution+%3D+fixed+AND+fixVersion+in+%28%223.8%22%29+ORDER+BY+priority+DESC&runQuery=true&clear=true la lista completa de composturas en 3.8].
+
Aquí está [https://tracker.moodle.org/secure/IssueNavigator!executeAdvanced.jspa?jqlQuery=project+%3D+mdl+AND+resolution+%3D+fixed+AND+fixVersion+in+%28%223.9%22%29+ORDER+BY+priority+DESC&runQuery=true&clear=true la lista completa de composturas en 3.9].
  
 
Vea nuestra página de las [[Nuevas características de Moodle 3.9]] en la documentación del usuario para una introducción más amistosa, con imágenes, sobre Moodle 3.9.
 
Vea nuestra página de las [[Nuevas características de Moodle 3.9]] en la documentación del usuario para una introducción más amistosa, con imágenes, sobre Moodle 3.9.
Línea 18: Línea 18:
 
Estas son solamente las versiones mínimas soportadas. Nosotros recomendamos mantener todo su ''software'' y su sistema operativo actualizados.
 
Estas son solamente las versiones mínimas soportadas. Nosotros recomendamos mantener todo su ''software'' y su sistema operativo actualizados.
  
* Actualización de Moodle:  Moodle 3.2 o más reciente (si actualiza desde una versión más antigua, Usted debe primeramente de actualizar a 3.2 como un primer paso)
+
* Actualización de Moodle:  Moodle 3.5 o más reciente (si actualiza desde una versión más antigua, Usted debe primeramente de actualizar a 3.2 como un primer paso)
* Versión de [[PHP]]: minimo PHP 7.1.0 (¡importante! la versión mínima de [[PHP]] se ha incrementado desde Moodle 3.6). PHP 7.2.x y 7.3.x están soportados. PHP 7.x podría tener algunas [https://docs.moodle.org/dev/Moodle_and_PHP7#Can_I_use_PHP7_yet.3F limitaciones del motor].  
+
* Versión de [[PHP]]: minimo PHP 7.2.0 (¡importante! la versión mínima de [[PHP]] se ha incrementado desde Moodle 3.6). PHP 7.3.x y 7.4.x están soportados. Vea [[Moodle y PHP]] para los detalles.
* La extensión PHP '''intl''' ahora es necesaria desde Moodle 3.4 (era recomendada a partir de Moodle 2.0 en adelante)
+
* La extensión PHP '''mbstring''' ahora es necesaria (era recomendada anteriormente)
 
   
 
   
 
=== Requisitos de la BasedeDatos ===
 
=== Requisitos de la BasedeDatos ===
Línea 33: Línea 33:
 
|-
 
|-
 
| [http://www.postgresql.org/ PostgreSQL]
 
| [http://www.postgresql.org/ PostgreSQL]
| 9.4
+
| 9.5
 
| 11.x - tenga en cuenta que 12.x aun no está soportada (MDL-67414)
 
| 11.x - tenga en cuenta que 12.x aun no está soportada (MDL-67414)
 
|-
 
|-
Línea 41: Línea 41:
 
|-
 
|-
 
| [https://mariadb.org/ MariaDB]
 
| [https://mariadb.org/ MariaDB]
| 5.5.31
+
| 10.2.29
 
| La más reciente
 
| La más reciente
 
|-
 
|-
Línea 76: Línea 76:
  
 
==Principales características==
 
==Principales características==
 
===Analíticas===
 
...
 
===Integración H5P===
 
...
 
===Tarea===
 
...
 
===Banco de preguntas===
 
...
 
===Vista general del curso===
 
...
 
===Mejoras de usabilidad===
 
 
...
 
...
 
==Otros aspectos destacados==
 
==Otros aspectos destacados==
 
===Cambios funcionales===
 
 
...
 
===Para administradores===
 
...
 
==Para desarrolladores==
 
 
...
 
===Agregados y actualizaciones a los servicios web===
 
 
...
 
===Actualizaciones a la API===
 
 
...
 
...
 
==Asuntos de seguridad==
 
==Asuntos de seguridad==

Revisión del 22:13 23 may 2020

Nota: Esta es una traducción de una página de la documentación para desarrolladores (Developer docs), que se considera particularmente importante, y que en su versión original se actualiza frecuentemente. Por ello, se le recomienda que revise la página original en idioma inglés: Moodle 3.9 release notes.

Moodle 3.9Historia de las versiones > Notas de Moodle 3.9

Fecha de liberación: ...no se ha liberado aun - está planeado para 8 de Junio del 2020

Aquí está la lista completa de composturas en 3.9.

Vea nuestra página de las Nuevas características de Moodle 3.9 en la documentación del usuario para una introducción más amistosa, con imágenes, sobre Moodle 3.9.


Si Usted está actualizando desde una versión anterior, asegúrese de leer la documentación sobre Actualización de moodle.

Requisitos del servidor

Estas son solamente las versiones mínimas soportadas. Nosotros recomendamos mantener todo su software y su sistema operativo actualizados.

  • Actualización de Moodle: Moodle 3.5 o más reciente (si actualiza desde una versión más antigua, Usted debe primeramente de actualizar a 3.2 como un primer paso)
  • Versión de PHP: minimo PHP 7.2.0 (¡importante! la versión mínima de PHP se ha incrementado desde Moodle 3.6). PHP 7.3.x y 7.4.x están soportados. Vea Moodle y PHP para los detalles.
  • La extensión PHP mbstring ahora es necesaria (era recomendada anteriormente)

Requisitos de la BasedeDatos

Moodle soporta los siguientes servidores de Base de Datos. Una vez más, los números de las versiones son las versiones mínimas soportadas. Nosotros recomendamos correr la versión estable más reciente de cualquier software.

BasedeDatos Versión mínima Recomendada
PostgreSQL 9.5 11.x - tenga en cuenta que 12.x aun no está soportada (MDL-67414)
MySQL 5.6 La más reciente
MariaDB 10.2.29 La más reciente
Microsoft SQL Server 2012 (incrementada desde Moodle 3.7) La más reciente
Oracle Database 11.2 La más reciente

Requisitos del cliente

Soporte para Navegador

Moodle es compatible con cualquier navegador de Internet que cumpla con los estándares actuales. Nosotros regularmente probamos Moodle con los siguientes navegadores:

PC de escritorio:

  • Chrome
  • Firefox
  • Safari
  • Edge
  • Internet Explorer

Móvil:

  • MobileSafari
  • Google Chrome

Para la mejor experiencia y seguridad óptima, nosotros recomendamos que Usted mantenga actualizado su navegador. https://whatbrowser.org

Nota: Navegadores antiguos que tienen problemas conocidos de compatibilidad con Moodle 3.x:

  • Internet Explorer 10 e inferiores
  • Safari 7 e inferiores

Principales características

...

Otros aspectos destacados

...

Asuntos de seguridad

Un número de asuntos de seguridad fueron resueltos. Detalles de ellos van a ser publicados en un período de aproximadamente una semana para permitir a los administradores de sistemas actualizar de manera segura a la última versión.

Vea también