Diferencia entre revisiones de «Editor cloze para TinyMCE»

Saltar a: navegación, buscar
(updted |entry = https://moodle.org/plugins/view.php?plugin=tinymce_clozeeditor)
(fix typo)
(No se muestra una edición intermedia del mismo usuario)
Línea 154: Línea 154:
 
* Y aquí están las cadenas de texto traducidas al Español empleadas en el plugin:
 
* Y aquí están las cadenas de texto traducidas al Español empleadas en el plugin:
 
[[File:Cloze editor in spanish.png]]
 
[[File:Cloze editor in spanish.png]]
 +
 +
*La siguiente imagen muestra una traducción francesa de este plugin:
 +
[[File:CLOZE editor fr language.png|600px]]
 +
 +
==Corrigiendo el problema de que 'la pantalla no es suficientemente ancha'==
 +
Con algunos navegadores de Internet la pantalla no es lo suficientemente ancha.
 +
[[File:CLOZE editor issue screen not wide enough.png]]
 +
* Para corregir esto, Usted necesitará editar el archivo lib/editor/tinymce/plugins/clozeeditor/tinymce/editorplugin.js
 +
* Allí, deberá cambiar el valor del ancho 'width' (que originalmente es de 490) a 620 (pixeles).
 +
[[File:CLOZE editor editing editor_plugin_js.png]]
 +
* Usted puede usar un editor de texto como [https://notepad-plus-plus.org/ Notepad ++]. No intente usar Word para Windows.
 +
* No olvide limpiar las cachés: del navegador y de Moodle
 +
 +
==Editor Cloze para Atto==
 +
En 2016, Daniel Thies creó el plugin adicional del [[Editor cloze para Atto]].
  
 
==Vea también==
 
==Vea también==

Revisión del 00:01 13 mar 2018

Editor cloze para TinyMCE
Tipo Activity module, Cloze editor
Conjunto N/A
Descargas https://moodle.org/plugins/view.php?plugin=tinymce_clozeeditor
Problemas https://moodle.org/plugins/view.php?plugin=other_cloze
Discusión https://moodle.org/plugins/view.php?plugin=other_cloze
Mantenedor(es) Andreas Glombitza

Una interfaz que se integra al Editor HTML existente de Moodle (HTMLArea en 1.9 y TinyMCE en 2.x) para apoyar a los profesores a crear el Tipo de Pregunta con respuestas incrustadas (Cloze) en sintaxis GIFT.

Descarga

Puede descargar versiones específicas para Moodle 1.9, 2.0, 2.1 y para 2.4, 2.5, 2.6 y 2.7) desde https://moodle.org/plugins/view.php?plugin=tinymce_clozeeditor.

Vista general

La integración (PHP/JavaScript) es esencialmente un nuevo botón dentro del Editor HTML, que invoca una interfaz que nos ayuda a crear preguntas incrustadas (CLOZE) en la sintaxis correcta. Funciona con todos los idiomas, incluyendo Español

  • para la versión para Moodle 1.9 se incluyen traducciones al Alemán, Francés y Español
  • para la versión para Moodle 2.x las traducciones se realizan en AMOS

Instrucciones de instalación

Moodle 1.9

Para Moodle 1.9

Aquí hay una demostración (de la versión 1.9):

http://www.pellic.com/mod/resource/view.php?id=2507

Moodle 1.9

INSTALACIÓN PARA MOODLE 1.9

  • Localice su directorio moodleroot (generalmente llamado moodle)

Contenidos de Moodleroot.png

  • Descompríma el archivo ZIP


  • Copie el contenido de la carpeta clozeeditor/lib del archivo ZIP descomprimido a su directorio moodleroot/lib, manteniendo la estructura del directorio
    • Copie la carpeta clozeditor a moodle

Contenidos de Moodleroot con archivos copiados.png

Los siguientes archivos originales de su servidor serán sobre-escritos con archivos modificados, por lo que debería de asegurarse de RESPALDARLOS CON ANTERIORIDAD.:

lib/weblib.php *
lib/editor/htmlarea/htmlarea.php
lib/editor/htmlarea/dialog.js
  • El sobre-escribir el archivo weblib.php es OPCIONAL:
  • Si Usted elige incluir este archivo modificado, el botón editor de Moodle solamente se mostrará para los profesores, y solamente en la interfaz para preguntas. En otras instancias del editor, y para los estudiantes, este botón no se verá.
  • Si Usted conserva su archivo original de weblib.php, el plugin seguirá funcionando, pero el botón del editor será visible en TODAS las instancias del editor para los profesores, pero no para los alumnos.

Moodle 2.3

Moodle 2.2

Moodle 2.1

Moodle 2.0

Instalación para Moodle 2.0, 2.1, 2.2 y 2.3

  1. Descomprima el archivo ZIP.
  2. Copie los contenidos (exceptuando version.php) del directorio clozeeditor hacia el directorio lib/editor/tinymce en su servidor Moodle, manteniendo la estructura del directorio.

ATENCIÓN: NO SOBRE-ESCRIBAlib/editor/tinymce/version.php ya que esto descompondrá TinyMCE; el archivo version.php presente en el paquete descargadopuede ignorarse o eliminarse.

El archivo siguiente en su instalación será SOBRE-ESCRITO con un archivo modificado, por lo que le conviene asegurarse de haberlo respaldado ANTES de sobre-escribirlo:

lib/editor/tinymce/lib.php

Instalación para Moodle 2.4 y versiones superiores

  1. Descomprima el archivo ZIP
  2. Copie los contenidos del directorio al directorio lib/editor/tinymce/plugins de su servidor Moodle, manteniendo la estructura del directorio.
  3. Visite ' Administración > Administración del sitio > Notificaciones '
  4. Termine el proceso de instalación al elegir el botón para 'Actualizar la BasedeDatos de Moodle ahora' button.

Moodle 2.7

Moodle 2.6

Moodle 2.5

Instalación para Moodle 2.5 y versiones superiores

  1. En su menú para "Administración del sitio", vaya a "Plugins/Instalar complementos"
  2. Busque la sección para "Instalar complemento desde archivo ZIP"
  3. Seleccione "Editor TinyMCE HTML / tinymce (tinymce)" como "Tipo de plugin"
  4. Arrastre y suelte (o elija la localización y suba el archivo al servidor) el archivo "clozeeditor.zip" adentro del area para Paquete ZIP

26 Subir plugin por ZIP.png

  1. Active la casilla de la declaratoria de que ..sabe lo que hace...
  2. En la validación del paquete del complemento, si todo sale bien, elija el botón para "¡Instalar complemento!"
  3. Si la pantalla se pone en blanco y se pausa la instalación, presione la tecla para "actualizar la pantalla" key (F5) cuantas veces as (aprox 5) como sea necesario
  4. En la pantalla de revisión del plugin, elija el botón para "Actualizar ahora la BasedeDatos de Moodle"
  5. En la pantalla final que muestra el éxito, elija el botón para "Continuar"

Moodle 2.7

Instalación para Moodle 2.7 y superiores

  • Desde abril del 2014, Moodle 2.7 ahora incluye dos editores de texto HTML: el antiguo TinyMCEy el nuevo Atto.
  • Mientras permanezca el antiguo edirtor TinyMCE incluido, Usted puede continuar instalando el editor CLOZE como se describió arriba para Moodle 2.5
  • Después de haber instalado exitosamente el complemento mencionado, Usted debe de ir a ' Administración > Administración del sitio > Plugins > Editores de texto > Gestionar editores '
  • Verá los editores de texto disponibles en Moodle:

27available editors default config.png

  • El Editor Atto ahora es el editor de texto por defecto para Moodle 2.7+. Es muy pequeño, pero no tiene soprte para CLOZE:

27Atto editor.png

  • Usted deberá subir al editor TinyMCE:

27available editors default config click here.png

  • Y ahora Usted verá a TinyMCEcomo su Editor de texto seleccionado por defecto:

27available editors Moving Atto down makes TinyMCE top.png

  • Y el editor CLOZE funciona maravillosamente bien en Moodle 2.7+:

27TinyMCE editor with CLOZE plugin working OK.png

Uso del botón editor cloze

  • El botón del editor de cloze es un pequeño signo de interrogación de color amarillo dentro del editor HTML.

Cloze editor symbol.png

  • Escriba un texto pequeño en el editor HTML
  • En este caso, usaremos un poema de Emily Dickinson para un curso de literatura inglesa

to make a prairie 1.png

  • Seleccione una palabra a ser remplazada por un CLOZE

to make a prairie 2.png

  • Elija el signo de interrogación amarillo

Cloze editor symbol.png

  • Elija el formato de sub-pregunta Cloze a usar
  • En este caso usaremos Dropdown menu in-line in the text (menú deplegable en línea en el texto)

to make a prairie 3.png

  • Complete la respuesta correcta (la respuesta 1 será pre-llenada automáticamente)
  • En este caso la respuesta correcta es bee (abeja)
  • Complete las respuestas incorrectas (distractores) si las hubiera
  • En este caso, cow & elephant (vaca y elefante)

to make a prairie 4.png]]

  • Elija el botón para 'Insertar' ( Insert )

to make a prairie 5.png]]

  • Se mostrará la sintaxis CLOZE correcta

to make a prairie 6.png]]

  • Guarde la pregunta
  • Revise que la pregunta funciona como Usted lo espera

to make a prairie 7.png]]

El botón editor cloze y los roles de Moodle

El botón del editor CLOZE será visible para los profesores y para los estudiantes también, cada vez que usen el Editor HTML, aun cuando estuvieran escribiendo cualquier otro texto no relacionado con una pregunta cloze (por ejemplo, en un foro).

Otros idiomas

  • Las cadenas de texto en idioma Inglés para este plugin pueden traducirse desde AMOS. Para febrero del 2014 ya estaba hecha la traducción al Español de México.
  • Si no existe una traducción para su paquete de Idioma, Usted puede hacer una Personalización del idioma, puede tener el editor cloze en su idioma preferido.
  • Vea la traducción siguiente al Español de México:

cloze editor language customization.png

  • Y aquí están las cadenas de texto traducidas al Español empleadas en el plugin:

Cloze editor in spanish.png

  • La siguiente imagen muestra una traducción francesa de este plugin:

CLOZE editor fr language.png

Corrigiendo el problema de que 'la pantalla no es suficientemente ancha'

Con algunos navegadores de Internet la pantalla no es lo suficientemente ancha. CLOZE editor issue screen not wide enough.png

  • Para corregir esto, Usted necesitará editar el archivo lib/editor/tinymce/plugins/clozeeditor/tinymce/editorplugin.js
  • Allí, deberá cambiar el valor del ancho 'width' (que originalmente es de 490) a 620 (pixeles).

CLOZE editor editing editor plugin js.png

  • Usted puede usar un editor de texto como Notepad ++. No intente usar Word para Windows.
  • No olvide limpiar las cachés: del navegador y de Moodle

Editor Cloze para Atto

En 2016, Daniel Thies creó el plugin adicional del Editor cloze para Atto.

Vea también