Requisitos para instalación de moodle 2.6

Saltar a: navegación, buscar
  • Un sistema operativo (¡!). Cualquiera que corra el siguiente software, aunque la elección muy probablemente dependerá del desempeño que necesite y las habilidades que tenga disponibles. Linux y Windows son las elecciones más comunes y para las que existe buen soporte disponible. Si Usted puede elegir libremente, Linux es considerado generalmente como la plataforma óptima. Moodle también se prueba regularmente con los sistemas operativos Windows XP/200/2003, Solaris 10 (Sparc y x64), Mac OS X y Netware 6.
  • Un servidor web. Primariamente Apache o IIS . No está completamente probado (o soportado) pero debería de funcionar con lightttpd, nginx, cherokee, zeus y LiteSpeed. Moodle se rehusará a instalarse en cualquier otro servidor web diferente a los descritos. Su servidor web debe de estar configurado correctamente para servir archivos PHP. La versión no es crítica pero se le recomienda instalar el paquete con la versión más reciente que tenga disponible.
  • PHP - La versión mínima para Moodle 2.6 es la 5.3.3. Moodle 2.7 requiere PHP 5.4.4 o superior.

Se requieren varias extensiones; vea la página de PHP para los detalles completos. La instalación de Moodle se detendrá durante la revisión del entorno si faltara alguna de las extensiones requeridas. Si estuviera disponible, PHP 5.5 y más recientes contienen OPcache, que es altamente recomendable (Usted puede ignorar la revisión del Entorno para esto si no estuviera disponible.

  • Una base de datos. MySQL y PostgreSQL son las bases de datos para desarrollo primario, las más completamente probadas y las que tienen abundante documentación y soporte. MSSQL es completamente soportadas (tome nota de que los plugins opcionales pueden estar no probados con estas bases de datos) pero la documentación y ayuda en línea no son tan completas como con MySQL/PostgreSQL. La Base de Datos de Oracle no está completamente soportada y no está recomendada. Si ttiene dudas use MySQL (tiene más documentación) o PostgreSQL (tiene mejor estabilidad y desempeño). Usted necesitará la extensión de PHP apropiada (configurada si lo requiere) para su base de datos elegida.
    • MySQL - versión mínima 5.1.33; Moodle 2.7 requiere MySQL 5.5.31
    • MariaDB - versión mínima 5.3.5 (remplazo completo para MySQL)
    • PostgreSQL - versión mínima 8.3
    • MSSQL - versión mínima 9.0
    • Oracle - versión mínima 10.2 (no recomendada)
  • Navegador mínimo para accesar Moodle: versiones recientes de Firefox, Internet Explorer 9, Safari 6, Google Chrome 11 reciente (versiones inferiores podrían funcionar pero no están completamente soportadas)

,

Cliente

  • Sus clientes/usuarios accesan Moodle desde un navegador web en su PC/tableta/laptop. Cualquier navegador moderno debería de funcionar (pero Internet Explorer 6 y anteriores NO están soportados). El sistema operativo no es importante pero Usted puede necesitar programas para leer los archivos que haya subido por ejemplo: Si sube archivos de texto de Microsoft Word, sus usuarios necesitarán un programa para poderlos leer).

Vea también...

Especialmente si Usted está planeando una instalación grande o compleja, lea Desempeño y (en particular) las Preguntas frecuentes sobre rendimiento para entender algunos términos y preocupaciones comunes.