Actualización de moodle 1.6

Saltar a: navegación, buscar

Moodle 1.6

Debido a que la actualización de Moodle 1.5.x a Moodle 1.6 no solo cambia la estructura de la base de datos, sino ademas el contenido de la misma, es IMPORTANTE tomar algunas consideraciones antes de realizar cualquier cambio.

(IMPORTANTE) Verificar los requerimientos del sistema (IMPORTANTE)

Ir a la opción Administración >> Entorno y seleccionar Moodle 1.6 ;-) Va obtener un reporte donde indica si su servidor reune los requerimientos necesarios para utilizar Moodle 1.6 y que necesita hacer de no tenerlos. Básicamente necesitará que su servidor tenga instalados PHP 4.3.0 o versión mas actual (para PHP5, la versión 5.1.0 o mas actual es requerida), y en MySQL se requiere 4.1.16 o versión mas nueva (4.1.12 esta bien si su lugar utiliza solamente caracteres tipo Latin) o PostgreSQL. Soporte nativo de la función iconv agilizará los procesos (necesita ser especificado al momento de compilación) pero no es requerido.

Actualizar los archivos de Moodle

Realizar una actualización regular de su instalación Moodle, TOMANDO CUIDADO ESPECIAL cuando saque respaldo de sus bases de datos. Ponga cuidado de incluir TODOS los modulos opcionales que haya adicionado a su actual instalación. La Conversión de los datos a UTF-8 de estos modulos no va ser posible si se olvida de estos.

Migración de la Base Datos

Aunque no es estrictamente necesario, es muy recomendable que realize la migración de su base de datos a UTF-8 inmediatamente despues de actualizar a 1.6. Antes, verificar si su portal trabaja apropiadamente (ej. modulos opcionales).

Si su portal trabaja en solo un lenguage, seleccione esta opción para acortar el tiempo de la migración. De otra manera Moodle deberá encontrar formas para hacer la migración de cada pieza de información basado en el lenguage del usuario, curso y portal. La migración es un proceso que utiliza bastante recurso de procesador y de memoria y puede tomar mucho tiempo para realizarla, debe escoger el momento de migración con sumo cuidado. Es una buena práctica hacer primero una conversión de prueba si tiene algún portal de experimentación.

El proceso de migración va poner la instalación Moodle (Portal) en Modo de mantenimiento de tal manera que solo administradores tendran acceso. A fin de evitar tener que reiniciar el proceso de migración, es recomendable que el valor del paremetro max_execution_time Texto en cursiva en el archivo php.ini sea puesto con valor 0 (cero) de tal manera que el proceso no se interrumpa. Después que la migración ha sido completada, el parámetro de tiempo de ejecución puede ser devuelto a su valor normal. El proceso de migración guarda continuamente el actual parámetro de estado (current state) durante la ejecución, de tal manera que si el proceso tuviera que ser restablecido, va comenzar aproximadamente donde fue interrumpido. De todas maneras una vez iniciado el proceso de migración, este necesita terminarse antes que el sitio Moodle pueda ser utilizado por otros.

Lenguajes

Ha sido diseñada una interface para lenguajes completamente nueva. Después de la migración de la base de datos, ir a a Administración >> Configuración >> Idioma y siga el enlace Utilidad de importación de idioma en donde podrá seleccionar los paquetes lingúísticos deseados que se encuentran en el panel derecho e instalarlos directamente. Las actualizaciones de paquetes lingüísticos pueden ser hechos de una manera bastante sencilla siguiendo el enlace de actualización. Deje que Moodle haga la descarga y la instalación de lenguaje/s (paquete/s lingüístico/s) por usted.

Los paquetes lingüísticos personalizados deberán instalarse en el directrio moodledata/lang. Estos deberan estar en un direcorio de la forma xx_utf8 y deberán ser codificados en utf8.

Para localizaciones de paquetes lingüísticos xx_utf8 se deberá nombrarlos como xx_utf8_local, estos deberan estar codificados en utf8 e instalarse en el directorio moodledata/lang. Es posible nombrar el directorio de otra manera, ej. xx_mipaquete_utf8, pero deberá adicionar el texto 'parentlanguage' en moodle.php desde su localización.

Debe usar siempre un paquete lingüístico que corresponda al contenido de su base de datos:

* Upgraded installations: first database migration, then utf8 langpacks
* New 1.6 installations: immediately use utf8 langpacks

No vá encontrar el paquete lingüístico en_utf8 en el directorio moodledata/lang. Se encuentra en el directorio moodle/lang y no debe realizar ninguna modificación. Nunca deberá actualizarse debido a que forma parte de la instalación. Todos los otros paquetes lingüísticos, y alguna modificación del paquete Inglés, deberán ir en el directorio moodledata/lang (los paquetes en Inglés están en la forma en_utf8_local o en_xx_utf8 pero además con la cadena 'parentlanguage' en moodle.php).

Si utiliza la variable del langlist en la página de configuración de las Variables, no olvide cambiar los nombres del idioma a partir de xx a xx_utf8 o las idiomas no se mostrarán en el menú desplegable del idioma.

IMPORTANTE: Recuerde cambiar su configuración de la variable "locale", en "Administración, Configuración, Variables, locale:" al correspondiente valor UTF-8, tal como se ve en la Tabla de locales (en.UTF-8 , es_ES.UTF-8,...). Esto hará que se puedan visualizar correctamente fechas y horas en su lenguaje local (por ejemplo en la Actividad reciente, mensajes mandados a los foros, etc.)

Mirar además

Foros de discusión en Moodle:

Enlaces Externos

  • [1]us3.php.net/iconv