Notes de mise à jour de Moodle 3.0.1

De MoodleDocs
Révision datée du 15 mars 2017 à 10:20 par Séverin Terrier (discussion | contributions)
(diff) ← Version précédente | Voir la version actuelle (diff) | Version suivante → (diff)

Date de sortie : 21 décembre 2015

Vous pouvez consulter la liste des détails sur les évolutions et corrections de bogues de cette version 3.0.1 (en anglais).

Changements importants

Moodle 3.0.1 est une version spéciale en dehors du cycle habituel des versions planifiées. La principale amélioration est le support de PHP 7.0. C'est la nouvelle version majeure du langage de programmation utilisé pour Moodle ; elle a des performances largement améliorées et beaucoup de changements dans son moteur interne. Veuillez noter que Moodle 2.9.x affichera des erreurs s'il est utilisé avec PHP 7.

Avant de mettre à jour vers PHP 7.0 vos serveurs de production, nous vous recommandons fortement de tester activement tous vos plugins. Voyez Moodle et PHP7 pour la documentation développeur.

PHP 7.0 est sorti le 3 décembre 2015 et est actuellement très jeune. Toutes les librairies et/ou pilotes ne sont pas encore disponibles pour PHP 7. Par exemple, il n'y a pas de pilote pour SQL*Server. D'autres pilotes requis par vos plugins peuvent également être manquants.

Sécurité

Pas de correction de sécurité dans cette version. Plusieurs problèmes de sécurité sont corrigés dans Moodle 3.0.2.

Corrections et améliorations

  • MDL-44330 - When using assignment grading in several tabs the links to individual students grades work correctly
  • MDL-37834 - Excel can be used to edit the assignment offline grading worksheet
  • MDL-42571 - Edit PDF: Fixed bug with viewing a second PDF on the assignment grading page
  • MDL-43069 - Assignment grading: "Submission comments" fail to expand if you hide the "file submissions" column
  • MDL-37308 - Uploaded PNG images preserve transparency when resized
  • MDL-49490 - Fixed export to portfolio link in assignment with additional files
  • MDL-52194 - Correction de Flowplayer qui ne fonctionnait pas avec une configuration non sécurisé de request_order

Pour les développeurs

  • MDL-51582 - Passage à grunt pour compiler LESS (recess n'étant plus maintenu)

Voir aussi