Historique des versions : Différence entre versions

(Moodle 3.8)
m (Versions supportées)
(Une révision intermédiaire par le même utilisateur non affichée)
Ligne 36 : Ligne 36 :
 
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 11 mai 2020
 
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 11 mai 2020
 
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 9 novembre 2020
 
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 9 novembre 2020
 +
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer ou supprimer en temps utiles !
 +
|-
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 3.8
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color:#f98012; padding: .3rem 0.5rem 0.3rem 0.5rem;" | Stable supportée actuelle
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 18 novembre 2019
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 9 novembre 2020
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 10 mai 2021
 +
|-
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 3.9
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color:#f98012; padding: .3rem 0.5rem 0.3rem 0.5rem;" | Stable supportée actuelle
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 11 mai 2020
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 10 mai 2021
 +
| style="vertical-align: top; border-top: 1px solid #dee2e6; background-color: #FFFFFF" | 8 mai 2023
 +
</includeonly>
 
|}
 
|}
  
Ligne 153 : Ligne 167 :
 
|-
 
|-
 
! Moodle 3.7.3
 
! Moodle 3.7.3
| prévue le 11 novembre 2019 (en cours de développement)
+
| 11 novembre 2019
 
| 2019052003
 
| 2019052003
 
| [[Notes de mise à jour de Moodle 3.7.3|Notes de mise à jour]]
 
| [[Notes de mise à jour de Moodle 3.7.3|Notes de mise à jour]]
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 
 
|-
 
|-
 
! Moodle 3.7.4
 
! Moodle 3.7.4
 
| prévue le 13 janvier 2020 (en cours de développement)
 
| prévue le 13 janvier 2020 (en cours de développement)
 
| 2019052004
 
| 2019052004
| [[Notes de mise à jour de Moodle 3.7.4|Notes de mise à jour]]|-
+
| [[Notes de mise à jour de Moodle 3.7.4|Notes de mise à jour]]
 +
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 +
|-
 
! Moodle 3.7.5
 
! Moodle 3.7.5
 
| prévue le 9 mars 2020 (en cours de développement)
 
| prévue le 9 mars 2020 (en cours de développement)
Ligne 227 : Ligne 242 :
 
|-
 
|-
 
! Moodle 3.6.7
 
! Moodle 3.6.7
| prévue le 11 novembre 2019 (en cours de développement)
+
| 11 novembre 2019
 
| 2018120307
 
| 2018120307
 
| [[Notes de mise à jour de Moodle 3.6.7|Notes de mise à jour]]
 
| [[Notes de mise à jour de Moodle 3.6.7|Notes de mise à jour]]
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 
 
|-
 
|-
 
! Moodle 3.6.8
 
! Moodle 3.6.8
Ligne 236 : Ligne 250 :
 
| 2018120308
 
| 2018120308
 
| [[Notes de mise à jour de Moodle 3.6.8|Notes de mise à jour]]
 
| [[Notes de mise à jour de Moodle 3.6.8|Notes de mise à jour]]
 +
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 
|-
 
|-
 
! Moodle 3.6.9
 
! Moodle 3.6.9
Ligne 313 : Ligne 328 :
 
|-
 
|-
 
! Moodle 3.5.9
 
! Moodle 3.5.9
| prévue le 11 novembre 2019 (en cours de développement)
+
| 11 novembre 2019
 
| 2018051709
 
| 2018051709
 
| [[Notes de mise à jour de Moodle 3.5.9|Notes de mise à jour]]
 
| [[Notes de mise à jour de Moodle 3.5.9|Notes de mise à jour]]
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 
 
|-
 
|-
 
! Moodle 3.5.10
 
! Moodle 3.5.10
Ligne 322 : Ligne 336 :
 
| 2018051710
 
| 2018051710
 
| [[Notes de mise à jour de Moodle 3.5.10|Notes de mise à jour]]
 
| [[Notes de mise à jour de Moodle 3.5.10|Notes de mise à jour]]
 +
<includeonly> On masque cette partie actuellement ; ces balises seront à déplacer en temps utiles (et supprimer quand le support est terminé) !
 
|-
 
|-
 
! Moodle 3.5.11
 
! Moodle 3.5.11

Version du 8 novembre 2019 à 13:16

Cette page liste l'intégralité des versions de Moodle. Cliquez sur "Notes de mise à jour" pour plus de détails sur les modifications apportées par la version de votre choix.

Les informations détaillées concernant l'application pour mobile (téléphones et tablettes) ou l'application de bureau ne sont pas traduites en français. Vous pouvez trouver (en anglais) les fonctionnalités de l'app Moodle, les nouveautés de la dernière version, les détails des notes de mise à jour de l'app Moodle ainsi que la planification pour les versions à venir. Les notes de mise à jour de l'application de bureau sont également disponibles.

Versions supportées

Depuis Moodle 2.6, la fin du support, que ce soit pour les bogues ou les correctifs de sécurité, est fixée au second lundi de mai et novembre, en observant les cycles respectifs de 12 et 18 mois, et ceci que la date de sortie de la version majeure ait été retardée ou non. Si des versions supplémentaires sortent entre-temps, afin de corriger des problèmes sérieux (de sécurité), cela n'affectera pas le calendrier prévu de nouvelles versions !

Les versions supportées actuellement sont : Moodle 3.5 (LTS), Moodle 3.6 et Moodle 3.7.

Version Statut Date de sortie initiale Fin du support de bogues Fin du support de sécurité
3.5 (LTS) Supportée pour la sécurité 17 mai 2018 13 mai 2019 10 mai 2021
3.6 Stable supportée actuelle 3 décembre 2018 11 novembre 2019 11 mai 2020
3.7 Stable supportée actuelle 20 mai 2019 11 mai 2020 9 novembre 2020

Versions supportées à long terme (LTS)

Des versions supportées à long terme (uniquement pour les bogues de sécurité, de confidentialité des données et de perte de données) devraient sortir tous les 2 ans, au mois de mai. La première était Moodle 2.7, la seconde Moodle 3.1, la troisième Moodle 3.5 (sortie en mai 2018) et la prochaine sera Moodle 3.9 (en mai 2020).

Pour mettre à jour vers une version LTS, il faut au minimum la précédente version LTS (décidé dans MDL-59159) : Moodle 2.7 minimum pour passer en version 3.1 et Moodle 3.1 minimum pour passer en version 3.5.

Attention : dans l'idée des développeurs de Moodle, avoir une version supportée à long terme ne doit pas encourager à rester sur une version ancienne. Les montées de version devraient être faites régulièrement, sauf réelle impossibilité !

Calendrier des sorties de versions

Voici les dates prévues pour les nouvelles versions. Ces dates peuvent varier légèrement en cas de circonstances particulières.

Type de version Fréquence Date
Majeure (ex : 3.x) 6 mois Second lundi de mai et novembre
Mineure (ex : 3.x.y) 2 mois Second lundi de janvier, mars, mai, juillet, septembre et novembre

Toutes les sorties de nouvelles versions sont précédées d'un avertissement pendant une semaine. Les dates des versions à venir sont disponibles dans le calendrier de développement de Moodle (lien iCal).

Planification

Si vous souhaitez en savoir plus sur ce qui est planifié pour les versions à venir, veuillez consulter la page dédiée à la planification.

Développements en cours

Si vous souhaitez suivre les développements en cours, vous pouvez consulter :


Moodle 3.8

La mise à jour vers Moodle 3.8 sera possible depuis Moodle 3.2 minimum !

Moodle 3.8 nécessitera PHP 7.1 minimum (et supportera PHP 7.2 et PHP 7.3) !

Cette version est en cours de développement, et prévue pour le 18 novembre 2019, à ne PAS utiliser en exploitation !

Vous pourrez trouver quelques informations dans la planification des versions à venir et (bien plus tardivement) les Notes de mise à jour de Moodle 3.8.

Les pré-requis techniques sont déterminés dans MDL-64614.

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.8 Prévue le 18 novembre 2019 (en cours de développement, à ne PAS utiliser en exploitation !) prévue 2019111800 Notes de mise à jour

Moodle 3.7

Vous pouvez consulter les Nouveautés de Moodle 3.7 et les instructions de Mise à jour vers Moodle 3.7.x (à partir de Moodle 3.2 minimum).

Moodle 3.7 nécessite PHP 7.1 minimum (et supporte PHP 7.2 et PHP 7.3) ! Les pré-requis techniques évoluent : PHP 7.1 minimum !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.7 20 mai 2019 2019052000 Notes de mise à jour
Moodle 3.7.1 8 juillet 2019 2019052001 Notes de mise à jour
Moodle 3.7.2 9 septembre 2019 2019052002 Notes de mise à jour
Moodle 3.7.3 11 novembre 2019 2019052003 Notes de mise à jour
Moodle 3.7.4 prévue le 13 janvier 2020 (en cours de développement) 2019052004 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.7 sur une seule page, et la Liste des plugins compatibles Moodle 3.7.

Les bogues de la branche 3.7.x seront corrigés jusqu'au 11 mai 2020 (12 mois).
Les correctifs de sécurité de la branche 3.7.x seront assurés jusqu'au 9 novembre 2020 (18 mois).

Moodle 3.6

Vous pouvez consulter les Nouveautés de Moodle 3.6 et les instructions de Mise à jour vers Moodle 3.6.x (à partir de Moodle 3.1 minimum).

Moodle 3.6 nécessite PHP 7.0 minimum (et supporte PHP 7.1 et PHP 7.2) ! Une version 64 bits est recommandée. Le support de PHP 7.3.x est implémenté (@ MDL-63420) mais est prêt pour la production seulement à partir de Moodle 3.6.4. Les prérequis techniques évoluent : MySQL 5.6, PostgreSQL 9.4 et Oracle 11.2 minimum !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.6 3 décembre 2018 2018120300 Notes de mise à jour
Moodle 3.6.1 5 décembre 2018 2018120301 Notes de mise à jour
Moodle 3.6.2 14 janvier 2019 2018120302 Notes de mise à jour
Moodle 3.6.3 11 mars 2019 2018120303 Notes de mise à jour
Moodle 3.6.4 13 mai 2019 2018120304 Notes de mise à jour
Moodle 3.6.5 8 juillet 2019 2018120305 Notes de mise à jour
Moodle 3.6.6 9 septembre 2019 2018120306 Notes de mise à jour
Moodle 3.6.7 11 novembre 2019 2018120307 Notes de mise à jour
Moodle 3.6.8 prévue le 13 janvier 2020 (en cours de développement) 2018120308 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.6 sur une seule page, et la Liste des plugins compatibles Moodle 3.6.

Les bogues de la branche 3.6.x seront corrigés jusqu'au 11 novembre 2019 (12 mois).
Les correctifs de sécurité de la branche 3.6.x seront assurés jusqu'au 11 mai 2020 (18 mois).

Moodle 3.5 (LTS)

Vous pouvez consulter les Nouveautés de Moodle 3.5 et les instructions de Mise à jour vers Moodle 3.5.x (à partir de Moodle 3.1 minimum).

Moodle 3.5 nécessite PHP 7.0 minimum (et supporte PHP 7.1 et PHP 7.2) ! Les prérequis techniques restent les mêmes que Moodle 3.4.

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.5 17 mai 2018 2018051700 Notes de mise à jour
Moodle 3.5.1 9 juillet 2018 2018051701 Notes de mise à jour
Moodle 3.5.2 10 septembre 2018 2018051702 Notes de mise à jour
Moodle 3.5.3 12 novembre 2018 2018051703 Notes de mise à jour
Moodle 3.5.4 14 janvier 2019 2018051704 Notes de mise à jour
Moodle 3.5.5 11 mars 2019 2018051705 Notes de mise à jour
Moodle 3.5.6 13 mai 2019 2018051706 Notes de mise à jour
Moodle 3.5.7 8 juillet 2019 2018051707 Notes de mise à jour
Moodle 3.5.8 9 septembre 2019 2018051708 Notes de mise à jour
Moodle 3.5.9 11 novembre 2019 2018051709 Notes de mise à jour
Moodle 3.5.10 prévue le 13 janvier 2020 (en cours de développement) 2018051710 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.5 sur une seule page, et la Liste des plugins compatibles Moodle 3.5.

Les bogues de la branche 3.5.x ont été corrigés jusqu'au 13 mai 2019 (12 mois).
Les correctifs de sécurité de la branche 3.5.x seront assurés jusqu'au 10 mai 2021 (36 mois), cette branche étant supportée à long terme.

Moodle 3.4

Vous pouvez consulter les Nouveautés de Moodle 3.4 et les instructions de Mise à jour vers Moodle 3.4.x (à partir de Moodle 3.0 minimum).

Moodle 3.4 nécessite PHP 7.0 minimum (et supporte PHP 7.1 et PHP 7.2) ! Les autres prérequis techniques restent les mêmes que Moodle 3.3.

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.4 13 novembre 2017 2017111300 Notes de mise à jour
Moodle 3.4.1 15 janvier 2018 2017111301 Notes de mise à jour
Moodle 3.4.2 19 mars 2018 2017111302 Notes de mise à jour
Moodle 3.4.3 17 mai 2018 2017111303 Notes de mise à jour
Moodle 3.4.4 9 juillet 2018 2017111304 Notes de mise à jour
Moodle 3.4.5 10 septembre 2018 2017111305 Notes de mise à jour
Moodle 3.4.6 12 novembre 2018 2017111306 Notes de mise à jour
Moodle 3.4.7 14 janvier 2019 2017111307 Notes de mise à jour
Moodle 3.4.8 11 mars 2019 2017111308 Notes de mise à jour
Moodle 3.4.9 13 mai 2019 2017111309 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.4 sur une seule page, et la Liste des plugins compatibles Moodle 3.4.

Les bogues de la branche 3.4.x ont été corrigés jusqu'au 12 novembre 2018 (12 mois).
Les correctifs de sécurité de la branche 3.4.x ont été assurés jusqu'au 13 mai 2019 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 3.4.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 3.3

Vous pouvez consulter les Nouveautés de Moodle 3.3 et les instructions de Mise à jour vers Moodle 3.3.x (à partir de Moodle 2.7 minimum).

Moodle 3.3 nécessite PHP 5.6.5 minimum (et supporte PHP 7.0 et PHP 7.1) ! Vérifiez les autres prérequis techniques de Moodle 3.3.

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.3 15 mai 2017 2017051500 Notes de mise à jour
Moodle 3.3.1 10 juillet 2017 2017051501 Notes de mise à jour
Moodle 3.3.2 11 septembre 2017 2017051502 Notes de mise à jour
Moodle 3.3.3 13 novembre 2017 2017051503 Notes de mise à jour
Moodle 3.3.4 15 janvier 2018 2017051504 Notes de mise à jour
Moodle 3.3.5 19 mars 2018 2017051505 Notes de mise à jour
Moodle 3.3.6 17 mai 2018 2017051506 Notes de mise à jour
Moodle 3.3.7 9 juillet 2018 2017051507 Notes de mise à jour
Moodle 3.3.8 10 septembre 2018 2017051508 Notes de mise à jour
Moodle 3.3.9 12 novembre 2018 2017051509 Notes de mise à jour
Moodle 3.3.9+ 1 février 2019 2017051509.03 Dernières modifications

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.3 sur une seule page, et la Liste des plugins compatibles Moodle 3.3.

Les bogues de la branche 3.3.x ont été corrigés jusqu'au 17 mai 2018 (12 mois).
Les correctifs de sécurité de la branche 3.3.x ont été assurés jusqu'au 12 novembre 2018 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 3.3.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 3.2

Vous pouvez consulter les Nouveautés de Moodle 3.2 et les instructions de Mise à jour vers Moodle 3.2.x (à partir de Moodle 2.7 minimum).

Moodle 3.2 nécessite PHP 5.6.5 minimum (et supporte PHP 7.0 et PHP 7.1) ! Les autres prérequis restent les mêmes que Moodle 3.1.

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.2 5 décembre 2016 2016120500 Notes de mise à jour
Moodle 3.2.1 9 janvier 2017 2016120501 Notes de mise à jour
Moodle 3.2.2 13 mars 2017 2016120502 Notes de mise à jour
Moodle 3.2.3 8 mai 2017 2016120503 Notes de mise à jour
Moodle 3.2.4 10 juillet 2017 2016120504 Notes de mise à jour
Moodle 3.2.5 11 septembre 2017 2016120505 Notes de mise à jour
Moodle 3.2.6 13 novembre 2017 2016120506 Notes de mise à jour
Moodle 3.2.7 15 janvier 2018 2016120507 Notes de mise à jour
Moodle 3.2.8 19 mars 2018 2016120508 Notes de mise à jour
Moodle 3.2.9 17 mai 2018 2016120509 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.2 sur une seule page, et la Liste des plugins compatibles Moodle 3.2.

Les bogues de la branche 3.2.x ont été corrigés jusqu'au 13 novembre 2017 (12 mois).
Les correctifs de sécurité de la branche 3.2.x ont été assurés jusqu'au 17 mai 2018 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 3.2.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 3.1 (LTS)

Vous pouvez consulter les Nouveautés de Moodle 3.1 et les instructions de Mise à jour vers Moodle 3.1.x (à partir de Moodle 2.7 minimum).

Moodle 3.1 nécessite PHP 5.4.4 minimum (et supporte PHP 7.0) !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.1 23 mai 2016 2016052300 Notes de mise à jour
Moodle 3.1.1 11 juillet 2016 2016052301 Notes de mise à jour
Moodle 3.1.2 12 septembre 2016 2016052302 Notes de mise à jour
Moodle 3.1.3 14 novembre 2016 2016052303 Notes de mise à jour
Moodle 3.1.4 9 janvier 2017 2016052304 Notes de mise à jour
Moodle 3.1.5 13 mars 2017 2016052305 Notes de mise à jour
Moodle 3.1.6 8 mai 2017 2016052306 Notes de mise à jour
Moodle 3.1.7 10 juillet 2017 2016052307 Notes de mise à jour
Moodle 3.1.8 11 septembre 2017 2016052308 Notes de mise à jour
Moodle 3.1.9 13 novembre 2017 2016052309 Notes de mise à jour
Moodle 3.1.10 15 janvier 2018 2016052310 Notes de mise à jour
Moodle 3.1.11 19 mars 2018 2016052311 Notes de mise à jour
Moodle 3.1.12 17 mai 2018 2016052312 Notes de mise à jour
Moodle 3.1.13 9 juillet 2018 2016052313 Notes de mise à jour
Moodle 3.1.14 10 septembre 2018 2016052314 Notes de mise à jour
Moodle 3.1.15 12 novembre 2018 2016052315 Notes de mise à jour
Moodle 3.1.16 14 janvier 2019 2016052316 Notes de mise à jour
Moodle 3.1.17 11 mars 2019 2016052317 Notes de mise à jour
Moodle 3.1.18 13 mai 2019 2016052318 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.1 sur une seule page, et la Liste des plugins compatibles Moodle 3.1.

Les bogues de la branche 3.1.x ont été corrigés jusqu'au 8 mai 2017 (12 mois).
Les correctifs de sécurité de la branche 3.1.x ont été assurés jusqu'au 13 mai 2019 (36 mois), cette branche étant supportée à long terme.
Le support de cette branche est terminé !
Si vous utilisez Moodle 3.1.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 3.0

La version 3.0 est la suite de Moodle 2.9, et n'introduit pas de changement majeur aussi important que lors du passage 1.9 vers Moodle 2.0 (elle aurait pu être nommée 2.10).

Vous pouvez consulter les Nouveautés de Moodle 3.0 et les instructions de Mise à jour vers Moodle 3.0.x (à partir de Moodle 2.2 minimum).

Moodle 3.0 nécessite PHP 5.4.4 minimum (et supporte PHP 7.0 à partir de Moodle 3.0.1) !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 3.0 16 novembre 2015 2015111600 Notes de mise à jour
Moodle 3.0.1 21 décembre 2015 2015111601 Notes de mise à jour
Moodle 3.0.2 11 janvier 2016 2015111602 Notes de mise à jour
Moodle 3.0.3 14 mars 2016 2015111603 Notes de mise à jour
Moodle 3.0.4 9 mai 2016 2015111604 Notes de mise à jour
Moodle 3.0.5 11 juillet 2016 2015111605 Notes de mise à jour
Moodle 3.0.6 12 septembre 2016 2015111606 Notes de mise à jour
Moodle 3.0.7 14 novembre 2016 2015111607 Notes de mise à jour
Moodle 3.0.8 9 janvier 2017 2015111608 Notes de mise à jour
Moodle 3.0.9 13 mars 2017 2015111609 Notes de mise à jour
Moodle 3.0.10 8 mai 2017 2015111610 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 3.0 sur une seule page, et la Liste des plugins compatibles Moodle 3.0.

Les bogues de la branche 3.0.x ont été corrigés jusqu'au 14 novembre 2016 (12 mois).
Les correctifs de sécurité de la branche 3.0.x ont été assurés jusqu'au 8 mai 2017 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 3.0.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 2.9

Vous pouvez consulter les Nouveautés de Moodle 2.9 et les instructions de Mise à jour vers Moodle 2.9.x (à partir de Moodle 2.2 minimum).

Moodle 2.9 nécessite PHP 5.4.4 minimum (attention : PHP 7.0 n'est pas supporté) !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.9 11 mai 2015 2015051100 Notes de mise à jour
Moodle 2.9.1 6 juillet 2015 2015051101 Notes de mise à jour
Moodle 2.9.2 14 septembre 2015 2015051102 Notes de mise à jour
Moodle 2.9.3 9 novembre 2015 2015051103 Notes de mise à jour
Moodle 2.9.4 11 janvier 2016 2015051104 Notes de mise à jour
Moodle 2.9.5 14 mars 2016 2015051105 Notes de mise à jour
Moodle 2.9.6 9 mai 2016 2015051106 Notes de mise à jour
Moodle 2.9.7 11 juillet 2016 2015051107 Notes de mise à jour
Moodle 2.9.8 12 septembre 2016 2015051108 Notes de mise à jour
Moodle 2.9.9 14 novembre 2016 2015051109 Notes de mise à jour
Moodle 2.9.9+ 29 novembre 2016 2015051109.02 Dernières modifications

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 2.9 sur une seule page, et la Liste des plugins compatibles Moodle 2.9.

Les bogues de la branche 2.9.x ont été corrigés jusqu'au 9 mai 2016 (12 mois).
Les correctifs de sécurité de la branche 2.9.x ont été assurés jusqu'au 14 novembre 2016 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.9.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 2.8

Vous pouvez consulter les Nouveautés de Moodle 2.8 et les instructions de Mise à jour vers Moodle 2.8.x (à partir de Moodle 2.2 minimum).

Moodle 2.8 nécessite PHP 5.4.4 minimum (attention : PHP 7.0 n'est pas supporté) !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.8 10 novembre 2014 2014111000 Notes de mise à jour
Moodle 2.8.1 13 novembre 2014 2014111001 Notes de mise à jour
Moodle 2.8.2 12 janvier 2015 2014111002 Notes de mise à jour
Moodle 2.8.3 2 février 2015 2014111003 Notes de mise à jour
Moodle 2.8.4 9 mars 2015 2014111004 Notes de mise à jour
Moodle 2.8.5 10 mars 2015 2014111005 Notes de mise à jour
Moodle 2.8.6 11 mai 2015 2014111006 Notes de mise à jour
Moodle 2.8.7 6 juillet 2015 2014111007 Notes de mise à jour
Moodle 2.8.8 14 septembre 2015 2014111008 Notes de mise à jour
Moodle 2.8.9 9 novembre 2015 2014111009 Notes de mise à jour
Moodle 2.8.10 11 janvier 2016 2014111010 Notes de mise à jour
Moodle 2.8.11 14 mars 2016 2014111011 Notes de mise à jour
Moodle 2.8.12 9 mai 2016 2014111012 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 2.8 sur une seule page, et la Liste des plugins compatibles Moodle 2.8.

Les bogues de la branche 2.8.x ont été corrigés jusqu'au 9 novembre 2015 (12 mois).
Les correctifs de sécurité de la branche 2.8.x ont été assurés jusqu'au 9 mai 2016 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.8.x (ou antérieur), vous devriez mettre à jour vers une version récente et maintenue.

Moodle 2.7 (LTS)

Vous pouvez consulter les Nouveautés de Moodle 2.7 et les instructions de Mise à jour vers Moodle 2.7.x (à partir de Moodle 2.2 minimum).

Moodle 2.7 nécessite PHP 5.4.4 minimum (attention : PHP 7.0 n'est pas supporté) !

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.7 12 mai 2014 2014051200 Notes de mise à jour
Moodle 2.7.1 14 juillet 2014 2014051201 Notes de mise à jour
Moodle 2.7.2 8 septembre 2014 2014051202 Notes de mise à jour
Moodle 2.7.3 10 novembre 2014 2014051203 Notes de mise à jour
Moodle 2.7.4 12 janvier 2015 2014051204 Notes de mise à jour
Moodle 2.7.5 2 février 2015 2014051205 Notes de mise à jour
Moodle 2.7.6 9 mars 2015 2014051206 Notes de mise à jour
Moodle 2.7.7 10 mars 2015 2014051207 Notes de mise à jour
Moodle 2.7.8 11 mai 2015 2014051208 Notes de mise à jour
Moodle 2.7.9 6 juillet 2015 2014051209 Notes de mise à jour
Moodle 2.7.10 14 septembre 2015 2014051210 Notes de mise à jour
Moodle 2.7.11 9 novembre 2015 2014051211 Notes de mise à jour
Moodle 2.7.12 11 janvier 2016 2014051212 Notes de mise à jour
Moodle 2.7.13 14 mars 2016 2014051213 Notes de mise à jour
Moodle 2.7.14 9 mai 2016 2014051214 Notes de mise à jour
Moodle 2.7.15 11 juillet 2016 2014051215 Notes de mise à jour
Moodle 2.7.16 12 septembre 2016 2014051216 Notes de mise à jour
Moodle 2.7.17 14 novembre 2016 2014051217 Notes de mise à jour
Moodle 2.7.18 9 janvier 2017 2014051218 Notes de mise à jour
Moodle 2.7.19 13 mars 2017 2014051219 Notes de mise à jour
Moodle 2.7.20 8 mai 2017 2014051220 Notes de mise à jour

Vous pouvez aussi consulter la totalité des notes de mise à jour de la branche Moodle 2.7 sur une seule page, et la Liste des plugins compatibles Moodle 2.7.

Les bogues de la branche 2.7.x ont été corrigés jusqu'au 11 mai 2015 (12 mois).
Les correctifs de sécurité de la branche 2.7.x ont été assurés jusqu'au 8 mai 2017 (36 mois), cette branche ayant été supportée à long terme.
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.7.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.7.20, puis mettre à jour vers une version récente et maintenue.

Moodle 2.6

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.6 sur une seule page, et les instructions de Mise à jour vers Moodle 2.6.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.6 18 novembre 2013 2013111800 Notes de mise à jour
Moodle 2.6.1 13 janvier 2014 2013111801 Notes de mise à jour
Moodle 2.6.2 10 mars 2014 2013111802 Notes de mise à jour
Moodle 2.6.3 12 mai 2014 2013111803 Notes de mise à jour
Moodle 2.6.4 14 juillet 2014 2013111804 Notes de mise à jour
Moodle 2.6.5 8 septembre 2014 2013111805 Notes de mise à jour
Moodle 2.6.6 10 novembre 2014 2013111806 Notes de mise à jour
Moodle 2.6.7 12 janvier 2015 2013111807 Notes de mise à jour
Moodle 2.6.8 2 février 2015 2013111808 Notes de mise à jour
Moodle 2.6.9 9 mars 2015 2013111809 Notes de mise à jour
Moodle 2.6.10 10 mars 2015 2013111810 Notes de mise à jour
Moodle 2.6.11 11 mai 2015 2013111811 Notes de mise à jour
Moodle 2.6.11+ 18 juin 2015 2013111811.01 Dernières modifications
Les bogues de la branche 2.6.x ont été corrigés jusqu'au 10 novembre 2014 (12 mois).
Les correctifs de sécurité de la branche 2.6.x ont été assurés jusqu'au 11 mai 2015 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.6.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.7.20, puis mettre à jour vers une version récente et maintenue.

Moodle 2.5

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.5 sur une seule page, et les instructions de Mise à jour vers Moodle 2.5.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.5 14 mai 2013 2013051400 Notes de mise à jour
Moodle 2.5.1 8 juillet 2013 2013051401 Notes de mise à jour
Moodle 2.5.2 9 septembre 2013 2013051402 Notes de mise à jour
Moodle 2.5.3 11 novembre 2013 2013051403 Notes de mise à jour
Moodle 2.5.4 13 janvier 2014 2013051404 Notes de mise à jour
Moodle 2.5.5 10 mars 2014 2013051405 Notes de mise à jour
Moodle 2.5.6 12 mai 2014 2013051406 Notes de mise à jour
Moodle 2.5.7 14 juillet 2014 2013051407 Notes de mise à jour
Moodle 2.5.8 8 septembre 2014 2013051408 Notes de mise à jour
Moodle 2.5.9 10 novembre 2014 2013051409 Notes de mise à jour
Les bogues de la branche 2.5.x ont été corrigés jusqu'en mai 2014 (12 mois).
Les correctifs de sécurité de la branche 2.5.x ont été assurés jusqu'au 10 novembre 2014 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.5.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.7.20, puis mettre à jour vers une version récente et maintenue.

Moodle 2.4

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.4 sur une seule page, et les instructions de Mise à jour vers Moodle 2.4.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.4 3 décembre 2012 2012120300 Notes de mise à jour
Moodle 2.4.1 14 janvier 2013 2012120301 Notes de mise à jour
Moodle 2.4.2 11 mars 2013 2012120302 Notes de mise à jour
Moodle 2.4.3 18 mars 2013 2012120303 Notes de mise à jour
Moodle 2.4.4 14 mai 2013 2012120304 Notes de mise à jour
Moodle 2.4.5 8 juillet 2013 2012120305 Notes de mise à jour
Moodle 2.4.6 9 septembre 2013 2012120306 Notes de mise à jour
Moodle 2.4.7 11 novembre 2013 2012120307 Notes de mise à jour
Moodle 2.4.8 13 janvier 2014 2012120308 Notes de mise à jour
Moodle 2.4.9 10 mars 2014 2012120309 Notes de mise à jour
Moodle 2.4.10 12 mai 2014 2012120310 Notes de mise à jour
Moodle 2.4.11 14 juillet 2014 2012120311 Notes de mise à jour
Les bogues de la branche 2.4.x ont été corrigés jusqu'à fin décembre 2013 (12 mois).
Les correctifs de sécurité de la branche 2.4.x ont été assurés jusqu'en juin 2014 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.4.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.7.20, puis mettre à jour vers une version récente et maintenue.

Moodle 2.3

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.3 sur une seule page, et les instructions de Mise à jour vers Moodle 2.3.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.3 25 juin 2012 2012062500 Notes de mise à jour
Moodle 2.3.1 9 juillet 2012 2012062501 Notes de mise à jour
Moodle 2.3.2 10 septembre 2012 2012062502 Notes de mise à jour
Moodle 2.3.3 12 novembre 2012 2012062503 Notes de mise à jour
Moodle 2.3.4 14 janvier 2013 2012062504 Notes de mise à jour
Moodle 2.3.5 11 mars 2013 2012062505 Notes de mise à jour
Moodle 2.3.6 18 mars 2013 2012062506 Notes de mise à jour
Moodle 2.3.7 14 mai 2013 2012062507 Notes de mise à jour
Moodle 2.3.8 8 juillet 2013 2012062508 Notes de mise à jour
Moodle 2.3.9 9 septembre 2013 2012062509 Notes de mise à jour
Moodle 2.3.10 11 novembre 2013 2012062510 Notes de mise à jour
Moodle 2.3.11 13 janvier 2014 2012062511 Notes de mise à jour
Les bogues de la branche 2.3.x ont été corrigés jusqu'à fin juin 2013 (12 mois).
Les correctifs de sécurité de la branche 2.3.x ont été assurés jusqu'à fin décembre 2013 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.3.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.7.20, puis mettre à jour vers une version récente et maintenue.

Moodle 2.2

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.2 sur une seule page, et les instructions de Mise à jour vers Moodle 2.2.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.2 5 décembre 2011 2011120500 Notes de mise à jour
Moodle 2.2.1 9 janvier 2012 2011120501 Notes de mise à jour
Moodle 2.2.2 12 mars 2012 2011120502 Notes de mise à jour
Moodle 2.2.3 14 mai 2012 2011120503 Notes de mise à jour
Moodle 2.2.4 9 juillet 2012 2011120504 Notes de mise à jour
Moodle 2.2.5 10 septembre 2012 2011120505 Notes de mise à jour
Moodle 2.2.6 12 novembre 2012 2011120506 Notes de mise à jour
Moodle 2.2.7 14 janvier 2013 2011120507 Notes de mise à jour
Moodle 2.2.8 11 mars 2013 2011120508 Notes de mise à jour
Moodle 2.2.9 18 mars 2013 2011120509 Notes de mise à jour
Moodle 2.2.10 14 mai 2013 2011120510 Notes de mise à jour
Moodle 2.2.11 8 juillet 2013 2011120511 Notes de mise à jour
Les bogues de la branche 2.2.x ont été corrigés jusqu'à fin décembre 2012 (12 mois).
Les correctifs de sécurité de la branche 2.2.x ont été assurés jusqu'en juin 2013 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.2.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.2.11, puis Moodle 2.7.20, , puis vers une version récente et maintenue.

Moodle 2.1

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.1 sur une seule page, et les instructions de Mise à jour vers Moodle 2.1.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.1 1er juillet 2011 2011070100 Notes de mise à jour
Moodle 2.1.1 1er août 2011 2011070101 Notes de mise à jour
Moodle 2.1.2 10 octobre 2011 2011070102 Notes de mise à jour
Moodle 2.1.3 28 novembre 2011 2011070103 Notes de mise à jour
Moodle 2.1.4 9 janvier 2012 2011070104 Notes de mise à jour
Moodle 2.1.5 12 mars 2012 2011070105 Notes de mise à jour
Moodle 2.1.6 14 mai 2012 2011070106 Notes de mise à jour
Moodle 2.1.7 9 juillet 2012 2011070107 Notes de mise à jour
Moodle 2.1.8 10 septembre 2012 2011070108 Notes de mise à jour
Moodle 2.1.9 12 novembre 2012 2011070109 Notes de mise à jour
Moodle 2.1.10 14 janvier 2013 2011070110 Notes de mise à jour
Les bogues de la branche 2.1.x ont été corrigés jusqu'à fin juin 2012 (12 mois).
Les correctifs de sécurité de la branche 2.1.x ne sont plus assurés depuis décembre 2012 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.1.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.2.11, puis Moodle 2.7.20, , puis vers une version récente et maintenue.

Moodle 2.0

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 2.0 sur une seule page, et les instructions de Mise à jour vers Moodle 2.0.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 2.0 24 novembre 2010 2010112400 Notes de mise à jour
Moodle 2.0.1 25 décembre 2010 2010122500 Notes de mise à jour
Moodle 2.0.2 21 février 2011 2011022100 Notes de mise à jour
Moodle 2.0.3 5 mai 2011 2011033003 Notes de mise à jour
Moodle 2.0.4 1er août 2011 2011033004 Notes de mise à jour
Moodle 2.0.5 10 octobre 2011 2011033005 Notes de mise à jour
Moodle 2.0.6 28 novembre 2011 2011033006 Notes de mise à jour
Moodle 2.0.7 9 janvier 2012 2011033007 Notes de mise à jour
Moodle 2.0.8 12 mars 2012 2011033008 Notes de mise à jour
Moodle 2.0.9 14 mai 2012 2011033009 Notes de mise à jour
Moodle 2.0.10 9 juillet 2012 2011033010 Notes de mise à jour
Les bogues de la branche 2.0.x ne sont plus corrigés depuis fin décembre 2011 (le support a duré 1 an).
Les correctifs de sécurité de la branche 2.0.x ne sont plus assurés depuis juin 2012 (18 mois).
Le support de cette branche est terminé !
Si vous utilisez Moodle 2.0.x (ou antérieur), vous devriez mettre à jour vers Moodle 2.2.11, puis Moodle 2.7.20, puis vers une version récente et maintenue.

Moodle 1.9

Vous pouvez consulter la totalité des notes de mise à jour de la branche Moodle 1.9 sur une seule page, et les instructions de Mise à jour vers Moodle 1.9.x (si vous utilisez une version antérieure).

Version Date de sortie Numéro de version Notes de mise à jour
Moodle 1.9 3 mars 2008 2007101509 Notes de mise à jour
Moodle 1.9.1 15 mai 2008 2007101512 Notes de mise à jour
Moodle 1.9.2 11 juillet 2008 2007101520 Notes de mise à jour
Moodle 1.9.3 15 octobre 2008 2007101530 Notes de mise à jour
Moodle 1.9.4 28 janvier 2009 2007101540 Notes de mise à jour
Moodle 1.9.5 13 mai 2009 2007101550 Notes de mise à jour
Moodle 1.9.6 21 octobre 2009 2007101560 Notes de mise à jour
Moodle 1.9.7 25 novembre 2009 2007101570 Notes de mise à jour
Moodle 1.9.8 25 mars 2010 2007101580.00 Notes de mise à jour
Moodle 1.9.9 8 juin 2010 2007101590.00 Notes de mise à jour
Moodle 1.9.10 25 octobre 2010 2007101591.00 Notes de mise à jour
Moodle 1.9.11 21 février 2011 2007101591.02 Notes de mise à jour
Moodle 1.9.12 10 mai 2011 2007101591.03 Notes de mise à jour
Moodle 1.9.13 1er août 2011 2007101591.04 Notes de mise à jour
Moodle 1.9.14 10 octobre 2011 2007101591.06 Notes de mise à jour
Moodle 1.9.15 28 novembre 2011 2007101591.07 Notes de mise à jour
Moodle 1.9.16 9 janvier 2012 2007101591.10 Notes de mise à jour
Moodle 1.9.17 12 mars 2012 2007101591.12 Notes de mise à jour
Moodle 1.9.18 14 mai 2012 2007101591.16 Notes de mise à jour
Moodle 1.9.19 9 juillet 2012 2007101592.00 Notes de mise à jour
Moodle 1.9.19+ 13 mai 2013 2007101592.05 Notes de mise à jour
Les bogues de la branche 1.9.x ne sont plus corrigés depuis fin juin 2011 (le support a duré 3 ans et demi).
Les correctifs de sécurité de la branche 1.9.x ont été assurés par Moodle HQ jusqu'en juin 2012 (support de 4 ans et demi).
Les correctifs de sécurité de la branche 1.9.x ont été assurés par Catalyst IT (partenaire Moodle) jusqu'à décembre 2013 (support de 6 ans).
Le support de cette branche est terminé !
Si vous utilisez Moodle 1.9.x, vous devriez mettre à jour vers Moodle 2.2.11, puis vers une version récente et maintenue.

Moodle 1.8

Le support de cette branche est terminé !

Moodle 1.7

Le support de cette branche est terminé !

Moodle 1.6

Le support de cette branche est terminé !

Moodle 1.5

Le support de cette branche est terminé !

Moodle 1.4

Le support de cette branche est terminé !

Moodle 1.3

  • Moodle 1.3 - 25 mai 2004
  • Moodle 1.3.1 - 4 juin 2004
  • Moodle 1.3.2 - 9 juillet 2004
  • Moodle 1.3.3 - 16 juillet 2004
  • Moodle 1.3.4 - 11 août 2004
  • Moodle 1.3.5 - 9 septembre 2004

Le support de cette branche est terminé !

Moodle 1.2

  • Moodle 1.2 - 20 mars 2004
  • Moodle 1.2.1 - 25 mars 2004

Le support de cette branche est terminé !

Moodle 1.1

  • Moodle 1.1 - 29 août 2003
  • Moodle 1.1.1 - 11 septembre 2003

Le support de cette branche est terminé !

Moodle 1.0

  • Moodle 1.0 - 20 août 2002
  • Moodle 1.0.1 - 26 août 2002
  • Moodle 1.0.2 - 2 septembre 2002
  • Moodle 1.0.3 - 5 septembre 2002
  • Moodle 1.0.4 - 10 septembre 2002
  • Moodle 1.0.5 - 27 septembre 2002
  • Moodle 1.0.6 - 26 octobre 2002
1.0.6.1 - 6 novembre
1.0.6.2 - 11 novembre
1.0.6.3 - 14 novembre
1.0.6.4 - 25 novembre
  • Moodle 1.0.7 - 9 décembre 2002
  • Moodle 1.0.8 - 7 janvier 2003
  • Moodle 1.0.9 - 30 mai 2003

Le support de cette branche est terminé !

Voir aussi

  • La planification des versions à venir.
  • Les pré-requis techniques de Moodle 3.9 sont déterminés dans MDL-65809.