Notifications de mise à jour

Si vous arrivez sur cette page suite à un avertissement lors d'une mise à jour à partir d'une version stable, il est très probable que certains changements du code source de Moodle ont été téléchargés sur votre serveur.

Si vous voulez continuer à utiliser la version stable la plus récente de Moodle, vous devez modifier votre checkout pour utiliser la branche MOODLE_3x_STABLE.

Avec Git, vous devez donc créer dans votre version une nouvelle branche locale correspondant à la branche stable distante, et passer sur cette branche.

   git branch --track local_3x_STABLE origin/MOODLE_3x_STABLE      (1)
   git checkout local_3x_STABLE                                    (2)
   git pull                                                        (3)

Il est à noter que vous pouvez dénommer votre branche locale à votre guise. Dans l'exemple ci-dessus, la branche locale s'appelle local_3x_STABLE. La ligne (1) crée la nouvelle branche locale et la fait correspondre avec la branche distante MOODLE_3x_STABLE. La ligne (2) nous place dans la nouvelle branche que nous venons de créer. À la ligne (3), la commande git pull récupère les modifications de la branche distante et les fusionne avec la branche locale. Pour mettre à jour votre installation de Moodle les prochaines fois, il suffit de lancer la commande de la ligne (3).

Pour plus d'information sur la gestion des versions de Moodle avec Git, voir la page dev:Moodle_versions (en anglais).

Voir aussi