Aktualisierung FAQ: Unterschied zwischen den Versionen

Wechseln zu: Navigation, Suche
(Kann ich bei der Aktualisierung mehrere Versionen überspringen?)
 
(5 dazwischenliegende Versionen von 2 Benutzern werden nicht angezeigt)
Zeile 1: Zeile 1:
 
{{Installation}}
 
{{Installation}}
 +
==Wie aktualisiere ich von Moodle 1.9.x auf {{Version}}?==
  
 +
1.x ->  1.9.19+ -> 2.2.11 -> 2.7.20 -> 3.0.10 -> {{Version}}
 +
 +
Es empfiehlt sich, jeweils auf die letzte stabile Version x.y.z zu aktualisieren. Dasselbe gilt für Zusatz-Plugins.
 +
 +
Moodle 2.2.11 kann hier heruntergeladen werden: https://download.moodle.org/stable22/.
  
 
==Wie aktualisiere ich Moodle? Überschreibe ich einfach die PHP-Skripte?==
 
==Wie aktualisiere ich Moodle? Überschreibe ich einfach die PHP-Skripte?==
 
Überschreiben Sie die PHP-Skripte '''nicht''' - Sie könnten Probleme bekommen: Lesen Sie den Artikel [[Aktualisierung von Moodle]], bevor Sie loslegen.
 
Überschreiben Sie die PHP-Skripte '''nicht''' - Sie könnten Probleme bekommen: Lesen Sie den Artikel [[Aktualisierung von Moodle]], bevor Sie loslegen.
  
==Ich habe auf Moodle 2 aktualisiert und vermisse zahlreiche Dateien!==
+
==Ich bekomme die Nachricht "Upgrade already running in this session, please wait!"==
Prüfen Sie, ob die Dateien auch im alten Moodle 1.9 fehlen.
+
Wahrscheinlich haben Sie die Seite neu aufgerufen, bevor die Nachricht über den erfolgreichen Abschluss der Aktualisierung angezeigt wurde. Wenn Sie ganz sicher sind, dass kein Aktualisierungsprozess läuft, dann klicken Sie auf "!!!" und starten Sie den Aktualisierungsprozess erneut.
 +
 
 +
''Hinweis'': Wenn Sie auf "'!!!" klicken oder den Aktualisierungsprozess in einem anderen Browser neu starten, dann kann es passieren, dass die Daten in Ihrer Moodle-Datenbank beschädigt werden. Wenn das passiert, müssen Sie die Sicherung Ihrer Datenbank (MySQL-Dump) wieder einspielen (also den Zustand von Moodle vor der Aktualisierung). Anschließend können Sie die Aktualisierung neu starten.
  
 
==Kann ich bei der Aktualisierung mehrere Versionen überspringen?==
 
==Kann ich bei der Aktualisierung mehrere Versionen überspringen?==
 +
Sie können nur von Moodle 3.0 oder neuer auf Moodle {{Version}} aktualisieren.
 +
 +
Sie können nur von Moodle 2.2 oder neuer auf Moodle 2.7 aktualisieren.
 +
 +
Sie können nur von Moodle 1.9 oder neuer auf Moodle 2.2 aktualisieren.
 +
 +
==Ich habe angepassten Code in meiner Moodle-Site. Wie aktualisiere ich Moodle in diesem Fall?==
 +
Lesen Sie diesen [https://moodle.org/mod/forum/discuss.php?d=263355#p1141326 Forumsbeitrag] - dort finden Sie ein paar Vorschläge.
 +
 +
==Siehe auch==
 +
 +
* [[Installation FAQ]]
  
Siehe [[Aktualisierung von Moodle#Mehrere Versionen bei der Aktualisierung überspringen|Mehrere Versionen bei der Aktualisierung überspringen]].
 
  
  
Zeile 16: Zeile 35:
  
 
[[en:Upgrading FAQ]]
 
[[en:Upgrading FAQ]]
 +
[[es:Actualización FAQ]]
 +
[[fr:FAQ de mise à jour]]
 +
[[ja:アップグレードFAQ]]

Aktuelle Version vom 11. Februar 2019, 15:33 Uhr

Wie aktualisiere ich von Moodle 1.9.x auf 3.9?

1.x -> 1.9.19+ -> 2.2.11 -> 2.7.20 -> 3.0.10 -> 3.9

Es empfiehlt sich, jeweils auf die letzte stabile Version x.y.z zu aktualisieren. Dasselbe gilt für Zusatz-Plugins.

Moodle 2.2.11 kann hier heruntergeladen werden: https://download.moodle.org/stable22/.

Wie aktualisiere ich Moodle? Überschreibe ich einfach die PHP-Skripte?

Überschreiben Sie die PHP-Skripte nicht - Sie könnten Probleme bekommen: Lesen Sie den Artikel Aktualisierung von Moodle, bevor Sie loslegen.

Ich bekomme die Nachricht "Upgrade already running in this session, please wait!"

Wahrscheinlich haben Sie die Seite neu aufgerufen, bevor die Nachricht über den erfolgreichen Abschluss der Aktualisierung angezeigt wurde. Wenn Sie ganz sicher sind, dass kein Aktualisierungsprozess läuft, dann klicken Sie auf "!!!" und starten Sie den Aktualisierungsprozess erneut.

Hinweis: Wenn Sie auf "'!!!" klicken oder den Aktualisierungsprozess in einem anderen Browser neu starten, dann kann es passieren, dass die Daten in Ihrer Moodle-Datenbank beschädigt werden. Wenn das passiert, müssen Sie die Sicherung Ihrer Datenbank (MySQL-Dump) wieder einspielen (also den Zustand von Moodle vor der Aktualisierung). Anschließend können Sie die Aktualisierung neu starten.

Kann ich bei der Aktualisierung mehrere Versionen überspringen?

Sie können nur von Moodle 3.0 oder neuer auf Moodle 3.9 aktualisieren.

Sie können nur von Moodle 2.2 oder neuer auf Moodle 2.7 aktualisieren.

Sie können nur von Moodle 1.9 oder neuer auf Moodle 2.2 aktualisieren.

Ich habe angepassten Code in meiner Moodle-Site. Wie aktualisiere ich Moodle in diesem Fall?

Lesen Sie diesen Forumsbeitrag - dort finden Sie ein paar Vorschläge.

Siehe auch