Revision as of 01:48, 17 January 2020 by Elizabeth Dalton (talk | contribs) (created page for this error, which I encountered while upgrading a local site to the latest version of master from a pre-release version of 3.8)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

You may see an error if you have installed the Python learning analytics backend, but the version of Moodle you are using requires a more recent backend. From a shell, do this:

$ sudo -H python3 -m pip install "moodlemlbackend==2.4.*"
Collecting moodlemlbackend==2.4.*
Installing collected packages: moodlemlbackend
  Found existing installation: moodlemlbackend 2.3.0
    Uninstalling moodlemlbackend-2.3.0:
      Successfully uninstalled moodlemlbackend-2.3.0
Successfully installed moodlemlbackend-2.4.0

Check the documentation for the correct version of moodlemlbackend to install for your version of Moodle.