Difference between revisions of "error/analytics/errorprocessornotready"

Jump to: navigation, search
(created page for this error, which I encountered while upgrading a local site to the latest version of master from a pre-release version of 3.8)
 
m (Added link to Spanish page)
 
Line 13: Line 13:
  
 
Check the documentation for the correct version of moodlemlbackend to install for your version of Moodle.
 
Check the documentation for the correct version of moodlemlbackend to install for your version of Moodle.
 +
 +
[[es:error/analytics/errorprocessornotready]]

Latest revision as of 16:13, 17 January 2020

You may see an error if you have installed the Python learning analytics backend, but the version of Moodle you are using requires a more recent backend. From a shell, do this:

$ sudo -H python3 -m pip install "moodlemlbackend==2.4.*"
Collecting moodlemlbackend==2.4.*
...
Installing collected packages: moodlemlbackend
  Found existing installation: moodlemlbackend 2.3.0
    Uninstalling moodlemlbackend-2.3.0:
      Successfully uninstalled moodlemlbackend-2.3.0
Successfully installed moodlemlbackend-2.4.0

Check the documentation for the correct version of moodlemlbackend to install for your version of Moodle.