Difference between revisions of "Using slash arguments"

Jump to: navigation, search
(About slash arguments (info copied from MDL-50182))
m (Added a mention to MDL-51554)
Line 30: Line 30:
 
* [https://moodle.org/mod/forum/discuss.php?d=278916 Requiring slasharguments in Moodle 2.9 - will anybody be seriously affected?] forum discussion
 
* [https://moodle.org/mod/forum/discuss.php?d=278916 Requiring slasharguments in Moodle 2.9 - will anybody be seriously affected?] forum discussion
 
* [https://tracker.moodle.org/browse/MDL-50416 <nowiki>[MDL-50416]</nowiki> slasharguments check gives a warning on install], for versions 2.9 and 2.9.1
 
* [https://tracker.moodle.org/browse/MDL-50416 <nowiki>[MDL-50416]</nowiki> slasharguments check gives a warning on install], for versions 2.9 and 2.9.1
 +
* [https://tracker.moodle.org/browse/MDL-51554 <nowiki>[MDL-51554]</nowiki> Broken file serving under Apache and PHP-FPM via mod_proxy_fcgi, when the filename is not only plain ASCII or w/ blank spaces], for versions below  2.8.9 and 2.9.3
  
 
[[es:Usando slash arguments]]
 
[[es:Usando slash arguments]]

Revision as of 22:06, 28 October 2015

About slash arguments

'Slash arguments' (using PATH_INFO) is required for SCORM packages and multiple-file resources to display correctly. If your web server doesn't support 'slash arguments' and you are unable to configure it, the setting can be disabled, though it will result in things not working.

Enabling slash arguments

Slash arguments must be enabled on your web server, as described in:

Error when uploading a file

If you obtain a 'File not found' error when uploading a file, it indicates that slash arguments are not enabled on your web server. Please try enabling it.

If your web server doesn't support slash arguments, its use in Moodle can be disabled by un-ticking the checkbox 'Use slash arguments' in Administration > Site administration > Server > HTTP.

Warning: Disabling the use of slash arguments will result in SCORM packages not working and slash arguments warnings being displayed!

Slash arguments environment check

Note: The use of slash arguments will be required in future versions of Moodle.

If your web server doesn't support slash arguments, you will in future need to change to a web server which does. (It will no longer be possible to disable the use of slash arguments.)

In the meantime, Administration > Site administration > Server > Environment reports if the slash argument setting needs to be checked i.e. if it is detected that 'Use slash arguments' is disabled in Administration > Site administration > Server > HTTP. Thus, the check is a warning of the future requirement.

See also