Difference between revisions of "error/debug/cannotdowngrade"

Jump to: navigation, search
(initial stub)
 
(Error condition)
Line 1: Line 1:
==Error condition==
+
This error occurs when a new version of a plugin has been installed at some point and then has been replace by an older version of the same plugin.  
It seems that this error take place when [[upgrading]] under certain circumstances, and a module or a block in the older version is newer than the module contained at the newer version upgraded to.
 
  
the newer version of [[Moodle]] may adapt a certain [[plugin]] that isn't included at the previous version [[standard pakage]], but mostly widely used [[messages block]] for example at V2.0.0 whith is not standard at V1.9.x, and more likely for Moodle core team to adapt a certain version of the module not the last one. in this case the connotdowngrade error might happen.
+
In this scenario you need to determine what has caused this to happen. It might be that you've accidentally tried to install a version compatible with older versions of Moodle.
  
 
==what to do==
 
==what to do==
 
simpliest action is to remove the module folder and continue upgrading
 
simpliest action is to remove the module folder and continue upgrading

Revision as of 12:22, 16 April 2013

This error occurs when a new version of a plugin has been installed at some point and then has been replace by an older version of the same plugin.

In this scenario you need to determine what has caused this to happen. It might be that you've accidentally tried to install a version compatible with older versions of Moodle.

what to do

simpliest action is to remove the module folder and continue upgrading