Difference between revisions of "Talk:Certificate customizing"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.6. Up-to-date documentation for the latest stable version of Moodle is likely available here: Certificate customizing.

(Added this page to discuss potential 2.7 certificate customization)
 
m (Certificate compatibility in 2.7: mod_certificate_moodle27_2014041800 version. Hooray!)
 
Line 3: Line 3:
  
 
===Certificate compatibility in 2.7===
 
===Certificate compatibility in 2.7===
Since I am  interested in using Moodle 2.7,  I want to see if I can find a version of certificate code that works.  The plugin downpage only talks about 2.6.  I have quickly check that and for my purposes, it will work.  However, at this moment I have just created a clean install of 2.7 on what will be my production server.  I will be back to update the  documentation based upon by experiences --[[User:chris collman|chris collman]] ([[User talk:chris collman|talk]]) 21:57, 17 June 2014 (WST)
+
Since I am  interested in using Moodle 2.7,  I want to see if I can find a version of certificate code that works.  The plugin downpage only talks about 2.6.  I have quickly check that and for my purposes, it will work.  However, at this moment I have just created a clean install of 2.7 on what will be my production server.  I will be back to update the  documentation based upon by experiences--[[User:chris collman|chris collman]] ([[User talk:chris collman|talk]]) 21:57, 17 June 2014 (WST)
 +
 
 +
:Notice that Mark  has  created a mod_certificate_moodle27_2014041800 version. Hooray!--[[User:chris collman|chris collman]] ([[User talk:chris collman|talk]]) 22:04, 17 June 2014 (WST)
  
 
===File system impact on documentation===
 
===File system impact on documentation===

Latest revision as of 14:04, 17 June 2014

Update customization for 2.6 maybe will work for 2.7

I think I updated this page for a Moodle 1.9.9 many years ago. Now I am now figuring out how to upgrade to 2.6 and customize a certificate that works in 2.6. There are lots of changes, so I will take them one at a time as I find them. Others are welcome to add to my comments below, please sign them.

Certificate compatibility in 2.7

Since I am interested in using Moodle 2.7, I want to see if I can find a version of certificate code that works. The plugin downpage only talks about 2.6. I have quickly check that and for my purposes, it will work. However, at this moment I have just created a clean install of 2.7 on what will be my production server. I will be back to update the documentation based upon by experiences--chris collman (talk) 21:57, 17 June 2014 (WST)

Notice that Mark has created a mod_certificate_moodle27_2014041800 version. Hooray!--chris collman (talk) 22:04, 17 June 2014 (WST)

File system impact on documentation

I assume that the Certificate code was changed to work with the 2.x file system. The "legacy" images such as mod/certificate/pix are probably used at the time of install (notification link) as the default and "hidden" via a hash file. I don't see how to delete the default images in 2.6, certainly changing files in the ../pix folder does not have an effect in the image options. Users can only add to the images that appear on the list. Humm, to do is if I can delete an image file that has been uploaded via the site admin menu system.--chris collman (talk) 21:57, 17 June 2014 (WST)

Customizing certificate type code in 2.2

I have not played with the certificate code for 2.6. Please note my goal is to upgrade my 1.9.9 site to the highest and longest supported Moodle version (2.7, not 2.6). See the certificate compatibility in 2.7 section, and stay tuned for more comments.--chris collman (talk) 21:57, 17 June 2014 (WST)