Difference between revisions of "admin/environment/php"

Jump to: navigation, search
m (added info for M2.1 and generalized info for M2.0)
m
Line 2: Line 2:
  
 
* Moodle 2.1 will require PHP 5.3.2 or later
 
* Moodle 2.1 will require PHP 5.3.2 or later
* Moodle 2.0 will require PHP 5.2.8 or later. However PHP 5.3.x is recommended
+
* Moodle 2.0 requires PHP 5.2.8 or later. However PHP 5.3.x is recommended
 
* Moodle 1.6 to 1.9 requires PHP 4.3.0 or later
 
* Moodle 1.6 to 1.9 requires PHP 4.3.0 or later
 
* Moodle 1.0 to 1.5 requires PHP 4.1.0 or later
 
* Moodle 1.0 to 1.5 requires PHP 4.1.0 or later

Revision as of 07:58, 29 March 2011

Moodle has different PHP requirements for different versions:

  • Moodle 2.1 will require PHP 5.3.2 or later
  • Moodle 2.0 requires PHP 5.2.8 or later. However PHP 5.3.x is recommended
  • Moodle 1.6 to 1.9 requires PHP 4.3.0 or later
  • Moodle 1.0 to 1.5 requires PHP 4.1.0 or later

See also