Difference between revisions of "Oracle"

Jump to: navigation, search
Line 1: Line 1:
 
{{Installing Moodle}}
 
{{Installing Moodle}}
The Oracle database server is not fully supported, there are known issues. Please use other database if possible.
+
 
 +
Moodle will technically work on Oracle, as it's supported by our database framework and it passes our basic unit testing.
 +
 
 +
However, we do not recommend it for any new installations because it is generally slow, and hardly any Moodle developers use it for development.
 +
 
 +
Unless you are being forced somehow to use Oracle, we recommend Postgres or MariaDB for new Moodle installations.
  
 
== See also ==
 
== See also ==

Revision as of 09:06, 6 April 2017


Moodle will technically work on Oracle, as it's supported by our database framework and it passes our basic unit testing.

However, we do not recommend it for any new installations because it is generally slow, and hardly any Moodle developers use it for development.

Unless you are being forced somehow to use Oracle, we recommend Postgres or MariaDB for new Moodle installations.

See also