Difference between revisions of "Installation FAQ"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.2. Up-to-date documentation for the latest stable version of Moodle is probably available here: Installation FAQ.

(PHP - is it installed and what version do I have?)
(Why are all my pages blank?)
Line 30: Line 30:
  
 
== Why are all my pages blank? ==
 
== Why are all my pages blank? ==
 +
 +
Check the dirroot variable in config.php. You must use complete, absolute pathnames, eg:
 +
 +
$CFG->dirroot = "d:\inetpub\sites\www.yoursite.com\web\moodle";
 +
 +
Redhat Linux platform please see: [[Installing_Apache%2C_MySQL_and_PHP#Redhat_Linux|Redhat Linux]]
  
 
== My pages show fatal errors such as : call to undefined function: get_string() ==
 
== My pages show fatal errors such as : call to undefined function: get_string() ==

Revision as of 19:13, 2 July 2005

This page contains answers to some of the most frequently asked questions by people installing Moodle. If you have followed the installation instructions but you still have a problem, then this page is probably the best place to be.

If you don't find your answer here try the Using Moodle course on moodle.org. Start by searching the forums using a few keywords, in case your problem has already been discussed. If you don't find anything, then try posting your question into the appropriate forum - somebody will usually be able to help you.

If you have tried a number of solutions without resolving an issue, and you are running behind a firewall, it may be advisable to try re-configuring your firewall to ensure that it is not blocking a required function or necessary communication. Firewalls very rarely cause problems with Moodle but are occasionally responsible for reduced functionality due to a mis-configuration in the firewall settings.

Use this list to jump to the appropriate answer below:

Whenever I try to access or view a file that I uploaded, I get an error "File not Found"

For example: Not Found: The requested URL /moodle/file.php/2/myfile.jpg was not found on this server.

Your web server needs to be configured to allow the part of the URL after a script name to be passed directly to the script. This is usually enabled in Apache 1, but is usually disabled by default in Apache 2. To turn it on, add this line to your httpd.conf, or to a .htaccess file in your local directory (see the Install documentation for more details):

AcceptPathInfo on

Note, this will ONLY work for Apache versions 2.x.

If you are not using Apache 2 and you still have this problem (unlikely) then you can switch Moodle to use an alternative method. The disadvantages are a slight loss of performance for your users and you won't be able to use relative links within HTML resources.

To use this alternative method: login as Admin, go into the "Configure Variables" page and change the setting for "slasharguments". You should now be able to access your uploaded files.

PHP - is it installed and what version do I have?

Make a new file on your web site called info.php, containing the following text, and call it from your browser:

<?PHP phpinfo() ?>

If nothing happens then you don't have PHP installed. See the installation docs for some information about where to download it for your computer.

Why are all my pages blank?

Check the dirroot variable in config.php. You must use complete, absolute pathnames, eg:

$CFG->dirroot = "d:\inetpub\sites\www.yoursite.com\web\moodle";

Redhat Linux platform please see: Redhat Linux

My pages show fatal errors such as : call to undefined function: get_string()

Why do I keep getting error messages about "headers already sent"?

I keep getting this error: Failed opening required '/web/moodle/lib/setup.php'

Any text I add with an apostrophe (') or a quote (") causes errors or comes up with a slash added

I keep getting error messages about session_start

When I go to the admin page, I get told to make dirroot blank!

I login but the login link doesn't change. I am logged in and can navigate freely.

When trying to add a resource I receive error messages.

During the initial setting-up process, I never get asked to create an admin account!

I can't log in - I just stay stuck on the login screen.

How do I backup my whole Moodle site?

Why doesn't my Moodle site display the time & date correctly?

Email copies are not being sent from my forums