Difference between revisions of "Installation FAQ"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.2. Up-to-date documentation for the latest stable version of Moodle is probably available here: Installation FAQ.

 
Line 6: Line 6:
  
 
Use this list to jump to the appropriate answer below:
 
Use this list to jump to the appropriate answer below:
__TOC__
 
  
 
== Whenever I try to access or view a file that I uploaded, I get an error "File not Found" ==
 
== Whenever I try to access or view a file that I uploaded, I get an error "File not Found" ==
Line 21: Line 20:
  
 
== Any text I add with an apostrophe (') or a quote (") causes errors or comes up with a slash added ==
 
== Any text I add with an apostrophe (') or a quote (") causes errors or comes up with a slash added ==
 +
 +
== I keep getting error messages about session_start ==
 +
 +
== When I go to the admin page, I get told to make dirroot blank! ==
 +
 +
== I login but don't appear to be. I am logged in and can navigate freely. ==
 +
 +
== When trying to add a resource I receive error messages. ==
 +
 +
== During the initial setting-up process, I never get asked to create an admin account! ==
 +
 +
== I can't log in - I just stay stuck on the login screen. ==
 +
 +
== How do I backup my whole Moodle site? ==
 +
 +
== Why doesn't my Moodle site display the time & date correctly? ==
 +
 +
== Email copies are not being sent from my forums ==

Revision as of 19:06, 2 July 2005

This page contains answers to some of the most frequently asked questions by people installing Moodle. If you have followed the installation instructions but you still have a problem, then this page is probably the best place to be.

If you don't find your answer here try the Using Moodle course on moodle.org. Start by searching the forums using a few keywords, in case your problem has already been discussed. If you don't find anything, then try posting your question into the appropriate forum - somebody will usually be able to help you.

If you have tried a number of solutions without resolving an issue, and you are running behind a firewall, it may be advisable to try re-configuring your firewall to ensure that it is not blocking a required function or necessary communication. Firewalls very rarely cause problems with Moodle but are occasionally responsible for reduced functionality due to a mis-configuration in the firewall settings.

Use this list to jump to the appropriate answer below:

Whenever I try to access or view a file that I uploaded, I get an error "File not Found"

PHP - is it installed and what version do I have?

Why are all my pages blank?

My pages show fatal errors such as : call to undefined function: get_string()

Why do I keep getting error messages about "headers already sent"?

I keep getting this error: Failed opening required '/web/moodle/lib/setup.php'

Any text I add with an apostrophe (') or a quote (") causes errors or comes up with a slash added

I keep getting error messages about session_start

When I go to the admin page, I get told to make dirroot blank!

I login but don't appear to be. I am logged in and can navigate freely.

When trying to add a resource I receive error messages.

During the initial setting-up process, I never get asked to create an admin account!

I can't log in - I just stay stuck on the login screen.

How do I backup my whole Moodle site?

Why doesn't my Moodle site display the time & date correctly?

Email copies are not being sent from my forums