Difference between revisions of "Publishflow Block : Requirements"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 3.0. Up-to-date documentation for the latest stable version of Moodle may be available here: Publishflow Block : Requirements.

m
 
(3 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
[[Course Publishing block (publishflow)|Back to index]]
 
[[Course Publishing block (publishflow)|Back to index]]
  
===XMLRPC Handling by blocks===
+
All dependencies to other components have been removed.
 
 
The Publishflow block makes an important use of MNET RPC calls at block level.
 
 
 
Running the Publishflow architecture needs to add an identified patch called : extending RPC handling to blocks in Moodle 1.9. This handling is implemented in Moodle 2.0.
 
 
 
Tracker reference is : http://tracker.moodle.org/browse/MDL-23194
 
 
 
===User Mnet Hosts block===
 
 
 
In its actual version, the publish flow uses the blocks/user_mnet_hosts (non standard)
 
block as basic policy to allow or not allow course deployment.
 
 
 
(That is, a user need tohave a granted access to a MNET remote host to be able to deploy
 
or publish).
 
 
 
This was used in some projects.
 
 
 
We should provide a further version that avoid this cross dependancy.
 

Latest revision as of 21:26, 28 September 2012

Back to index

All dependencies to other components have been removed.