Difference between revisions of "Upgrading to Moodle 2.3"

Jump to: navigation, search

Note: You are currently viewing documentation for Moodle 2.5. Up-to-date documentation for the latest stable version of Moodle may be available here: Upgrading to Moodle 2.3.

(Fix browser requirements)
(System requirements)
Line 17: Line 17:
 
** Firefox 4 or later
 
** Firefox 4 or later
 
** Safari 5 or later  
 
** Safari 5 or later  
** Google Chrome 4 or later
+
** Google Chrome 11 or later
 
** Opera 9 or later
 
** Opera 9 or later
 
** MS Internet Explorer 8 or later
 
** MS Internet Explorer 8 or later

Revision as of 17:23, 6 June 2012

Note: You can only upgrade to Moodle 2.3 from Moodle 2.2 or later.

We advise that you test the upgrade first on a COPY of your production site, to make sure it works as you expect.

System requirements

  • PHP must be 5.3.2 or later
    • Required PHP extensions: iconv, curl, ctype, zip, simplexml, spl, pcre, dom, xml, json
    • Required PHP memory_limit at least 40MB (64MB or more recommended if you have a choice)
  • Databases should be one of the following:
    • MySQL 5.0.25 or later (InnoDB storage engine highly recommended)
    • PostgreSQL 8.3 or later
    • Oracle 10.2 or later
    • MS SQL 2005 or later
  • Any standards-supporting browser from the past few years, for example:
    • Firefox 4 or later
    • Safari 5 or later
    • Google Chrome 11 or later
    • Opera 9 or later
    • MS Internet Explorer 8 or later

Note: The above server requirements are unchanged from Moodle 2.1.

Before upgrading please...

NOTE: The upgrade process will irreversibly modify the contents of your database and your moodledata file storage area. If something goes wrong you cannot go back. It is vital that you take good backups of both moodledata and the database in case you have problems with the upgrade. If you are not sure how see Site backup or ask in the moodle.org forums (explaining what your operating system is).

  • Read the Moodle 2.3 release notes and check the list of new features
  • Check your site to make sure it meets all system requirements for 2.3 in Settings > Site administration > Server > Environment
  • Do a full database backup!
  • Do a full moodledata backup
  • Check your backups carefully
  • Remember to purge PHP cache if using any PHP accelerator

Possible issues that may affect you

Two assignment modules

A new assignment module has been added in Moodle 2.3. The old assignment module is still available and sites which have upgraded from previous versions will have both versions available.

Please add items here...

Checking database schema - old sites

If your Moodle site has been upgraded through many prior versions it is possible that there will be some problems with the database schema (compared to a fresh 2.0 installation). This may cause the upgrade to fail. If your site started life prior to Moodle 2.0 it is a very good idea to check and correct the database schema before upgrading. See Verify Database Schema. You should also run the database integrity checks in the XMLDB editor, see the 'See also' for a link to extra scripts to check for other discrepancies.

Now upgrade

Once you have satisfied the requirements for Moodle 2.3, follow the instructions on the upgrading page.

On Linux servers, Moodle 2.3 supports running the upgrade from the command line, rather than through a web browser. This is likely to be more reliable, particularly for large sites.

After upgrade

The config.php file from your 2.0 installation should work fine but if you take a look at config-dist.php that came with Moodle 2.0 there are more/different options available (e.g. database drivers and settings). It's a good idea to map your old config.php settings to a new one based on the 2.3 config-dist.php.

See also